Fórum Debian

Versão Completa: Instalação do skype - Parte III
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Boa tarde, galera do FD!

Há tempos eu estou tentando instalar (e fazer funcionar) o skype no meu trabalho..
Minha saga pode ser acompanhada nos tópicos http://www.forumdebian.com.br/topico-13 ... highlight=
e http://www.forumdebian.com.br/topico-92 ... highlight=

Pois bem, consegui fazer o danado funcionar.... mas só em dois pcs...o problema é que mexi em tanta coisa que não sei qual foi a que realmente funcionou....rsrsrs

Bom, considerando que tenho outros pcs na mesma sala, usando o mesmo
servidor, com o mesmo dhcp, etc, ect, e ainda não consegui fazer o skype funcionar neles, gostaria de saber se tem como monitorar o caminho que o meu skype faz quando está sendo executado (portas, conexões etc), para fazer uma comparação com os outros...
O que eu poderia comparar nas duas máquinas (sistema) para ver a diferença ?

Se alguém tiver mais alguma sugestão, ficarei muito agradecido.

Marcelo
Marcelo Felipe, se vc der um netstat -anp vc consegue ver qual porta o serviço esta acessando, outra coisa pode ser firewall, se vc tiver.
ljúlio, percebi duas diferenças no monitoramento das portas, mas não sei o que significam...veja:


PC que não conecta:

59/skype
tcp 0 0 127.0.0.1:2453 0.0.0.0:* OUÇA 62

259/skype
udp 0 0 10.XX.XX:137 0.0.0.0:* 6


PC que conecta:

udp 0 0 127.0.0.1:1030 0.0.0.0:* 8 556/skype


udp 0 0 0.0.0.0:3082 0.0.0.0:* 8 556/skype
udp 0 0 10.XX.XX:138 0.0.0.0:*


Será que essas diferenças podem ser acertadas manualmente?
Marcelo Felipe, talvez sim mas acho que ai deve ser alguma configuração no próprio skype, tenta comparar a configuração dos dois, talvez vc ache a diferença.
Instalei o skype no debian etch (rc1), mas não estou conseguindo conversar com as pessoas, eu consigo ouvir a pessoa falar, porém ela não me houve.

Tenho o alsamixer completamene instalado e tb tentei reconfigurar o som pelo alsaconf, mas nada feito. Tive o mesmo problema no ubuntu edgy, agora migrei para o debian e pretendo tentar solucionar esse problema.

Podem me ajudar a tentar resolver esse problema???

Placa mãe: ASUS M2N-SLI DELUXE
kernel debian:2.6.18-4-486

Obrigado.
Saiu no dia 14 de junho a versão 1.4 do skype para linux com melhoramentos http://www.skype.com/download/skype/linux/
Por ser uma versão beta pode conter bugs, pelo que li não usa mais o Oss como arquitetura de som.
a versao 1.4 naum funcionou em ksa..
depois q eu coloco usuario e senha o skype congela...
Intalei aqui e funcionou legal....mas nates, tive que instalar uma lib que tava faltando...


Citar:Descompactando substituto skype ...
dpkg: problemas de dependência impedem configuração de skype:
skype depende de libqt4-core (>= 4.2.1); porém:
O pacote libqt4-core não está instalado.
skype depende de libqt4-gui (>= 4.2.1); porém:
O pacote libqt4-gui não está instalado.
dpkg: erro processando skype (--install):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante processamento de:
skype

Marcelo:# apt-get -f install
Lendo Lista de Pacotes... Pronto
Construindo Árvore de Dependências... Pronto
Corrigindo dependências... Pronto
Os pacotes extra a seguir serão instalados:
libqt4-core libqt4-gui
Pacotes recomendados :
qt4-qtconfig
Os NOVOS pacotes a seguir serão instalados:
libqt4-core libqt4-gui
0 pacotes atualizados, 2 pacotes novos instalados, 0 a serem removidos e 573 não atualizados.
1 pacotes não totalmente instalados ou removidos.
É preciso fazer o download de 5717kB de arquivos.
Depois de desempacotamento, 14,1MB adicionais de espaço em disco serão usados.
Quer continuar [S/n] ? S
Obtendo:1 http://security.debian.org etch/updates/main libqt4-core 4.2.1-2+etch1 [1167kB]
Obtendo:2 http://security.debian.org etch/updates/main libqt4-gui 4.2.1-2+etch1 [4550kB]
Baixados 5717kB em 1m56s (48,9kB/s)
Selecionando pacote previamente não selecionado libqt4-core.
(Lendo banco de dados ... 85339 arquivos e diretórios atualmente instalados.)
Descompactando libqt4-core (de .../libqt4-core_4.2.1-2+etch1_i386.deb) ...
Selecionando pacote previamente não selecionado libqt4-gui.
Descompactando libqt4-gui (de .../libqt4-gui_4.2.1-2+etch1_i386.deb) ...
Instalando libqt4-core (4.2.1-2+etch1) ...

Instalando libqt4-gui (4.2.1-2+etch1) ...

Instalando skype (1.4.0.74-1) ...

Arquivo de configuração `/etc/dbus-1/system.d/skype.conf'
==> Arquivo no sistema criado por você ou por um script.
==> Arquivo também no pacote, fornecido pelo mantenedor dele.
O que você gostaria de fazer sobre isso ? Suas opções são:
Y ou I : instalar a versão do mantenedor do pacote
N ou O : manter sua versão atual instalada
D : mostrar as diferenças entre as versões
Z : jogar este processo para 2o plano para examinar a situação
A ação padrão é manter sua versão atual.
*** skype.conf (Y/I/N/O/D/Z) [padrão=N] ? Y
Instalando nova versão do arquivo de configuração /etc/dbus-1/system.d/skype.conf ...
Pra mim, num primeiro momento, essa versão tá muiiiiiiiito mais leve...carrega rapidinho, tem mais funcionabilidade (som, emotions, etc)...
O que não gostei é que não é possível mudar a linguagem...tá tudo em inglês.....mas o programa tá bem mais leve.....
engra'cado, no meu naum perguntou sobre esse arquivo de configuracao... vou tentar remover e instalar de novo
bom, se eu não estiver enganado, devido à falta dessa lib, o skipe não é instalado, apesar de vc mandar dpkg -i.....mas depois que vc instala a lib, a instalação do programa é automática...testa aí!!!
Estou tentando instalar o skype 2.0_i386 no debian lenny kernel 2.6.25-2 – AMD64, mas está aparecendo o seguinte erro:

#dpkg -i --force-architecture skype-debian_2.0.0.72-1_i386.deb

dpkg - aviso, ignorando problema porque --force foi habilitado:

arquitetura do pacote (i386) não combina com a do sistema (amd64)

(Lendo banco de dados ... 117843 arquivos e diretórios atualmente instalados).

Desempacotando skype (de skype-debian_2.0.0.72-1_i386.deb) ...

dpkg-deb (sub-processo): leitura curta em buffer_copy (falhou ao escrever para o "pipe" na cópia)

dpkg-deb: sub-processo paste retornou estado de saída de erro 2

dpkg: erro processando skype-debian_2.0.0.72-1_i386.deb (--install):

leitura curta em buffer_copy (mecanismo dpkg-deb durante './usr/share/skype/lang/skype_lv.qm')

Erros foram encontrados durante o processamento de:

skype-debian_2.0.0.72-1_i386.deb


A partir daí a instalação é abostada.
Os pacotes necessários foram instalados e atualizados: lib32asound2, ia32-libs-gtk, ia32-libs-kde, libqt4-core, libqt4-gui, libdbus-1-3, libsigc++-2.0-2, libxss, Qt4, D-bus e libasound2.

O que pode estar ocorrendo ??

Preciso de ajuda para resolver esse problema !!

Obrigado.
vc instalou o pacote ia32-libs ?
Sim, o pacote ia32-libs está instalado.

O problema aqui foi no download do arquivo Skype_i386.deb, por algum motivo houve um desarranjo no pacote .deb, tive que fazer o download 3 vezes para ver que o problema estava no arquivo de instalação e não nas depedências.

Muito estranho, mas é isso aí !!

O pacote está instalado e funcionando, ainda não testei o microfone, que sempre é uma fonte problemas, mas as letra no skype me parecem muito pequenas em relação ao layout de minha área de trabalho, isso eu não consegui arrumar.

Flw ... e obrigado !!
URL de Referência