Fórum Debian

Versão Completa: Grub: The file /boot/grub/stage1 not read correctly.
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
E ai galera, eu to tentando reinstalar o grub na minha mbr dps de uma formataçao e nao vai nem a pau, tipo que to acessando a particao minha que do boot no cd do slack, monto e acesso a particao que ta com o debian como root,
mount /dev/hda6 /mnt
chroot /mnt
blz, ate ai td ok, mas sempre que do o comando grub-install /dev/hda me retorna esse erro: The file /boot/grub/stage1 not read correctly.
entrei no grub e tentei da um comando root (hd0,6) e esse me retornou q o o filesystem é desconhecido mas a particao é linux. Ainda dentro do grub dei o comando find /boot/stage1 e este me retorna (hd0,5) que ja teve uma instalaçao mas que agora possui um arquivo torrent q estava baixando no debian no tamanho de um dvd e que esta quase todo baixado e nao posso perde-lo, hehehe.
Bem é isso, tentei duas soluçoes q encontrei na net e nao deram, acho q a que poderia funcionar melhor seria a primeira, que esta retornando a mensagem de erro, entao é ela quer gostaria de corrigir e tentar novamente, ou se alguem tiver outra ideia ne.

[]'s
arcanjo_mg,

Já tentou fazer dessa forma?

http://www.dicas-l.com.br/dicas-l/20020610.php
E ai grande moderador!

Mestre, tentei fazer o que diz no tutorial, na verdade ja havia feito isso, resultados:

o find encontra o stage1 na partiçao hda5 que nao tem nenhum sistema instalado, apenas meu torrent. Ok, msm assim prossegui como no exemplo e deu pra fazer tudo, as mesmas mgs do exemplo, testei no reboot e nada. Segundo passo, usando o fdisk coloquei a tal partiçao hda5 como boot. Nada foi bootado.
Terceiro round, tentei usar o comando root com para o hda6 que é onde de fato esta meu debian, a mensagem retornada é que o sistema de arquivo nao foi conhecido, mas a particao é linux. (isto é uma traduçao da msg, nao copie-a). Tentei fazer um setup (hd0,6) e a msg foi que nao era possivel montar tao partiçao.
Round quatro, voltei ao fdisk e tentei colocar hda6 como boot, novamente nada foi bootado.
Por fim nada consegui. E agora? sera que o grub esta com pau? Nao queria perder meu Debian dps de tanto personaliza-lo e de tudo que ta instalado legal e tals.
Opa,

Poderia postar o resultado de

Código:
fdisk -l /dev/hda

E o arquivo de configuração do grub? Geralmente /boot/grub/menu.lst

Outra coisa, seu computador sofreu alguma queda brusca de energia ultimamente?
fdisk -l /dev/hda

Código:
Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device       Boot   Start   End    Blocks        Id     System
/dev/hda1   *          1     3250  26105593+   7      HPFS/NTFS
/dev/hda2            3251  9729   52042567+   f     W95 Ext'd (LBA)
/dev/hda5            3251  4041   6353676      83    Linux
/dev/hda6            4042  4832   6353676      83    Linux
/dev/hda7            4833  4865     265041      82   Linux swap
/dev/hda8            4866  9729   39070048+   b    W95 FAT32

menu.lst

Código:
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.          
default        0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout        8

# Pretty colours
#color cyan/blue white/blue

# Fun splashimage ;-)
# Check http://ruslug.rutgers.edu/~mcgrof/grub-images for a HOWTO
# on making GRUB splashimages.
#
# I recommend putting all GRUB splashimages in /boot/grub/images
# to not bloat the /boot/grub directory ;)
splashimage /boot/grub/splashimages/debian_cooleye.xpm.gz

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title        Windows 95/98/NT/2000
# root        (hd0,0)
# makeactive
# chainloader    +1
#
# title        Linux
# root        (hd0,1)
# kernel    /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specifiv kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
# kopt=root=/dev/hda8 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,7)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## ## End Default Options ##

title        Debian GNU/Linux, kernel 2.6.8-2-386
root        (hd0,7)
kernel        /boot/vmlinuz-2.6.8-2-386 root=/dev/hda8 ro
initrd        /boot/initrd.img-2.6.8-2-386
savedefault
boot

title        Debian GNU/Linux, kernel 2.6.8-2-386 (recovery mode)
root        (hd0,7)
kernel        /boot/vmlinuz-2.6.8-2-386 root=/dev/hda8 ro single
initrd        /boot/initrd.img-2.6.8-2-386
savedefault
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
#title        Other operating systems:
#root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title        Microsoft Windows XP Professional
root        (hd0,0)
savedefault
makeactive
chainloader    +1


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/hda5.
#title        Linux (on /dev/hda5)
#root        (hd0,4)
#kernel        /boot/vmlinuz root=/dev/hda5 ro
#savedefault
#boot

Nesse menu.lst tem uma coisa estranha tbm, sempre eu altero para hda6 nos parametros mas qdo tento instalar eles voltam para hda7 e hda8.

Nao, nao sofreu nenhuma queda brusca de energia. Apenas reinstalei o Win na particao hda1.
Tu já tentou isso aqui???

grub-install /dev/hda

Claro, vc precisa entrar com uma distro live, montar a partição do sistema e entrar com chroot.

Logo depois do chroot, execute

mount -t proc /proc proc

Antes de sair desmonte.

Isso deveria resolver, mano.

Abraço,
arcanjo_mg,

Possível problema: O hda6 não está marcado como bootável.

Solução: Utilize o cfdisk para arrumar isso (é só ir em cima da partição, pressionar bootable e gravar as alterações.
apscherbach,

voce pode ver no meu primeiro post que ja tentei isso, bootei usando um cd do slack e usei o chroot e tentei utilizar o grub-install, retorna um erro que é a msg do titulo deste post.

Fernando,

tambem ja tentei isso, usando o fdisk, nao o cfdisk, tentei deixar so ela como boot, ela e a outra, so o hda5, nada é bootado alem do windows.

Bom galera, ta dificil e eu realmente queria recuperar pois formatar esta meio fora pra mim dps de tantas personalizaçoes e instalaçoes que fiz no sistema, qualquer ideia que tiverem pode mandando que eu testo. Obrigado pelas respostas.
arcanjo_mg Escreveu:Fernando,

tambem ja tentei isso, usando o fdisk, nao o cfdisk, tentei deixar so ela como boot, ela e a outra, so o hda5, nada é bootado alem do windows.

Tudo bem, então deixe marcado como bootable (eu realmente recomendo o cfdisk) e depois volte a postar o resultado de fdisk -l /dev/hda

O erro pode ser outro, mas se não estiver marcado como bootable nunca vai funcionar.
Código:
Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device       Boot   Start   End    Blocks        Id     System
/dev/hda1              1     3250  26105593+   7      HPFS/NTFS
/dev/hda2            3251  9729   52042567+   f     W95 Ext'd (LBA)
/dev/hda5            3251  4041   6353676      83    Linux
/dev/hda6   *       4042  4832   6353676      83    Linux
/dev/hda7            4833  4865     265041      82   Linux swap
/dev/hda8            4866  9729   39070048+   b    W95 FAT32

Desta maneira ai ele nao boota nada!

Olha, ja tentei mais coisas e nao deu certo, o problema acho que esta neste arquivo stage1, o problema ta sendo dito no titulo do post, acho q tenho que trocar esses arquivo pois deve estar corrompido ou algo assim. O que acha?
arcanjo_mg,

Acho que seu grub está errado nessa parte

Código:
title      Debian GNU/Linux, kernel 2.6.8-2-386
root      (hd0,7)
kernel      /boot/vmlinuz-2.6.8-2-386 root=/dev/hda8 ro
initrd      /boot/initrd.img-2.6.8-2-386
savedefault
boot

title      Debian GNU/Linux, kernel 2.6.8-2-386 (recovery mode)
root      (hd0,7)
kernel      /boot/vmlinuz-2.6.8-2-386 root=/dev/hda8 ro single
initrd      /boot/initrd.img-2.6.8-2-386
savedefault
boot

Está root=/dev/hda8, mas é /dev/hda6, não é?

Tente deixar assim

Código:
title      Debian GNU/Linux, kernel 2.6.8-2-386
root      (hd0,7)
kernel      /boot/vmlinuz-2.6.8-2-386 root=/dev/hda6 ro
initrd      /boot/initrd.img-2.6.8-2-386
savedefault
boot

title      Debian GNU/Linux, kernel 2.6.8-2-386 (recovery mode)
root      (hd0,7)
kernel      /boot/vmlinuz-2.6.8-2-386 root=/dev/hda6 ro single
initrd      /boot/initrd.img-2.6.8-2-386
savedefault
boot

Quanto ao bootable, deixe ele em todas as partições que vão dar boot (você pode deixar em mais de uma).
Fernando eu tentei e nao deu, o problema nao é alterar o menu.list, nao adianta somente altera-lo pq o grub nao instala, o comando de instalacao retorna a msg de erro no titulo deste post, tem algo errado é com esse arquivo stage1.
De qualquer maneira eu vou agora é reinstalar tudo, apelei!
hehehehe

obrigado pelo esforço.
Tive problema semelhante (alem de outros).

Comprei um novo micro, e como nao queria reinstalar windows nem linux, simplesmente tentei copiar as particoes do micro antigo para o novo.
Minha primeira dificuldade vou a mudanca do modo em que os discos SATA sao reconhecidos no linux e windows. O windows so reconhece eles se forem colocados em modo IDE e o linux em AHCI. Resultado, tenho que alternar toda hora na bios.

Primeiro eu tentei copiar as particoes diretamente com o partition magic 8, mas deu varios erros e embora tenha conseguido copiar as particoes para o novo disco, elas estava com geometria errada etc, entao tive que fazer as particoes no novo disco do zero. Felizmente eu tinha um outro disco SATA (vou chamar de disco sata 2) e instalei o debian 4.0 64 nele (embora tambem tenha sido muito dificil configurar a rede da minha DG965wh). Usei ele para bootar, criar as particoes e copiar este linux para a particao linux que criei no disco sata principal. O detalhe é que o grub nao instalava nem a caralho no disco sata1 (que é onde terei o disco com windows e linux). Tentei com chroot no disco destino, dando um --recheck, especificando com --root-directory, nada. Troquei os dois de cabo,(sda para sdb) etc.
Nao ia nem a caralho. Acho que ele se confundia com o lance sda/sdb dos discos, dava esse erro que ele nao conseguia ler o stage1. E quando eu consegui passar isso, ele nao achava o stage1.5 no disco que bootava. Enfim tentei fazer o seguinte, bootei com a particao linux antiga do meu disco PATA, e de la consegui instalar o grub (aleluia!). Entao parece que o lance é usar PATA e SATA para isso.
Ai veio a segunda parte do meu pesadelo, copiar o WINDOWS que estava em NTFS. Eu criei uma particao NTFS e outra FAT32 no novo disco, com o linux, bootei no windows no disco antigo, formatei as novas particoes NTFS e FAT32, e copiei tudo exceto o "documents and settings" e o dir "windows" para a nova NTFS, pois estavam em uso.
Bootei novamente no linux e copie essas duas que faltavam para a FAT32 (é uma bosta o linux ainda nao escrever direito em NTFS). Bootei novamente no windows e copiei da FAT32 para NTFS.
Finalmente para copiar o setor de boot do windows antigo para o novo usei um dd if=/dev/hda of=/dev/sda bs=512 count=1 e consegui copiar o MBR para o linux bootar. Depois foi so refazer o menu do grub no disco novo!
ufa!
espero que ajude gente com problema parecido como meu.
URL de Referência