Fórum Debian

Versão Completa: [Resolvido] Problema com Permissões
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Páginas: 1 2
Olá Pessoal.
[/font]
Estou com um problema ao montar um servidor samba para compartilhamento de arquivos.
O cliente windows funciona perfeitamente o compartilhamento e as permissões também.
No cliente Linux acontece semelhante ao windows porem tenho permissao negada em todas as pastas mesmo as permissôes estando para o meu usuario que esta logado.


agradeço desde já

utilizo Debian Lenny
Como você monta esta pasta no linux? Quero ver o comando com as opções que você usa para montagem.
o comando que eu uso é gerado através de um script quando o usuario loga no sistema aonde $passwdusers é uma senha padrão para alguns usuarios.
O comando é o seguinte:
sudo mount //192.168.3.1/dados /mnt/arquivos -o username=`whoami`,password=$passwdusers,acl
passa como parâmetro o rw também:

sudo mount //192.168.3.1/dados /mnt/arquivos -o username=`whoami`,password=$passwdusers,acl,rw

Vê se funfa!!!
Tentei adicionar o parâmetro rw mas não funcionou também, vou te falar o que eu foi feito até então

É um compartilhamento de arquivos samba, que faz o compartilhamento do /arquivos [nome do compartilhamento = dados]

tenho 4 grupos:
admins :suporte e admin
grupoa: usuario1,usuario2,usuario3,usuario4,usuario5
grupob: usuario6,usuario7,usuario8,usuario9,usuario10
grupoc: usuario11,usuario12,usuario13,usuario14,usuario15

O esquema de diretorios é o seguinte
Arquivos
|Admins
admin
suporte

|grupoa
usuario1
usuario2
usuario3
usuario4
usuario5

|grupob
usuario6
usuario7
usuario8
usuario9
usuario10

|grupoc
usuario11
usuario12
usuario13
usuario14
usuario15
os usuários do grupo tem permissão de leitura e execução dentro da pasta de seu diretório e acesso total em suas pastas(somente o usuário dono)
o grupo admins tem acesso total em todas as pastas
Já utilizei ACL’s para isso funcionar corretamente
No cliente Windows funciona perfeitamente
No cliente Debian não
Tive problemas com uid e gid mas configurei um servidor NIS e isso amenizou o problema
Antes não funcionava nada pois pegava o uid da máquina local ai dava erro nas permissões.
Mas agora so funcionam as permissões do sistema (chmod) já as ACL’s não funcionam

Gostaria de saber o que tenho que fazer para as ACL’s funcionarem

att
Agradeço desde já
Você já está passando "acl" no option da montagem...

Está colocando o parâmetro "nt acl support = yes" nos compartilhamentos?

Tem como postar o seu smb.conf?
sim estou colocando nt acl support = yes mas na sessão global, tem que ser nos compartilhamentos? se bem que tenho apenas um

Esta aqui o smb.conf

[global]
workgroup = WORKGROUP
server string = %h server
dns proxy = no
log file = /var/log/samba/log.%m
max log size = 1000
syslog = 0
panic action = /usr/share/samba/panic-action %d
encrypt passwords = true
passdb backend = smbpasswd
unix password sync = yes
passwd program = /bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
pam password change = yes
printing = cups
nis homedir = true
printcap name = cups
smbpasswd file = /etc/samba/smbpasswd
load printers = yes
security = share
acl check permissions = yes
acl compatibility = Auto
nt acl support = yes


; unix extensions = no
#[homes]
# comment = Home Directories
# browseable = no
# read only = yes
# create mask = 0700
# directory mask = 0700
# valid users = %S

[dados]
comment = pasta compartilhada
path = /arquivos
browseable = yes
writeable = yes
read only = no
valid users = @grupoa, @grupob, @grupoc, @admins
inherit acls = yes
inherit permissions = yes
map acl inherit = yes

[printers]
comment = All Printers
browseable = no
path = /var/spool/samba/nizkalog
printable = yes
guest ok = no
read only = yes
create mask = 0700
[print$]
comment = Printer Drivers
path = /var/lib/samba/printers
browseable = yes
read only = yes
guest ok = no
O parâmetro ""nt acl support = yes" não é geral e sim dentro de cada compartilhamento. coloque dentro de cada compartilhamento e vê se funciona!!!
Coloquei o parâmetro "nt acl support = yes" dentro do meu compartilhamento dados, porém não foi eficaz.
Continua não funcionando.
Só não entendo o porque das acl's não funcionarem em conjunto com NIS.
Muito estranho isso.

att
Sem NIS funciona?
Não, pois o UID e GID dos clientes não batem, por exemplo o usuario1 tem uid 1000 no servidor e 1010 no cliente, ai as permissões ficam erradas.
A pasta que deveria ser de um usuario acaba ficando para outro.
Com o NIS as permissões ficam certas, os usuarios entram nas suas pastas porém a ACL que permite o grupo admins controle total em todos os diretorios não funciona.
Ou seja as premissões do proprio linux funcionam já as acl's não
Você está usando o nis e o mesmo usuário ainda está no passwd? Remova o usuário do passwd se este for o caso.
Ele não existe no passwd.

Mas...
consegui arrumar uma solução mas na minha opnião não seria correto.
utilizei nfs para montagem dos usuarios que utilizam ACL (grupo admins), e funciona.
mas eu tenho que compartilhar a pasta(partição) /arquivos e o que me foi solicitado foi compartilhar como dados

no samba consegui fazer isso já com nfs estou procurando uma maneira de atribuir um "alias" e este compartilhamento para ser montado como dados.

att
Em relação a questão acima eu sincronizei os diretórios com o comando rsync porém gostaria que ele fosse sincronizado em tempo real coisa que não consegui até o momento, uma solução seria colocar o comando para executar dentro do crontab.

Existe algum parametro do rsync que permita a sincronização em tempo real?

att
Em tempo real? Como assim?
Páginas: 1 2
URL de Referência