Fórum Debian

Versão Completa: PHPERRO: "Fatal error: Call to undefined function mysql_connect()"
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Boa tarde senhores,
Estou com um problema, já procurei em varios lugares e não entrei resposta para ele.
Instalei todos os pacotes com o apache, php5 e mysql.
Porem o PHP funciona normal com o apache, só que quando eu tento fazer uma conexão com o banco, vem o erro que está no assunto do topico.
o script que nao dá erro é
Código PHP:
<?php
//$connect = mysql_connect('localhost', 'root', 'root123');
phpinfo();
?>
Agora se eu retiro o comentário
Citar:Fatal error: Call to undefined function mysql_connect() in /var/www/phpinfo.php on line 2
Procurei alguma referencia dentro do php.ini de mysql e achei estranho pq nao encontrei nada, e a variavel extension_dir está comentada, mas no phpinfo() aparece "extension_dir - /usr/lib/php5/20090626+lfs".
Abaixo a lista dos pacotes instalados
Código:
acpi                        install
acpi-support-base                install
acpid                        install
adduser                        install
apache2                        install
apache2-mpm-prefork                install
apache2-utils                    install
apache2.2-bin                    install
apache2.2-common                install
apt                        install
apt-utils                    install
aptitude                    install
base-files                    install
base-passwd                    install
bash                        install
bsdmainutils                    install
bsdutils                    install
busybox                        install
console-setup                    install
console-terminus                install
coreutils                    install
cpio                        install
cron                        install
dash                        install
dbus                        install
debconf                        install
debconf-i18n                    install
debian-archive-keyring                install
debianutils                    install
diffutils                    install
dmidecode                    install
dmsetup                        install
dpkg                        install
e2fslibs                    install
e2fsprogs                    install
eject                        install
file                        install
findutils                    install
gcc-4.4-base                    install
gettext-base                    install
gnupg                        install
gpgv                        install
grep                        install
groff-base                    install
grub-common                    install
grub-pc                        install
gzip                        install
heirloom-mailx                    install
hostname                    install
ifupdown                    install
info                        install
initramfs-tools                    install
initscripts                    install
insserv                        install
install-info                    install
installation-report                install
iproute                        install
iptables                    install
iputils-ping                    install
isc-dhcp-client                    install
isc-dhcp-common                    install
kbd                        install
keyboard-configuration                install
klibc-utils                    install
laptop-detect                    install
libacl1                        install
libapache2-mod-php5                install
libapr1                        install
libaprutil1                    install
libaprutil1-dbd-sqlite3                install
libaprutil1-ldap                install
libattr1                    install
libavahi-client3                install
libavahi-common-data                install
libavahi-common3                install
libblkid1                    install
libboost-iostreams1.42.0            install
libbsd0                        install
libbz2-1.0                    install
libc-bin                    install
libc6                        install
libc6-i686                    install
libcap2                        install
libcomerr2                    install
libcups2                    install
libcwidget3                    install
libdb4.7                    install
libdb4.8                    install
libdbd-mysql-perl                install
libdbi-perl                    install
libdbus-1-3                    install
libdevmapper1.02.1                install
libedit2                    install
libept1                        install
libexpat1                    install
libfile-copy-recursive-perl            install
libfreetype6                    install
libgcc1                        install
libgcrypt11                    install
libgdbm3                    install
libgnutls26                    install
libgpg-error0                    install
libgssapi-krb5-2                install
libhtml-template-perl                install
libk5crypto3                    install
libkeyutils1                    install
libklibc                    install
libkrb5-3                    install
libkrb5support0                    install
libldap-2.4-2                    install
liblocale-gettext-perl                install
liblzma2                    install
libmagic1                    install
libmysqlclient16                install
libncurses5                    install
libncursesw5                    install
libnet-daemon-perl                install
libnewt0.52                    install
libnfnetlink0                    install
libonig2                    install
libpam-modules                    install
libpam-runtime                    install
libpam0g                    install
libpci3                        install
libpcre3                    install
libplrpc-perl                    install
libpopt0                    install
libqdbm14                    install
libreadline6                    install
libsasl2-2                    install
libsasl2-modules                install
libselinux1                    install
libsepol1                    install
libsigc++-2.0-0c2a                install
libslang2                    install
libsqlite3-0                    install
libss2                        install
libssl0.9.8                    install
libstdc++6                    install
libtalloc2                    install
libtasn1-3                    install
libtext-charwidth-perl                install
libtext-iconv-perl                install
libtext-wrapi18n-perl                install
libudev0                    install
libusb-0.1-4                    install
libuuid-perl                    install
libuuid1                    install
libwbclient0                    install
libwrap0                    install
libxapian22                    install
libxml2                        install
linux-base                    install
linux-image-2.6-686                install
linux-image-2.6.32-5-686            install
locales                        install
login                        install
logrotate                    install
lsb-base                    install
man-db                        install
manpages                    install
mawk                        install
mime-support                    install
module-init-tools                install
mount                        install
mysql-client-5.1                install
mysql-common                    install
mysql-server                    install
mysql-server-5.1                install
mysql-server-core-5.1                install
nano                        install
ncurses-base                    install
ncurses-bin                    install
net-tools                    install
netbase                        install
netcat-traditional                install
openssh-blacklist                install
openssh-client                    install
openssh-server                    install
openssl                        install
passwd                        install
pciutils                    install
perl                        install
perl-base                    install
perl-modules                    install
php5                        install
php5-cli                    install
php5-common                    install
php5-suhosin                    install
procps                        install
psmisc                        install
readline-common                    install
rsyslog                        install
samba                        install
samba-common                    install
samba-common-bin                install
sed                        install
sensible-utils                    install
sgml-base                    install
ssl-cert                    install
sysv-rc                        install
sysvinit                    install
sysvinit-utils                    install
tar                        install
tasksel                        install
tasksel-data                    install
traceroute                    install
tzdata                        install
ucf                        install
udev                        install
update-inetd                    install
usbutils                    install
util-linux                    install
vim-common                    install
vim-tiny                    install
wget                        install
whiptail                    install
xkb-data                    install
xml-core                    install
xz-utils                    install
zlib1g                        install
Olá,

Instale o pacote php5-mysql e veja se funciona.
URL de Referência