Fórum Debian

Versão Completa: Apt-get install <pacote> não funciona...[RESOLVIDO]
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Olá pessoal, to com um problema ao tentar instalar pacotes no meu sistema debian...
quando digito apt-get install proftpd, por exemplo ou qual quer outro pacote tenho essa menssagem:

Citar:Lendo listas de pacotes... Erro!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_i 18n_Translation-en
E: As listas de pacotes ou os arquivos de estado não puderam ser analisados ou abertos.
se alguém souber alguma dica agradeço desde já...
o aptitude update está sendo executado sem erros?
já tentou mudar os repositórios e testar se ainda assim ocorre o mesmo problema?
sim dmatrix, o apt-get update roda tranquilo, ja troquei os repositórios também e nada... =/
vamos tentar refazer a lista de pacotes instalados e ver se resolve:

# mv /var/lib/dpkg/available /var/lib/dpkg/availbleold

agora dê um :
# echo -n >/var/lib/dpkg/available

assim teste novamente fazendo o update e tentando instalar algo.
dmatrix o apt-get update deu certo mas instalar algum programa não... =/
deu isso ai>>>

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/security.debian.org_dists_squeeze_updates_main_i18n_Translation-pt
E: As listas de pacotes ou os arquivos de estado não puderam ser analisados ou abertos.
deixe somente uma linha de repositórios no /etc/apt/sources.list ou seja comente as security e demais não essenciais.
e tente novamente aptitude update e instalar algo.
Dmatrix resolvi o problema aqui,
fui excluindo esses arquivos que tavam dando erro: "Problem with MergeList /var/lib/apt/lists/security.debian.org_dists_squeeze_updates_main_i18n_Translation-pt" até que parou de dar erro ao tentar executar os comandos apt-get update ou upgrade, agora tá tudo certo... Obrigado pelas dicas att...
"Resolvi", agora quando to instalando um pacote pelo apt-get install <pacote> ta dando esse erro ae:

dpkg: error: falhou ao abrir arquivo de informações do pacote '/var/lib/dpkg/available' para leitura: Arquivo ou diretório não encontrado
E: Sub-process /usr/bin/dpkg returned an error code (2)
ola o problema é que você deletou o renomeio o arquivo available para availableold
no processo acima indicado por dmatrix, entra na pasta /var/lib/dpkg/ e ver se tem o arquivo available e availableold se tiver apaga o available e renomeia o availableold para available
ixi foi bemmm isso mesmo Jvianez, desculpa a fata de atenção ai... vlw pela resposta!!! att...
URL de Referência