Fórum Debian

Versão Completa: VLC não reproduz video, apenas audio
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Páginas: 1 2
Olá pessoal, uso debian lenny e estou tentando usar o player VLC. Sei que parece apenas um erro de codecs, mas não sei se é só isso. Instalei ele pelo synaptic e instalei todos os plugins. Abro vídeos normalmente com outros players que tenho instalado, mas o VLC simplesmente não reproduz videos, não importa qual formato, apenas o audio. No meu VLC, não aparece nem algum espaço para reprodução de video, é muito estranho. Abaixo está uma print screen:

http://img64.imageshack.us/img64/2473/vlclinux.png

Alguém tem alguma ideia do que pode estar acontecendo?
eo seguinte você vai em synaptic e procura os seguintes pacotes:
1- Install vlc
2-mozilla-plugin-vlc
caso eles estiverem instalados desistalar e instala novamente.
caso não funcione os passos acima vá na aba do vlc
1 midia
2 abrir dispositivo de captura
3 capitura de dispositivo
4 modo capitura , video for linux 2
will Escreveu:eo seguinte você vai em synaptic e procura os seguintes pacotes:
1- Install vlc
2-mozilla-plugin-vlc
caso eles estiverem instalados desistalar e instala novamente.

Eu já havia feito isso, mais de uma vez, mas não deu certo.


will Escreveu:caso não funcione os passos acima vá na aba do vlc
1 midia
2 abrir dispositivo de captura
3 capitura de dispositivo
4 modo capitura , video for linux 2


Qual aba do vlc? Não encontrei a opção "Midia" em lugar algum. Fui em Arquivo >> Open Capture Device >> Video4Linux

Está tudo OK lá. Não consigo ver qual é o problema. Alguém tem alguma ideia?

(obs: minha versão é a 0.8.6h)
bom em relação a midia acredito que ela nao esteja disponivel em sua versão.

mas em relação ao seu problema acredito que isso possa resolver instale essa depedencia de acordo com seu processador.
http://packages.debian.org/pt/lenny/vlc

e poste no que deu.
Isso não é uma dependência para instalar, é o próprio pacote do vlc.

Mas de qualquer maneira, não tenho problema de dependências, pois instalei pelo synaptic.

Alguém tem alguma luz? =/
Talvez seja o driver de vídeo nas preferências do VLC, já tentou mudar?
Video4Linuxnesta seção mude para video for linux 2
will Escreveu:Video4Linuxnesta seção mude para video for linux 2

Não tem nenhuma opção desse tipo. Olha um print screen: http://img5.imageshack.us/img5/5779/vlcconfig.png

sistematico Escreveu:Talvez seja o driver de vídeo nas preferências do VLC, já tentou mudar?
Como que eu faço isso?
a sua versão e abaixo da minha acredito que não tem essa opção
http://klarkc.praiseweb.com.br/?p=66

de uma olhada nesse tutorial e ve se resolve seu problema
Pessoal, preciso de ajuda para instalar uma versão mais recente ou mais antiga do VLC. Descobri que o VLC simplesmente não funciona no Debian Lenny. Há um conflito entre alguns pacotes disponíveis no debian-multimidia e a versão do vlc pro lenny:

http://www.zeitoun.net/articles/vlc-con ... edia/start

A solução pro problema é alterar a versão do VLC ou de 7 pacotes de bibliotecas (ffmpeg libavcodec51 libavdevice52 libavformat52 libavutil49 libpostproc51 libswscale0), mas eu não sei fazer isso. Se eu altero os repositórios para o squeeze, quando tento instalar o VLC, o Synaptic pede pra instalar um monte de outras coisas e fazer várias atualizações. Não sei mais o que fazer com isso, preciso de ajuda... eu poderia tanto colocar uma versão mais antiga que a do lenny (ex: etch) ou uma mais recente, tanto faz... alguém tem alguma ideia? =/
Se realmente voce altera para squezze na sources.list ira atualizar seu sistema de lenny para squezze, e isso que voce pretende ?
Apenas o VLC...
Então renatov já que sua versão é a 0.8.6h você irá atualizar para 0.9.9.

Preparando seu sistema
Código:
# Apt-get install build-essential

Código:
# Apt-get install libqt4 dev-dev libpostproc-dev libavformat-dev libavcodec-libavutil dev-libmad0 dev-liba52-0.7.4-dev dev libhal-libdbus-1-dev Libfribidi dev-libgcrypt11-dev

Últimas instalar o VLC media player a partir da fonte (0.9.9 é a versão)

Código:
wget http://download.videolan.org/pub/videolan/vlc/0.9.9/vlc-0.9.9.tar.bz2

Extraia o arquivo tar.bz2 usando o seguinte comando
Código:
# Tar-xjf vlc-0.9.9.tar.bz2

Código:
# Cd vlc-0.9.9

Código:
#. / Configure -disable-swscale

Código:
# Make

Código:
# Make install

Isso é que isto vai completar a instalação

Usando o VLC

Se você deseja abrir VLC Você precisa ir a Aplicações-> Som & Video-VLC> Media Player

Se você quiser instalar o plugin mozilla use o seguinte comando

Código:
# Apt-get install mozilla-plugin-vlc

:mrgreen:
Páginas: 1 2
URL de Referência