Fórum Debian

Versão Completa: Configuração placa wireless Broadcom
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Prezados,

Boa noite!

Estou tentando instalar uma placa wireless Broadcom no BackTrack 5 R1 onde é evidenciado o erro abaixo:

[email protected]:~/Documentos# aptitude install bcmwl-kernel-source
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following NEW packages will be installed:
bcmwl-kernel-source dkms{a} linux-headers{a} linux-headers-2.6.39.4{a}
0 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/8,240kB of archives. After unpacking 58.5MB will be used.
Do you want to continue? [Y/n/?]
Writing extended state information... Done
Selecting previously deselected package dkms.
(Reading database ... 221308 files and directories currently installed.)
Unpacking dkms (from .../dkms_2.1.1.2-2fakesync1_all.deb) ...
Selecting previously deselected package linux-headers-2.6.39.4.
Unpacking linux-headers-2.6.39.4 (from .../linux-headers-2.6.39.4_2.6.39.4-10.00.Custom_amd64.deb) ...
Selecting previously deselected package linux-headers.
Unpacking linux-headers (from .../linux-headers_1.1-bt3_all.deb) ...
Selecting previously deselected package bcmwl-kernel-source.
Unpacking bcmwl-kernel-source (from .../bcmwl-kernel-source_5.60.48.36+bdcom-0ubuntu3_amd64.deb) ...
Processing triggers for man-db ...
Setting up dkms (2.1.1.2-2fakesync1) ...

Setting up linux-headers-2.6.39.4 (2.6.39.4-10.00.Custom) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 2.6.39.4 /boot/vmlinuz-2.6.39.4

Setting up linux-headers (1.1-bt3) ...
Setting up bcmwl-kernel-source (5.60.48.36+bdcom-0ubuntu3) ...
Loading new bcmwl-5.60.48.36+bdcom DKMS files...
First Installation: checking all kernels...
Building only for 2.6.39.4
Building for architecture x86_64
Building initial module for 2.6.39.4

Error! Bad return status for module build on kernel: 2.6.39.4 (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/bcmwl/5.60.48.36+bdcom/build/ for more information.
dpkg: error processing bcmwl-kernel-source (--configure):
subprocess installed post-installation script returned error exit status 10
Errors were encountered while processing:
bcmwl-kernel-source
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up bcmwl-kernel-source (5.60.48.36+bdcom-0ubuntu3) ...
Removing old bcmwl-5.60.48.36+bdcom DKMS files...

------------------------------
Deleting module version: 5.60.48.36+bdcom
completely from the DKMS tree.
------------------------------
Done.
Loading new bcmwl-5.60.48.36+bdcom DKMS files...
First Installation: checking all kernels...
Building only for 2.6.39.4
Building for architecture x86_64
Building initial module for 2.6.39.4

Error! Bad return status for module build on kernel: 2.6.39.4 (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/bcmwl/5.60.48.36+bdcom/build/ for more information.
dpkg: error processing bcmwl-kernel-source (--configure):
subprocess installed post-installation script returned error exit status 10
Errors were encountered while processing:
bcmwl-kernel-source
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done

[email protected]:~/Documentos#
[email protected]:~/Documentos#
[email protected]:~/Documentos# uname -r
2.6.39.4
[email protected]:~/Documentos# uname -a
Linux bt 2.6.39.4 #1 SMP Wed Aug 17 21:42:30 EDT 2011 x86_64 GNU/Linux
[email protected]:~/Documentos# cat /etc/issue
BackTrack 5 R1 - Code Name Revolution 64 bit\n \l

[email protected]:~/Documentos# lspci -vvnn | grep 14e4
02:00.0 Network controller [0280]: Broadcom Corporation BCM43225 802.11b/g/n [14e4:4357] (rev 01)


Procedimento de instalação presente em: https://help.ubuntu.com/community/WifiDo...t%20access


Se alguém puder ajudar...

Obrigado!
cara estou o mesmo problema segui as instruções do wiki do debian veja

http://wiki.debian.org/brcm80211

no debian 6.0 2.6.32. funciona normal com firmware não livre mas parece que no kernel ja é o driver livre incluido no kernel
Emanoel,

Obrigado pela dica.

Tentei seguir a wiki utilizando os pacotes .deb e mesmo assim deu erro.

Obrigado!
Você pode tentar instalar o driver proprietário então (módulo wl). Desfaça tudo que você fez até agora com relação a esses drivers livres e siga esse tutorial:

http://wiki.forumdebian.com.br/index.php...b/g_LP-PHY
o estranho é que no debian com kernel 2.6.32 funciona e no kernel 2.6.39 não funciona
Poste detalhes do procedimento seguido e da mensagem de erro retornada, para podermos ajudá-los.
URL de Referência