Fórum Debian

Versão Completa: Internet no Debian
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Páginas: 1 2 3
Bom dia

Sou iniciante no Debian e o que pretendo é o seguinte:

Configurar o Debian para comportiilhar internet na rede interna,

O que fiz ate agora:
Configurei o arquivo squid3.conf, resolv.conf, interfaces, porem meu servidor Debian nao esta conectando a internet, portanto nao consiguirei comportilhar internet ja que o meu servidor nem consegue conectar


Meu servidor esta numa VMare, com duas placas de rede, o modem de internet esta roteado 192.168.254.254, como poderia configurar as placas de redes,

Internamente consigo pingar o debian e funciona, o problema é o acesso a internert

As duas placas precisam esta em NAT?

Att
Junior
Nao entendir
Rapaz o que o sem noção colocou acima é propaganda clica em reportar
Para resolver o seu problema basta configurara a placa que vai conectar com o modem deixa ela na mesma faixa de ip no caso 192.16.254.xxx se a conexão for pppoe basta instalar o pppoeconf e depois executar o comando pppoeconf e preencher com os dados da sua conexão senha e usuario
Pessoal

Meu servidor ja esta conectando a internet, testei pigando endereços externos e pingei tambem o modem 192.168.254.254, ambos derão respostas, entao, suponho que agora tenho que fazer o compartilhamento para que as maquinas clientes possam acessar a internet atraves do meu debian


Qual é o proximo passo?
Agora vem a parte da configuração do iptables estas são as regras para compartilha a sua net coloque o conteúdo abaixo no fim do arquivo /etc/init.d/bootmisc.sh. Antes troque o pela sua conexão no seu caso eth0

modpobre iptable_nat
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE #sua interface de conexão com a internet
minha conexao é static o modem é roteado, entendo entao que nao utiliza o ppp0, ou eu que estou enganado mesmo?
faz o seguinte teste executa o comando ifconfig e posta aqui, para vermos com esta as suas configurações no servidor já tem internet
Ola

segue entao o print do comando ifconfig, apesar que suspeito minhas interfaces nao estao configguradas corretamente

att
supondo que a eth0 que não aparece é a interface ligada na net basta troca a interface do iptables que postei acima

modpobre iptable_nat
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE #sua interface de conexão com a internet

a interface eth1 é que vai distribuir a internet para os pc da rede local então tem que esta na mesma faixa de ip da eth1 que sera o gwt padrão
segue minha interfaces, pra vc dá uma revisada se esta tudo ok
segue
vamos volta para o inicio o servidor já tem a net funcionando nele? como esta em uma maquina virtual quantas interfaces de rede tem no seu windows? creio que você vai ter que colocar uma interface em mode brigde ente o windows e a maquina virtual para que o ip passe direto do roteador para a maquina virtual sem que o widnows pegue o ip e outra interface para ligar a maquina virtual ao windows com a mesma classe de ip do seu servidor virtual.
Você não tem um gabinete velho por ai encostado para fazer o servidor? colocar como esta a configuração do windows aqui (rede)
- A net ja esta funcionando no servidor;
- Virtualizei 02 interfaces de rede(01 brigde, NAT); no windows aparece essas interfaçes
- Os IPs que aparece no windows é diferente do debian;
- Nao tenho uma maquina antiga aqui para testar;

OBS:. Ja implantei outro servidor (Endian) virtualizado com 01 brigde e uma NAT, e funciona normal,

Preciso colocar IPs nas interfaces do windows virtualizadas?
Alguem me ajuda??
Você já fez o compartilhamento da internet no debian e colocou o conteúdo que descrevi acima em um arquivos que seja executado na inicialização geralmente eu coloco no arquivo bootmisc.sh que fica dentro da pasta /etc/init.d/ se ainda não vez depois coloca esta conteúdo dentro dele no fim do arquivo

modpobre iptable_nat
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE #troque eth0 pela sua interface que recebe a net

Para testa basta colocar o ip na mesma classe que estiver na eth1 no caso dela ser a que sai para a rede local e posta aqui se funcionou
Muito obrigado pelas orientaçoes,

Desde o inicio vinha tendo dificuldades, até agora, conseguir ter progessos, o meu servidor ja esta conectando a internet pingo varios endereços externos, e todos dão respostas, mesmo assim tenho duvida de como devo configurar as interfaces(eth0,eth1) etc/network/interfaces, sendo meu gayteway 192.168.254(modem roteado) 192.168.254.254 (DNS)

Como tem que esta minhas interfaces (eth1,eth0)?


grato
Páginas: 1 2 3
URL de Referência