Fórum Debian

Versão Completa: Dois HDs com Grub 2 e compartilhar internet
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Amigos do Forum Debian, tenho duas duvidas, a primeira é sobre Grub 2 com dois HDs no micro.
Tenho um HD SATA particionado da seguinte forma, Windows 7, Debian Etch e Swap.
Tenho também um segundo HD, IDE, particionado da seguinte forma, FAT32 e EXT3, o segundo HD é só de dados, não tem nenhum só instalado.
No Windows, funciona normal, ele reconhece a partição FAT32 do segundo HD, mas no Debian acontece algo estranho, a cada boot ele muda a denominação das partições, por exemplo:

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cilindros of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x3a673a67

Dispositivo Boot Start End Blocks Id System
/dev/sda1 1 30 240943+ 82 Linux swap / Solaris
/dev/sda2 * 31 13090 104902656 7 HPFS ou NTFS
/dev/sda3 13091 38913 207423247+ 83 Linux

Meu segundo HD esta desligado, mas ele mostraria:

/dev/sdb1 FAT32
/dev/sdb2 * EXT3

Começa ai minha duvida, HDs IDE deveria ser /dev/hd e não /dev/sd mas posso estar enganado.
Num segundo boot, ele inverte as denominações entre os dois HDs

/dev/sdb1 1 30 240943+ 82 Linux swap / Solaris
/dev/sdb2 * 31 13090 104902656 7 HPFS ou NTFS
/dev/sdb3 13091 38913 207423247+ 83 Linux

/dev/sda1 FAT32
/dev/sda2 * EXT3

Isto torna a configuração do meu /etc/fstab inútil, pois a cada boot ele inverte as denominações, já tentei update-grub mas não adiantou nada, detalhe, quando instalei o Debian, só havia o primeiro HD SATA, instalei o segundo HD IDE depois.

A segunda duvida é sobre compartilhar internet, criei um script chamado compartilharnet, com o seguinte conteúdo:

#!/bin/bash
echo "1" > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

Salvei em /etc/init.d, dei permissão com com chmod +x compartilharnet e depois

cd /etc/rc2.d

ln -s /etc/init.d/compartilharnet /etc/rc2.d/S99compartilharnet

Porem, o sript não surte efeito durante o boot, a internet não é compartilhada, mas se depois do boot eu vou até o diretorio /etc/init.d e digito, como root: ./compartilharnet, ai a internet passa a ser compartilhada.
Parece que o script é chamado antes de a internet ser iniciada, ou a própria rede, resolvi da seguinte forma, coloquei o script em /usr/bin e criei um link para /home/rodolfo/.kde/autostart :

$ ln -s /usr/bin/compartilharnet /home/rodolfo/.kde/Autostart/compartilharnet.
Funcionou, mas depende de iniciar o KDE para compartilhar a internet, deve haver solução mais elegante.
ver se os 2 hd estão como master e estão cada um conectado no master do sata1 e Ide1 se tiver faz um teste coloca o hd ide para escrava para ver se ele fica reconhecendo normalmente posse ser só a maneira que a bios esta reconhecendo os hds e repassando as informações para o sistema
Sobre a internet eu sempre coloco dentro de um arquivo que é iniciado durante o boot no meu casso sempre coloco dentro do arquivo bootmisc.sh que fica na pasta init.d basta adicionar no fim do arquivo.

cho "1" > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
Caro jvianez, eu realmente havia me esquecido de verificar o jumper do HD IDE, então coloquei ele para "SLAVE", o HD SATA , até onde eu sei, não é nem MASTER nem SLAVE, porque no cabo sata não pode ter dois HDs, acho que no HD SATA o jumper é só para limitar a velocidade, algo assim, o que define o boot no SATA é a configuração de prioridade de boot no SETUP.
O HD SATA esta na entrada SATA 1 da placa mãe, e mesmo assim o problema continua.
Quanto a sua dica para compartilhar a internet, funcionou.
Agradeço.
Caro jvianez, resolvi seguir a dica do próprio arquivo /etc/fstab e usr o blkid :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>

O resultado do blkid no meu Debian:
[email protected]:/home/rodolfo# blkid
/dev/sda1: UUID="52165C57165C3E63" TYPE="ntfs"
/dev/sda2: UUID="305542b3-f5f5-4cc3-874d-9e1fbf9aceb0" TYPE="ext4"
/dev/sdb1: UUID="e8c0a78a-bc33-4c59-8f8d-745ebb69fece" TYPE="swap"
/dev/sdb2: UUID="F806B87906B83B08" TYPE="ntfs"
/dev/sdb3: UUID="7b4722fa-a0f4-427a-aaad-000df12a0cd3" TYPE="ext4"

Com isso pude montar os HDs diretamente no /etc/fstab sem me preocupar com a nomenclatura dos drives ou que o sistema reconhece primeiro, pois parece que minha bios alterna a ordem de reconhecimento dos HDs em cada boot.
Usei então o UUID para montar meus HDs a parti r do /etc/fstab:

proc /proc proc defaults 0 0
# / was on /dev/sda3 during installation
UUID=7b4722fa-a0f4-427a-aaad-000df12a0cd3 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda1 during installation
UUID=e8c0a78a-bc33-4c59-8f8d-745ebb69fece none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0

UUID=305542b3-f5f5-4cc3-874d-9e1fbf9aceb0 /mnt/linux ext4 defaults 0 0

UUID=52165C57165C3E63 /mnt/ntfs2 ntfs auto,user,rw,nosuid,noexec,umask=0 0 0

UUID=F806B87906B83B08 /mnt/ntfs ntfs auto,user,rw,nosuid,noexec,umask=0 0 0
URL de Referência