Fórum Debian

Versão Completa: Tela preta após o grub
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Bom dia pessoal.

Procurei no fórum, mas não encontrei um tópico relacionado sobre.

Acabo de instalar o debian squeeze amd64 e logo após a tela do grub (seja em modo recovery ou não) ocorre o load linux e depois fica uma tela preta com um cursor piscando.

Qualquer coisa que eu digito não é apresentado na tela através do cursor.

Mas mesmo com a tela preta, eu realizo login com o usuário root e consigo executar o comando shutdown ou reboot, por exemplo.

Já verifiquei configurações de vídeo na bios e nada.

Alguém tem idéia do que possa ser?

Obrigado pela atenção.
Partindo do principio que:
1 - O cd de instalação foi comprado de um dos vendedores oficiais ou a iso foi baixada da página oficial do debian e que o md5 está correto;
2 - Que você tomou todas as precauções e executou o passo-a-passo da instalação de acordo com o manual da página do debian;
3 - Que você tem um live cd; e
4 - Que a tela preta não é por falta de paciência em função do seu hardware.

Coloque o live cd na midia e inicialize para abrir o debian (ou outro linux) com o live cd
Abra o terminal
sudo su
# fdisk -l
Observe qual o seu dispositivo. Vamos usar como exemplo /dev/sda1
# mkdir /mnt/sda1
# mount /dev/sda1 /mnt/sda1
# mount --bind /dev /mnt/sda1/dev
# mount --bind /dev/pts /mnt/sda1/dev/pts
# mount --bind /proc /mnt/sda1/proc
# mount --bind /sys /mnt/sda1/sys
# chroot /mnt/sda1
# apt-get update
# apt-get upgrade
# apt-get -f install
# grub-install /dev/sda
Aperte as teclas Ctrl+D simultaneamente (Primeiro Ctrl depois D)
# umount /mnt/sda1/dev/pts
# umount /mnt/sda1/dev
# umount /mnt/sys
# umount /mnt/proc
# umount /mnt/sda1
Reinicia o desktop para ver se tem gráfico. ( Não esqueça de retirar o cd)
Os procedimentos com o livecd podem ser substituidos usando um outro sistema linux caso tenha instalado em seu disco.
URL de Referência