Fórum Debian

Versão Completa: Travamento no boot notebook hp
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Ola,

Estou com o debian instalado em um dv5-1250us, funcionando muito bem, exceto no boot, que as vezes, trava e o unico jeito é reiniciar novamente ate ele entrar sistema, o problema é o seguinte quando comeca a carregar o sistema (depois de escolher a opcao no grub) ele comeca a carregar tudo certinho e trava exatamente:
Código:
...
[    0.018529] ... bit width:              48
[    0.018648] ... generic registers:      4
[    0.018767] ... value mask:             0000ffffffffffff
[    0.018890] ... max period:             00007fffffffffff
[    0.019012] ... fixed-purpose events:   0
[    0.019130] ... event mask:             000000000000000f
[    0.020000] ACPI: Core revision 20090903
[    0.040367] Setting APIC routing to flat
[    0.041241] ..TIMER: vector=0x30 apic1=0 pin1=2 apic2=-1 pin2=-1
[    0.082287] CPU0: AMD Turion(tm) X2 Ultra Dual-Core Mobile ZM-80 stepping 01
[    0.084001] Booting processor 1 APIC 0x1 ip 0x6000  << trava
quando ele inicializa corretamente apos a mensagem "Booting processor 1 APIC 0x1 ip 0x6000" tenho o seguinte:
Código:
...
[    0.082287] CPU0: AMD Turion(tm) X2 Ultra Dual-Core Mobile ZM-80 stepping 01
[    0.084001] Booting processor 1 APIC 0x1 ip 0x6000
[    0.012000] Initializing CPU#1
[    0.012000] CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
[    0.012000] CPU: L2 Cache: 1024K (64 bytes/line)
[    0.012000] CPU 1/0x1 -> Node 0
[    0.012000] CPU: Physical Processor ID: 0
[    0.012000] CPU: Processor Core ID: 1
[    0.168247] CPU1: AMD Turion(tm) X2 Ultra Dual-Core Mobile ZM-80 stepping 01
[    0.169257] checking TSC synchronization [CPU#0 -> CPU#1]:
...
eu penso entao que seja um problema em iniciar o segundo nucleo do processador, dei uma buscada na net e aqui no forum e nao encontrei algo relacionado, alguem ja viu algo assim e sabe como resolver esse meu problema, ou tem um ponteiro ai pra me direcionar minhas buscas?

muito obrigado!
abraços
Olá, que kernel está usando? estranho isso de dar problema aleatóriamente, mas todos casos tente otimizar o kernel aplicando as flags na linha do kernel no grub, há várias flags a serem aplicadas, no meu hp com kernel mais antigos tb tive problemas de boot e funcionava bem aplicando as flags " noapic nolapic " tente essas primeiro.
muito obrigado dmatrix, meu kernel é:
Código:
[email protected]:~$ uname -r
2.6.32-3-amd64
vou testar aqui com as flags ja volto com a resp
Bom acho que colocar as flags resolveu o problema, não é 100% a chance porque o negocio é aleatorio mais nesses dias que passaram o problema não se repetiu

muito obrigado dmatrix!
olha eu aqui denovo, andei reparando que nessa solucao de colocar nolapic, ele resolve esse problema, mas em contrapartida o sistema agora apenas reconhece um core do do meu dual core, sera que tem uma outra maneira pra mim solucionar esse problema?
estranho, aonde vc viu essa informação? foi através do comando cat /proc/cpuinfo ?
se vc dissesse que está alterando a saída do lsusb aí sim, mas anular uma cpu só se essa versão do kernel tem esse comportamento.
URL de Referência