Fórum Debian

Versão Completa: Debian 9 não inicia o modo gráfico (RESOLVIDO)
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Amigos do forum, após instalar o Debian 9 resolvi alterar o arquivo "/etc/lightdm/lightdm.conf" e configurar login automático do meu usuário. Alterei, também, o arquivo "/usr/share/lightdm/lightdm.conf.d/01_debian.conf" para deixar o nunlock ativado na inicialização, após instalar o "numlockx". Nenhuma das opções funcionou. Então deixei tudo como estava mas agora o modo gráfico só entra quando dou o comando "startx".O sistema retorna o seguinte: "Filed to Light Display Manager". O comando "# systemctl status lightdm.service" retorna o seguinte:

● lightdm.service - Light Display Manager
Loaded: loaded (/lib/systemd/system/lightdm.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Mon 2018-02-26 08:27:33 -03; 20min ago
Docs: man:lightdm(1)
Process: 578 ExecStart=/usr/sbin/lightdm (code=exited, status=1/FAILURE)
Process: 573 ExecStartPre=/bin/sh -c [ "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/sbin/lightdm" ] (code=exited, status=0/SUCCESS)
Main PID: 578 (code=exited, status=1/FAILURE)

Como resolvo este pepino? Obrigado.
Amigos, consegui resolver o problema usando, em princípio, uma dica do Giovanni_Menezes, do VivaoLinux. Digo em princípio porque os arquivos de configuração constantes da sua postagem diferem dos atuais. Removi e purguei o lightdm, removi os diretórios dos arquivos de configuração /etc/lightdm e /usr/share/lightdm e reinstalei o lightdm. Obrigado a todos que tentaram ajudar.
Amigos, continuando minha pesquisa na internet encontrei este endereço sobre configuração do login automático. Usei e deu certo:

https://steemit.com/software/@kskarthik/...in-lightdm
URL de Referência