Fórum Debian

Versão Completa: iceweasel não abre alguns sites
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Boa noite amigos...estou com problemas no iceweasel...tem sites que ele não abre!

Exemplos de sites que não abrem:

http://www.google.com.br
http://www.g1.com.br

outros ele abre...exemplos de sites que ele ABRE:

http://www.forumdebian.com.br
http://www.uol.com.br


Estes são só algusn exemplos...eu já excluí a pasta .mozilla do home e também já excluí o browser com o comando apt-get --purge remove *iceweasel mas o erro persiste....

No navegador vivaldi, tudo ok...abrem todas as páginas.

Alguma sugestão?
Boa noite,

Inicialize o browser pela linha de comando, em modo interativo, e verifique se ele dá alguma mensagem de erro no terminal.
Eis a saída que ele me dá em duas circunstâncias diferentes:

~$iceweasel

(firefox:1630): Gtk-WARNING **: 22:26:31.121: Theme directory base/ of theme default.kde4 has no size field

1538011652397 addons.productaddons ERROR Request failed certificate checks: [Exception... "SSL is required and URI scheme is not https." nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 145" data: no]
NOT SANDBOXED
[fresh 1731] [NPP] {zilch} NPP_ClearSiteData site=(null), flags=0, maxAge=18446744073709551615
~$


num segundo momento:

~$iceweasel

(firefox:1757): Gtk-WARNING **: 22:28:00.935: Theme directory base/ of theme default.kde4 has no size field

NOT SANDBOXED
[fresh 3726] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 3726] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 3726] not implemented: PPB_BrokerTrusted;0.3
[fresh 3726] not implemented: PPB_AudioOutput(Dev);0.1
[fresh 3726] [PPB] {zilch} ppb_network_monitor_update_network_list
[fresh 3726] [PPB] {zilch} ppb_flash_set_instance_always_on_top instance=11, on_top=1
1538011742197 addons.productaddons ERROR Request failed certificate checks: [Exception... "SSL is required and URI scheme is not https." nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 145" data: no]
^C
~$
Boa noite,

Qual a saida do comando:

Código:
sudo ldd /usr/bin/iceweasel

Até mais!!!
~$ sudo ldd /usr/bin/iceweasel
[sudo] senha para supercharger:
linux-vdso.so.1 (0x00007fffc682b000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f1c55b75000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f1c55971000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f1c555f2000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f1c5525f000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f1c55048000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f1c54c8e000)
/lib64/ld-linux-x86-64.so.2 (0x0000565075288000)
~$
Bom dia,

Poste também a saida do comando:

Código:
sudo dpkg -s iceweasel

Até mais!!!
Boa noite...eis a saída:

~$ sudo dpkg -s iceweasel
[sudo] senha para supercharger:
Package: iceweasel
Status: install ok installed
Priority: extra
Section: oldlibs
Installed-Size: 235
Maintainer: Maintainers of Mozilla-related packages <[email protected]>
Architecture: all
Source: firefox-esr
Version: 52.9.0esr-1
Depends: firefox-esr
Description: Web browser based on Firefox - Transitional package
This is a transitional package, it can be safely removed.
~$
Boa noite,

Ok. Vamos ver a dependência do firefox-esr:

Código:
sudo dpkg -s firefox-esr

Até mais...
~$ sudo dpkg -s firefox-esr
[sudo] senha para supercharger:
Package: firefox-esr
Status: install ok installed
Priority: optional
Section: web
Installed-Size: 100785
Maintainer: Maintainers of Mozilla-related packages <[email protected]>
Architecture: amd64
Version: 45.4.0esr-2
Provides: gnome-www-browser, www-browser
Depends: libasound2 (>= 1.0.16), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.17), libcairo2 (>= 1.2.4), libdbus-1-3 (>= 1.9.14), libdbus-glib-1-2 (>= 0.78), libevent-2.0-5 (>= 2.0.10-stable), libffi6 (>= 3.0.4), libfontconfig1 (>= 2.11), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.20.0), libgtk2.0-0 (>= 2.24.0), libhunspell-1.4-0, libnspr4 (>= 2:4.10.9), libnss3 (>= 2:3.26), libpango-1.0-0 (>= 1.14.0), libsqlite3-0 (>= 3.7.12-1~), libstartup-notification0 (>= 0.8), libstdc++6 (>= 5.2), libvpx4 (>= 1.6.0), libx11-6, libxcomposite1 (>= 1:0.3-1), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxrender1, libxt6, zlib1g (>= 1:1.2.0), fontconfig, procps, debianutils (>= 1.16)
Recommends: gstreamer1.0-libav, gstreamer1.0-plugins-good
Suggests: fonts-stix | otf-stix, fonts-lmodern, mozplugger, libgssapi-krb5-2 | libkrb53, libgnomeui-0, libcanberra0
Breaks: xul-ext-torbutton
Conflicts: iceweasel (<< 45), j2re1.4, pango-graphite (<< 0.9.3)
Conffiles:
/etc/firefox-esr/firefox-esr.js 5ace09019aba06296dc21f574d444368
Description: Mozilla Firefox web browser - Extended Support Release (ESR)
Firefox ESR is a powerful, extensible web browser with support for modern
web application technologies.
Boa noite,

Estranho, estou com a mesma versão instalada e funciona normalmente. O seu sistema esta atualizado?

Código:
sudo aptitude update
sudo aptitude safe-upgrade
sudo aptitude reinstall iceweasel firefox-esr

Até mais!!!
Oi vadinho consegui resolver...foi só dar um

sudo apt-get install --reinstall iceweasel firefox-esr

e voltou a funcionar kkkkkkkkkkk.

Obrigado.
Boa noite,

Beleza!!!

Apenas mude o tópico para resolvido para servir como base para outros.

Até mais!!!
URL de Referência