Fórum Debian

Versão Completa: erro na instalacao do sarg (resolvido)
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Boa tarde
Nao estou conseguindo fazer a instalacao do sarg no ubuntu 6.0 server.
Erro na instalacao com apt-get e codigo fonte.
Segue erro:

pacotes a seguir têm dependências desencontradas:
libgd2-noxpm: Depende: libc6 (>= 2.7-1) mas 2.3.6-0ubuntu20.5 está para ser instalado
Depende: libfreetype6 (>= 2.3.5) mas nÃo vai ser instalado
Depende: libjpeg62 mas não vai ser instalado
Depende: libpng12-0 (>= 1.2.13-4) mas não vai ser instalado
sarg: Depende: libc6 (>= 2.3.6-6) mas 2.3.6-0ubuntu20.5 está para ser instalado

obrigado

Samuel
Olá, então, é uma versão velha e o sarg requer umas dependencias de pacotes que estão somente nos repositórios das versões mais novas, o que vc poderia tentar é adicionar o repositório do backport do hardy e tentar novamente fazer a instalação:

deb http://cz.archive.ubuntu.com/ubuntu hardy-backports main universe

não esquecendo de dar o aptitude update.
Fiz as atualizacoes desse repositorio e tambem desses e deu certo. Obrigado

deb http://br.archive.ubuntu.com/ubuntu/ dapper main restricted
deb-src http://br.archive.ubuntu.com/ubuntu/ dapper main restricted
deb http://br.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
deb-src http://br.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
deb http://br.archive.ubuntu.com/ubuntu/ dapper universe
deb-src http://br.archive.ubuntu.com/ubuntu/ dapper universe
deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted
deb http://security.ubuntu.com/ubuntu dapper-security universe
deb-src http://security.ubuntu.com/ubuntu dapper-security universe|
URL de Referência