Fórum Debian

Versão Completa: problemas tentando instalar gnome-app-install no etch
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
muito boa tarde,
resolvi colocar este post, pois encontrei muita informação no forum mas nenhuma que solucionase o meu problema. :cry:

Já baixei o gnome-app-install_0.5.5.1-1_all.deb, mais agora não consigo faze-lo instalar. Triste
qual seria o procedimento correto?

ou onde tem algum guia sobre como fazer este tipo de coisa?
o problema é por ele ser um pacote de lenny? e meu debian ser o etch? :?

tentei
Código:
apt-get install gnome-app-install_0.5.5.1-1_all.deb
no mesmo diretório mas não deu certo. :?

Tentei também comentar os repositorios do etch e colocar este:
Código:
deb http://ftp.de.debian.org/debian lenny main

mas ele queria me mexer em muitos aplicativos algo como 500 mb de pacotes seriam atualizados e eu acabei não permitindo de essa forma. :? Triste

por favor se puderem me indicar qual o camiho agradeço. Alegre

zum...
Vamos às explicações...

1. O APT-GET não serve para instalar pacotes .deb.
Você baixou um .deb, e deve instalá-lo com o DPKG:
Código:
dpkg -i gnome-app-install_0.5.5.1-1_all.deb

2. Se quiser instalar por APT-GET, não precisa fazer o download do pacote .deb. Ele baixa automaticamente:
Código:
apt-get install gnome-app-install

Sempre prefira instalar os pacotes pelo APT-GET. Tente primeiro por ele (como eu descrevi em 2) e se não der certo, tente o DPKG (como em 1). Se em ambos os casos der erro, posta aqui pra gente as mensagens de erro que fica mais fácil de ajudarmos...
Obrigado pelos esclarecimentos elieser_topassi
elieser_topassi Escreveu:Vamos às explicações...

1. O APT-GET não serve para instalar pacotes .deb.
Você baixou um .deb, e deve instalá-lo com o DPKG:
Código:
dpkg -i gnome-app-install_0.5.5.1-1_all.deb

2. Se quiser instalar por APT-GET, não precisa fazer o download do pacote .deb. Ele baixa automaticamente:
Código:
apt-get install gnome-app-install

Sempre prefira instalar os pacotes pelo APT-GET. Tente primeiro por ele (como eu descrevi em 2) e se não der certo, tente o DPKG (como em 1). Se em ambos os casos der erro, posta aqui pra gente as mensagens de erro que fica mais fácil de ajudarmos...

Usei a opção 2 e recebi Triste a seguinte resposta:
Código:
dpkg: problemas de dependência impedem configuração de gnome-app-install:
gnome-app-install depende de python-central (>= 0.6.7); porém:
  Versão de python-central no sistema é 0.5.12.
gnome-app-install depende de app-install-data (>= 0.4.0); porém:
  Pacote app-install-data não está instalado.
gnome-app-install depende de python-apt (>= 0.7.5); porém:
  Versão de python-apt no sistema é 0.6.19.
gnome-app-install depende de python-dbus; porém:
  Pacote python-dbus não está instalado.
gnome-app-install depende de python-gdbm; porém:
  Pacote python-gdbm não está instalado.
gnome-app-install depende de python-gtkhtml2; porém:
  Pacote python-gtkhtml2 não está instalado.
gnome-app-install depende de python-gtkmozembed; porém:
  Pacote python-gtkmozembed não está instalado.
gnome-app-install depende de python-gst0.10; porém:
  Pacote python-gst0.10 não está instalado.
gnome-app-install depende de python-gtk2 (>= 2.10.1); porém:
  Versão de python-gtk2 no sistema é 2.8.6-8.
gnome-app-install depende de python-sexy; porém:
  Pacote python-sexy não está instalado.
dpkg: erro processando gnome-app-install (--install):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante processamento de:
gnome-app-install
depois dei
Código:
apt-get install gnome-app-install
e Triste respondeu
Código:
Lendo lista de pacotes... Pronto
Construindo árvore de dependências... Pronto
gnome-app-install já é a versão mais nova.
Você deve querer executar `apt-get -f install' para corrigir isso:
Os pacotes a seguir têm dependências desencontradas:
  gnome-app-install: Depende: python-central (>= 0.6.7) mas 0.5.12 está para ser instalado
                     Depende: app-install-data (>= 0.4.0) mas não vai ser instalado
                     Depende: python-apt (>= 0.7.5) mas 0.6.19 está para ser instalado
                     Depende: python-dbus mas não vai ser instalado
                     Depende: python-gdbm mas não vai ser instalado
                     Depende: python-gtkhtml2 mas não está instalável
                     Depende: python-gtkmozembed mas não está instalável
                     Depende: python-gst0.10 mas não vai ser instalado
                     Depende: python-gtk2 (>= 2.10.1) mas 2.8.6-8 está para ser instalado
                     Depende: python-sexy mas não está instalável
E: Dependências desencontradas. Tente `apt-get -f install' sem nenhum pacote (ou especifique uma solução).
Imaginei que poderia usar o synaptic para instalar as vesões que esta pedindo e assim solucionaria o caso, então fui no synaptic e fiz a busca dos itens, porem as vesões que estão atualmente instaladas são as que aparecem ali, ou seja imagino que isto esteja acontecendo porque a versão do Debian que estou usando é a ETCH e assim como a aplicação ou programa que estou tentando instalar não consta ali, as vesões necessarias dos arquivos complementares também não.
Se for isso como posso fazer para baixar o arquivo .DEB deles? :?
Se não for isso, podem me explicar como funciona? :?

De qualquer forma agradeço muito a ajuda. E aguardo suas respostas. Alegre

zum...
Bom dia

bom, depois de baixar manualmente tudo o que pedia, fui instalar e novamente dentro daqueles pacotes geravan-se várias dependencias, assim que vi que seria uma bola de neve, desisti. :cry:
.... e voltei a instalar"lenny" :wink: , la não tem esse tipo de problema com estes programas. Alegre

obrigado igual

zum....
URL de Referência