Fórum Debian

Versão Completa: Quis deixar boot + rápido e fiz besteira (resolvido)
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Olá amigos... eu tenho um computador antigo com debian e toda vez no boot, ele parava em uma parte com os dizeres “starting MTA” e demorava um bocado para entrar...

Querendo deixar o boot + rápido, resolvi buscar na net como resolver o problema.

Na primeira pesquisa, a primeira opção que encontrei foi desativar a caixa “ativar rede ao iniciar”, nas configurações da rede...fiz isso e não adiantou...

Então, resolvi tentar a segunda alternativa que achei:

modificar o /etc/hostname inserindo uma linha com qualquer coisa .com, e foi o que eu fiz... deixei assim: “qiwuerpiofj.example.com”

fiz isso e a bagunça se instalou geral!!!!

No lugar de “qiwuerpiofj.example.com”, antes tinha os dizeres “supercharger”...tentei alterar o arquivo para voltar com esses dizeres, e qual a minha surpresa ao ver que não surtiu efeito nenhum... o arquivo alterou (ficou supercharger mesmo), mas o sistema continua bagunçado...

No boot agora ele trava nessas 3 partes:

1ª parte: Starting system log daemon: syslog

2ª parte: ppdev: user-space parallel port driver

3ª parte: Starting MTA

afffffff....agora além de travar no MTA ainda trava nesses outros dois...alguma dica para consertar o sistema? E se possível, depois de concertado, tirar esse MTA que atrasa o boot...

PS: o sistema está funcionando (o KDE está entrando)...mas o boot está demorando demais!
DRAGSTERTUNER,

Sei bem como é esse problema. Para resolvê-lo poste o conteúdo desses dois arquivos:

Código:
cat /etc/hosts
cat /etc/hostname

Tendo essas informações será possível ajudá-lo.
O arquivo /etc/hosts tá em branco...... :shock: !!!


O /etc/hostname tá assim:

supercharger


Alguma dica?
No arquivo hosts coloque ele assim:

Código:
127.0.0.1       localhost.localdomain   localhost supercharger

Para desabilitar o MTA, use esse comando:

Código:
chmod -x /etc/init.d/exim4

Veja se o seu boot fica mais rápido agora.
Quanto ao MTA o padrão do Debian é o EXIM e se vc não usa servidor de email nesta máquina é só desinstala-lo.

# apt-get remove --purge exim4 exim4-base exim4-config
Obrigado pelas dicas amigos funcionou...

Agora o boot está bem rápido...tá uma maravilha!
URL de Referência