Fórum Debian

Versão Completa: Problema na instalação da Webcam
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Boa noite:
Uso Kurumin 7.0 e tenho vivido uma situação parecida com a do colega almaolpsi.
Tenho uma camera fotográfica Lenoxx com função de webcam, que baixa as fotos normalmente, mas qdo ativo função webcam, não funciona.
Baixei o driver gspca (segundo o site é o substituto do spca5xx para a versão do Kernel que uso.), instalei segundo dica do Guia do Hardware http://www.guiadohardware.net/dicas/sup ... bcams.html ($make, #make install), adicionei no aquivo modules e... nada.
Quando dá o boot aparece o driver nas mensagens de boot e lá em baixo um pouco antes do bootsplash vem a mensagem "FATAL Driver gspca.ko not found"
Quando uso o Camstream, nada. No Mercury, também não acha nada. Seguí as dicas do dmatrix (lsusb e lsmod) e a camera aparece lá:

Bus 002 Device 001: ID 0000:0000
Bus 001 Device 002: ID 04fc:5330 Sunplus Technology Co., Ltd
Bus 001 Device 001: ID 0000:0000
[email protected]_Bigdaddy:~$ lsmod
Module Size Used by
xt_limit 2304 8
ipt_LOG 6272 8
ipt_MASQUERADE 2816 0
ip_nat 14508 1 ipt_MASQUERADE
ipt_TOS 2048 0
ipt_REJECT 4224 1
ip_conntrack_irc 5360 0
ip_conntrack_ftp 6256 0
xt_state 2048 6
ip_conntrack 43828 5 ipt_MASQUERADE,ip_nat,ip_conntrack_irc,ip_conntrack_ftp,xt_state
nfnetlink 5144 2 ip_nat,ip_conntrack
iptable_filter 2432 1
ipt_TCPMSS 3712 0
xt_tcpmss 2176 0
xt_tcpudp 3200 6
iptable_mangle 2432 0
ip_tables 11592 2 iptable_filter,iptable_mangle
x_tables 10628 10 xt_limit,ipt_LOG,ipt_MASQUERADE,ipt_TOS,ipt_REJECT,xt_state,ipt_TCPMSS,xt_tcpmss​,xt_tcpudp,ip_tables
pppoe 9792 2
pppox 2952 1 pppoe
lp 9800 0
nvidia 4702292 22
ipv6 231520 14
af_packet 16136 2
ppp_generic 23444 6 pppoe,pppox
slhc 6528 1 ppp_generic
thermal 11016 0
fan 3588 0
button 5136 0
ac 3844 0
battery 7940 0
sis900 19328 0
mii 4736 1 sis900
gspca 663248 0
videodev 20864 1 gspca
v4l1_compat 13572 1 videodev
v4l2_common 19840 1 videodev
acpi_cpufreq 5260 0
processor 19500 2 thermal,acpi_cpufreq
cpufreq_powersave 1664 0
cpufreq_performance 1920 0
cpufreq_ondemand 4976 0
freq_table 3844 1 acpi_cpufreq
fuse 36756 0
ppdev 7172 0
tsdev 6208 0
snd_mpu401 6120 0
snd_seq_dummy 2820 0
snd_seq_oss 28544 0
snd_seq_midi 6432 0
snd_trident 35492 1
snd_seq_midi_event 6400 2 snd_seq_oss,snd_seq_midi
snd_ac97_codec 85280 1 snd_trident
snd_ac97_bus 2176 1 snd_ac97_codec
snd_pcm_oss 38432 0
snd_mixer_oss 13824 1 snd_pcm_oss
snd_pcm 66312 3 snd_trident,snd_ac97_codec,snd_pcm_oss
snd_seq 44752 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_page_alloc 7560 2 snd_trident,snd_pcm
snd_util_mem 3584 1 snd_trident
snd_mpu401_uart 6656 2 snd_mpu401,snd_trident
snd_timer 19204 2 snd_pcm,snd_seq
snd_rawmidi 19488 2 snd_seq_midi,snd_mpu401_uart
snd_seq_device 6412 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_trident,snd_seq,snd_rawmidi
analog 9760 0
gameport 11272 3 snd_trident,analog
snd 41828 14 snd_mpu401,snd_seq_oss,snd_trident,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_​pcm,snd_seq,snd_mpu401_uart,snd_timer,snd_rawmidi,snd_seq_device
parport_pc 35300 1
parport 30536 3 lp,ppdev,parport_pc
psmouse 33928 0
soundcore 7392 1 snd
8250_pnp 8576 0
8250 18340 1 8250_pnp
serial_core 17408 1 8250
shpchp 31772 0
pci_hotplug 27192 1 shpchp
i2c_sis630 6540 0
i2c_core 16656 2 nvidia,i2c_sis630
serio_raw 5252 0
pcspkr 2560 0
ohci_hcd 18436 0
usbcore 107012 3 gspca,ohci_hcd
sis_agp 6148 1
agpgart 25264 2 nvidia,sis_agp
evdev 7680 0
[email protected]_Bigdaddy:~$

De antemão agradeço a ajuda.

almagno
Olá, acho que está compilando errado, leia o readme do tarball.
veja se está utilizando a ultima versão: http://mxhaard.free.fr/spca50x/Download ... 224.tar.gz
extraia e entre no diretório:
~$ cd gspcav1-20071224
~/gspcav1-20071224$

agora utilize o construtor se possível com o sudo:
$ sudo ./gspca_build

observe que aqui neste ponto em diante não podem ocorrer erros graves e depois teste com o ekiga se está funcionando.
URL de Referência