Fórum Debian

Versão Completa: Dual boot no lilo (Debian e Win7)
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Boas...

Estou a tentar instalar no meu portátil, o debian e windows.... O meu portátil tem dois discos sata...

No sda instalei o debian
no sdb instalei o windows 7

as configurações que fiz foi:
Código:
boot=/dev/sda

vga=normal

prompt
timeout=100

map=/boot/map
#################
default=Linux

image=/vmlinuz
  label=Linux
  initrd=/initrd.img
  root=/dev/sda1
  read-only

other=/dev/sdb1
label=Seven
table=/dev/sdb

no sdb quando instalei o windows7 foi criado automaticamente uma partição de 100mb que fica oculta (sdb1). e é para essa partição que estou a apontar no lilo.

quando arranco o debian tudo corre bem, mas quando arranque o windows7 o windows fica parado no ecran preto iniciar que aparece com a bandeira do windows e a dizer "windows a inicar"...

alguém sabe como faço para fazer o lilo arrancar o windows7???
num tenho certeza se vai dar certo mas aqui quando utilizava o Vista as linhas que colocava no lilo eram:
other=/dev/sda1
label=Windows.Vista
loader=/boot/chain.b

talvez se fizesse semelhante, funcione aí

Interessante...primeira vez que fico sabendo de um portátil com 2 hds, é hd externo? Que marca/modelo é esse portátil?
dmatrix Escreveu:num tenho certeza se vai dar certo mas aqui quando utilizava o Vista as linhas que colocava no lilo eram:
other=/dev/sda1
label=Windows.Vista
loader=/boot/chain.b

talvez se fizesse semelhante, funcione aí


oi amigo tentei fazer o que disseste mas não resultou

Código:
boot=/dev/sda

vga=normal

prompt
timeout=100

map=/boot/map
#################
default=Linux

image=/vmlinuz
  label=Linux
  initrd=/initrd.img
  root=/dev/sda1
  read-only

other=/dev/sdb1
  label=Seven
#  table=/dev/sdb
  loader=/boot/chain.b

já tentei tudo e mais alguma coisa.... será que o grub resolve o meu problema??? o que aconselham??? grup ou lilo?



Citar:Interessante...primeira vez que fico sabendo de um portátil com 2 hds, é hd externo? Que marca/modelo é esse portátil?
sim o meu tem dois discos de 200gb cada... o meu portatil é um toshiba satelite a200-226 http://pt.computers.toshiba-europe.com/ ... D=147963#0
opa...grub funciona fácil isso, mas me explica uma coisa, vc instalou o debian e depois o seven? esse Debian é tão antigo assim que o gerenciador dele é o Lilo? Bom o Seven costuma ser meio chatinho e num gosta muito que se altere alguns arquivos de loader dele, é possível que voce tenha que reparar o loader (boot) do Seven, acho que inicializado as ferramentas de reparação do cd resolve isso, assim repara deixando ele rodar como se num existisse o Debian, daí depois disso feito, você tenta instalar o Lilo e configura-lo. É provável esteja faltando algum arquivo de inicialização do Seven.
o debian que estou a usar é o 5... mas coloquei do lilo porque sempre gostei dele.... e sim eu instalei o debian depois do seven e também já reparei que o boot do seven está danificado... só ainda não percebi porque... porque eu já instalei e reinstalei umas 5 vezes tudo de raiz e tenho certeza que não mando o lilo escrever por cima do boot do windows....

também já tentei recuperar o boot com a ferramenta de recuperação do cd instalação e não tive sucesso....

vou agora testar o grub
talvez exista uma incompatibilidade do lilo com o seven, que eu sei o grub funciona com o seven, estou usando desta forma sem problemas. ok, voce pode fazer o seguinte, instalar o debian depois do seven, mas instalando o grub na mbr, depois de visto que está tudo funcionando, tentar instalar o Lilo. Outro problema que vi é que está instalando o Seven no 2 hd, normalmente o Seven joga alguns arquivos na unidade 1 e se voce formatar para instalar o 1 hd, vai quebrar o boot do seven. Eu num estou certo de como resolver o seu problema, pois no meu caso o Seven está instalado na primeira partição do meu primeiro hd apesar de o grub estar na mbr. Talvez se tivesse como voce desativar o primeiro hd e instalar o Seven pode ser que impediria que o instalador do Seven gravasse algo nele.
Depois de muito tentar la consegui por por o linux e win7 no meu portátil... tive de esquecer o lilo e usar o grub como me aconselharam.... e pronto problema resolvido...

deixo aqui a minha configuração para quem querer fazer o mesmo que eu:
Código:
default         0

timeout         5

color cyan/blue white/blue

# Sistemas
title           Linux (Debian)
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.26-2-686 root=/dev/sda1 ro quiet
initrd          /boot/initrd.img-2.6.26-2-686

title           Windows Seven
root            (hd1,0)
savedefault
makeactive
map             (hd0) (hd1)
map             (hd1) (hd0)
chainloader     +1
URL de Referência