Fórum Debian

Versão Completa: kernel travando no Boot
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Olá pessoal,

compilei um novo kernel, todo configuradinho tal, mas na hora de bootar ao subir os modulos USB do teclado e dos mouses conectador à máquina o boot simplesmente interrompe e fica nakela.

Já reconfigurei o kernel botando as opções USB tudo como módulos mas ainda assim não boota. Também já copiei as config do kernel atual e absurdamente continua travando no mesmo ponto.

Preciso de ajuda, por favor.

Uso o Debian Sarge.
Qual o processador? mudou a estrutura ou é a i386? tente colocar na linha do kernel no grub opções como:
pnpacpi=off noapic nolapic
veja se inicializando em modo de segurança se inicializa.
Altere na bios as opções de USB ponha tudo em disable.
o processador eh um p4 HT 3.2 GHz, eu tentei entrar em modo de segurança mas dae ele trabou numa tela de waiting for filesystem !?!?

jah tinha aparecido antes mais ia beleza ... será que é pq o meu /usr tá numa partição separada !????

Obrigado
por estar em partição separada não mas pode estar sendo referenciado a partição errada.
como está configurado a linha do kernel no grub? exemplo:
kernel /boot/vmlinuz-2.6.16-2-686 root=/dev/hda1 ro

dê um boot com um cdlive e verifique as partições como estão distribuídas. me parece que deve estar errado ou faltando o tag root=dev/hda1
Não meu grub tá certinho:

Código:
title        Debian GNU/Linux, kernel 2.6.21-c1
root        (hd0,4)
kernel        /boot/vmlinuz-2.6.21-c1 root=/dev/sda5 ro vga=791
initrd        /boot/initrd.img-2.6.21-c1
savedefault

title        Debian GNU/Linux, kernel 2.6.21-c1 (recovery mode)
root        (hd0,4)
kernel        /boot/vmlinuz-2.6.21-c1 root=/dev/sda5 ro vga=791 single
initrd        /boot/initrd.img-2.6.21-c1
savedefault

title        Debian GNU/Linux, kernel 2.6.18-4-686
root        (hd0,4)
kernel        /boot/vmlinuz-2.6.18-4-686 root=/dev/sda5 ro vga=791
initrd        /boot/initrd.img-2.6.18-4-686
savedefault

title        Debian GNU/Linux, kernel 2.6.18-4-686 (recovery mode)
root        (hd0,4)
kernel        /boot/vmlinuz-2.6.18-4-686 root=/dev/sda5 ro vga=791 single
initrd        /boot/initrd.img-2.6.18-4-686
savedefault

O kernel 2.6.18-4-686 é o kernel ativo, (funcionando) o outro o 2.6.21 é o que está dando o waiting for filesystem.

Será que terei que criar akele tal System.map para o kernel2.6.21 !?? se sim como faço ??

Obrigado.
opa, não tem o System.map no /boot ? pode ser isso então, aqui sempre criou automaticamente esses arquivos quando compilei.
Veja se ele existe e então copie do provável caminho /usr/src/linux/System.map para pasta /boot/System.map-2.6.x.x
Poooouxa kara não existe o System.map, e tipow eu reconfigurei o kernel e fiz o make modules e o make modules_install ... e bahhh nadaaa não cria nenhum System.map ....

e agora ... nao sei mais como "proceder" ahahaha

Vlws caraaa .... por estar ajudando.
acho que alterou algo no .config do kernel que desabilitou a criação disto, talvez seria melhor, se for o caso utilizar o .config antigo e fazer o make oldconfig antes dos makes.
Vou pegar uma carona aqui. Já pesquisei e não achei. Compilei o kernel, coisa que por incrível que pareça, em anos de Linux, nunca havia feito, pois nunca vi necessidade. Mas agora precisei por causa de um problema na placa no som do meu notebook

Mas não consigo inicializar pelo novo kernel. O problema é o mesmo do amigo aí em cima. "WAITING FOR FILE SYSTEM..."

Não achei nenhum problema no menu.lst nem no device.map. Também parece ter tudo que é necessário em /boot.

Pavilion:/home/carlos# ls -l /boot
total 36772
-rw-r--r-- 1 root root 70781 2007-05-09 19:14 config-2.6.18-4-686
-rw-r--r-- 1 root root 70682 2007-12-24 13:58 config-2.6.18-5-686
-rw-r--r-- 1 root root 70682 2008-01-23 00:40 config-2.6.18-6-686
-rw-r--r-- 1 root root 75915 2008-02-09 20:12 config-2.6.23-custom
drwxr-xr-x 2 root root 4096 2008-02-09 23:33 grub
-rw-r--r-- 1 root root 4899711 2008-01-08 11:26 initrd.img-2.6.18-4-686
-rw-r--r-- 1 root root 4496522 2008-01-08 07:38 initrd.img-2.6.18-4-686.bak
-rw-r--r-- 1 root root 4900667 2008-01-08 11:28 initrd.img-2.6.18-5-686
-rw-r--r-- 1 root root 4900856 2008-01-08 10:36 initrd.img-2.6.18-5-686.bak
-rw-r--r-- 1 root root 4900398 2008-01-30 08:27 initrd.img-2.6.18-6-686
-rw-r--r-- 1 root root 4963668 2008-02-09 21:29 initrd.img-2.6.23-custom
-rw-r--r-- 1 root root 722037 2007-05-10 01:14 System.map-2.6.18-4-686
-rw-r--r-- 1 root root 723178 2007-12-24 19:36 System.map-2.6.18-5-686
-rw-r--r-- 1 root root 723178 2008-01-23 06:38 System.map-2.6.18-6-686
-rw-r--r-- 1 root root 819202 2008-02-10 16:55 System.map-2.6.23-custom
-rw-r--r-- 1 root root 1261213 2007-05-10 01:14 vmlinuz-2.6.18-4-686
-rw-r--r-- 1 root root 1260371 2007-12-24 19:36 vmlinuz-2.6.18-5-686
-rw-r--r-- 1 root root 1260374 2008-01-23 06:38 vmlinuz-2.6.18-6-686
-rw-r--r-- 1 root root 1369048 2008-02-09 20:58 vmlinuz-2.6.23-custom
Pavilion:/home/carlos#

Alguém sabe o que estou fazendo de errado?

Obrigado,
cabr
cabr Escreveu:Vou pegar uma carona aqui. Já pesquisei e não achei. Compilei o kernel, coisa que por incrível que pareça, em anos de Linux, nunca havia feito, pois nunca vi necessidade. Mas agora precisei por causa de um problema na placa no som do meu notebook

Mas não consigo inicializar pelo novo kernel. O problema é o mesmo do amigo aí em cima. "WAITING FOR FILE SYSTEM..."

Não achei nenhum problema no menu.lst nem no device.map. Também parece ter tudo que é necessário em /boot.

Pavilion:/home/carlos# ls -l /boot
total 36772
-rw-r--r-- 1 root root 70781 2007-05-09 19:14 config-2.6.18-4-686
-rw-r--r-- 1 root root 70682 2007-12-24 13:58 config-2.6.18-5-686
-rw-r--r-- 1 root root 70682 2008-01-23 00:40 config-2.6.18-6-686
-rw-r--r-- 1 root root 75915 2008-02-09 20:12 config-2.6.23-custom
drwxr-xr-x 2 root root 4096 2008-02-09 23:33 grub
-rw-r--r-- 1 root root 4899711 2008-01-08 11:26 initrd.img-2.6.18-4-686
-rw-r--r-- 1 root root 4496522 2008-01-08 07:38 initrd.img-2.6.18-4-686.bak
-rw-r--r-- 1 root root 4900667 2008-01-08 11:28 initrd.img-2.6.18-5-686
-rw-r--r-- 1 root root 4900856 2008-01-08 10:36 initrd.img-2.6.18-5-686.bak
-rw-r--r-- 1 root root 4900398 2008-01-30 08:27 initrd.img-2.6.18-6-686
-rw-r--r-- 1 root root 4963668 2008-02-09 21:29 initrd.img-2.6.23-custom
-rw-r--r-- 1 root root 722037 2007-05-10 01:14 System.map-2.6.18-4-686
-rw-r--r-- 1 root root 723178 2007-12-24 19:36 System.map-2.6.18-5-686
-rw-r--r-- 1 root root 723178 2008-01-23 06:38 System.map-2.6.18-6-686
-rw-r--r-- 1 root root 819202 2008-02-10 16:55 System.map-2.6.23-custom
-rw-r--r-- 1 root root 1261213 2007-05-10 01:14 vmlinuz-2.6.18-4-686
-rw-r--r-- 1 root root 1260371 2007-12-24 19:36 vmlinuz-2.6.18-5-686
-rw-r--r-- 1 root root 1260374 2008-01-23 06:38 vmlinuz-2.6.18-6-686
-rw-r--r-- 1 root root 1369048 2008-02-09 20:58 vmlinuz-2.6.23-custom
Pavilion:/home/carlos#

Alguém sabe o que estou fazendo de errado?

Obrigado,
cabr

Olá, o seu caso é diferente, é algo relacionado ao fucionamento dos irqs, está utilizando alguma opção na linha do kernel no menu.lst?
Não, nenhuma opção. Alguma sugestão?

cabr
cabr Escreveu:Não, nenhuma opção. Alguma sugestão?

cabr
já tentou colocar o noapic nolapic ?
nossa, to com esse mesmo problema, ja recompilei o kernel 3 vezes, de forma diferente, chegando em paginas diferentes com dicas diferentes.
bom, o q eu pude notar é q não esta montando o sata! tenteui montar manualmente depois q ele entra no prompt (nao sei se verificou, se esperar uns 5min ele cai num prompt) mas qdo dou o mount /dev/sda7 ele da such file or directory not found.
o q pude entender é que nao foi compilado o suporte a sata, mas em uma das vexzes q fiz o make menuconfig, eu marquei ele!
bom se alguem souber como resolver isso fico muito grato
msn: andre arroba focus.inf.br
URL de Referência