Fórum Debian

Versão Completa: Instalar mplayer
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Ei pessoal, estou tentando instalar o Mplayer 1.0rc, porém quando dou um "make" recebo vários erros:
Código:
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_key_file_get_integer'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_key_file_load_from_file'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_file_set_contents'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_option_context_set_main_group'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_type_register_static_simple'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_option_group_set_parse_hooks'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_filename_display_basename'/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_utf8_collate_key_for_filename'
/usr/lib/libpango-1.0.so: undefined reference to `g_key_file_get_value'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_intern_static_string'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_option_context_set_help_enabled'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_option_context_parse'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_option_context_add_group'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_key_file_free'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_get_language_names'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_get_host_name'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_key_file_new'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_option_context_set_ignore_unknown_options'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_object_compat_control'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_key_file_get_locale_string'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_key_file_get_integer_list'/usr/lib/libpango-1.0.so: undefined reference to `g_slice_free_chain_with_offset'
/usr/lib/libpangocairo-1.0.so: undefined reference to `g_slice_alloc'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_key_file_get_string'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_assert_warning'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_option_group_set_translation_domain'
/usr/lib/libpango-1.0.so: undefined reference to `g_key_file_get_keys'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_mapped_file_free'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_mapped_file_new'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_key_file_get_string_list'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_key_file_set_list_separator'
/usr/lib/libpangocairo-1.0.so: undefined reference to `g_slice_alloc0'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_get_user_data_dir'
/usr/lib/libpango-1.0.so: undefined reference to `g_key_file_get_groups'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_filename_display_name'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_option_error_quark'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_option_group_new'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_uri_list_extract_uris'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_option_context_new'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_get_system_data_dirs'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_strv_length'
/usr/lib/libpangocairo-1.0.so: undefined reference to `g_slice_free1'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_unlink'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_mapped_file_get_contents'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_option_context_free'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_option_context_add_main_entries'
/usr/lib/libpango-1.0.so: undefined reference to `g_access'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_option_group_add_entries'
/usr/lib/libgtk-x11-2.0.so: undefined reference to `g_return_if_fail_warning'
collect2: ld returned 1 exit status
make: ** [mplayer] Erro 1

Alguém tem alguma sugestão???
Bom, aconselho que você instale à "moda" Debian, insiraeste repositório em seu sources.list:
Código:
deb http://www.debian-multimedia.org stable main
Execute o comando:
Código:
apt-get update
Logo em seguida:
Código:
apt-get install mplayer mplayer-skin-blue mencoder w32codecs mplayer-codec
Certo, bom, na verdade eu já estou com o mplayer instalado, mas o problema é que ele foi compilado sem suporte ao libmp3lame e por isso, quando tento usar o mencoder recebo a seguinte mensagem de erro:
Código:
MPlayer was compiled without libmp3lame support.
-lameopts is not an MEncoder option

Exiting... (error parsing command line)
Por acaso seriam essas bbliotecas?

libtwolame-dev
libtwolame0
Acredito que seja a liblame0. Acontece que eu tenho esssas bibliotecas instaladas e o mesmo problema com o mencoder.
Um passo que poderia dar certo, desinstalar , e logo em seguida reinstalar tudo novamente ...
Reinstalei e continuo com o mesmo problema
Verifique se no seu diretório pessoal, existe o diretório .mplayer, caso exista exclua ...
URL de Referência