Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Varias Duvidas
25/08/2006, 19:15
Resposta: #1
Varias Duvidas
Possuo um computador com processador amd64, 512MB de ram, Geforce 2 440 64MB, HD SATA 80gb (10gb para o Debian), e para isso, baixei o debian sarge para amd64.

Sou um tanto novato nesta áarea, e estou enfrentando alguns problemas.

Instalei o Debian para usar no dia-a-dia, como desktop, então preciso de programas como, Gerenciador de Downloads, Firefox, Amule, Amsn,Openoffice, Thunderbird, Algum editor simples HTML\PHP, entre outras coisas...

E atualmente ferramentas para programar em C (o bom e velho gcc) (ja que o rwindows não está compilando, acho que é algo como o pascal, que prescisa de um compilador diferente para os amd's 64) e futuramente algumas ferramentas para desenvolvimento em java.

Bom, Vamos aos problemas:

- No KDE como no GNOME, no Debian como no Slackware, o mouse fica louco, mas só as vezes, movendo sozinho e dando clicks. Ele é um mouse PS2 óptico da Satellite, 2 botões e a rodinha scroll, não sei o modelo exatamente.

- Quando tento baixar algum pacote, acontece varios erros (a seguir). Creio eu, que esteja relacionado ao arquivo sources.list

Citar:# apt-get install mozilla-firefox
Lendo Lista de Pacotes... Pronto

Construindo Árvore de Dependências... Pronto
Você deve querer rodar `apt-get -f install' para corrigir isso:
Os pacotes a seguir têm dependências desencontradas:
synaptic: Depende: libapt-inst-libc6.3-6-1.1 mas não está instalável
Depende: libapt-pkg-libc6.3-6-3.11 mas não está instalável
Depende: libatk1.0-0 (>= 1.12.1) mas 1.8.0-4 está para ser instalado
Depende: libc6 (>= 2.3.5-1) mas 2.3.2.ds1-22 está para ser instalado
Depende: libcairo2 (>= 1.2.0) mas não está instalável
Depende: libgcc1 (>= 1:4.1.0) mas 1:3.4.3-13 está para ser instalado
Depende: libglade2-0 (>= 1:2.5.1) mas 1:2.4.2-2 está para ser instalado
Depende: libglib2.0-0 (>= 2.10.0) mas 2.6.4-1 está para ser instalado
Depende: libgtk2.0-0 (>= 2.8.0) mas 2.6.4-3 está para ser instalado Depende: libncurses5 (>= 5.4-5) mas 5.4-4 está para ser instalado Depende: libpango1.0-0 (>= 1.12.3) mas 1.8.1-1 está para ser instalado
Depende: libstdc++6 (>= 4.1.0) mas 3.4.3-13 está para ser instalado Depende: libvte4 (>= 1:0.12.1) mas 1:0.11.12-1 está para ser instalado
Depende: libxfixes3 mas não está instalável
Depende: libxinerama1 mas não está instalável
Depende: libxml2 (>= 2.6.26) mas 2.6.16-7 está para ser instalado
W: Não foi possível checar a lista de pacotes fonte http://security.debian.org testing/updates/main Packages (/var/lib/apt/lists/security.debian.org_dists_testing_updates_main_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrado)
W: Não foi possível checar a lista de pacotes fonte http://ftp.br.debian.org testing/main Packages (/var/lib/apt/lists/ftp.br.debian.org_debian_dists_testing_main_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrado)W: Não foi possível checar a lista de pacotes fonte http://ftp.br.debian.org testing/contrib Packages (/var/lib/apt/lists/ftp.br.debian.org_debian_dists_testing_contrib_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrado)W: Não foi possível checar a lista de pacotes fonte http://ftp.br.debian.org testing/non-free Packages (/var/lib/apt/lists/ftp.br.debian.org_debian_dists_testing_non-free_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrado)W: Não foi possível checar a lista de pacotes fonte http://public.planetmirror.com sarge/main Packages (/var/lib/apt/lists/public.planetmirror.com_pub_debian-amd64_debian_dists_sarge_main_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrado)
W: Não foi possível checar a lista de pacotes fonte http://public.planetmirror.com sarge/contrib Packages (/var/lib/apt/lists/public.planetmirror.com_pub_debian-amd64_debian_dists_sarge_contrib_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrado)
W: Não foi possível checar a lista de pacotes fonte http://ftp.cl.debian.org sarge/main Packages (/var/lib/apt/lists/ftp.cl.debian.org_debian-amd64_debian_dists_sarge_main_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrado)
W: Não foi possível checar a lista de pacotes fonte http://ftp.cl.debian.org sarge/contrib Packages (/var/lib/apt/lists/ftp.cl.debian.org_debian-amd64_debian_dists_sarge_contrib_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrado)
W: Não foi possível checar a lista de pacotes fonte http://ftp2.de.debian.org sarge/main Packages (/var/lib/apt/lists/ftp2.de.debian.org_debian-amd64_debian_dists_sarge_main_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrado)
W: Não foi possível checar a lista de pacotes fonte http://ftp2.de.debian.org sarge/contrib Packages (/var/lib/apt/lists/ftp2.de.debian.org_debian-amd64_debian_dists_sarge_contrib_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrado)
W: Não foi possível checar a lista de pacotes fonte http://ftp.es.debian.org sarge/main Packages (/var/lib/apt/lists/ftp.es.debian.org_debian-amd64_debian_dists_sarge_main_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrado)
W: Não foi possível checar a lista de pacotes fonte ftp://ftp2.caliu.info sarge/main Packages (/var/lib/apt/lists/ftp2.caliu.info_debian-amd64_debian_dists_sarge_main_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrado)W: Não foi possível checar a lista de pacotes fonte ftp://ftp2.caliu.info sarge/contrib Packages (/var/lib/apt/lists/ftp2.caliu.info_debian-amd64_debian_dists_sarge_contrib_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrad o)
W: Não foi possível checar a lista de pacotes fonte http://ftp.nl.debian.org sarge/main Packages (/var/lib/apt/lists/ftp.nl.debian.org_debian-amd64_debian_dists_sarge_main_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrado)
W: Não foi possível checar a lista de pacotes fonte http://bach.hpc2n.umu.se sarge/main Packages (/var/lib/apt/lists/bach.hpc2n.umu.se_debian-amd64_debian_dists_sarge_main_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrado)
W: Não foi possível checar a lista de pacotes fonte http://bach.hpc2n.umu.se sarge/contrib Packages (/var/lib/apt/lists/bach.hpc2n.umu.se_debian-amd64_debian_dists_sarge_contrib_binary-amd64_Packages) - stat (2 Arquivo ou diretório não encontrado)
W: Você terá que executar apt-get update para corrigir esses arquivos faltososE: Dependências desencontradas. Tente `apt-get -f install' sem nenhum pacote (ou especifique uma solução).

- Não consigo instalar o XFCE, além de não conseguir baixar os pacotes (por causa do erro anterior) também não sei o que devo configurar. Quero instalar o XFCE pois usava-o quando eu era usuário do Slackware.

Me ajudem, Não sei o que faço
Devo atualizar o Debian de Sarge para Etch?


Abraços e Obrigado... :wink:
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/08/2006, 19:19
Resposta: #2
Source.list
Meu Source.list:

Citar:deb file:///cdrom/ sarge main

#deb cdrom:[Debian GNU/Linux 3.1 r0a _Sarge_ - Official amd64 Binary-1 (20050613)]/ unstable contrib main

deb http://security.debian.org/ testing/updates main
deb http://ftp.br.debian.org/debian/ testing main contrib non-free

#PACOTES VLC VIDEOLAN
#deb http://download.videolan.org/pub/videolan/debian woody main
#deb-src http://download.videolan.org/pub/videolan/debian woody main
#deb http://download.videolan.org/pub/videolan/debian sarge main
#deb-src http://download.videolan.org/pub/videolan/debian sarge main
#deb http://download.videolan.org/pub/videolan/debian sid main
#deb-src http://download.videolan.org/pub/videolan/debian sid main

#PACOTES XFCE
#deb http://www.os-works.com/debian testing main
#deb-src http://www.os-works.com/debian testing main

#REPOSITORIOS AMD64
deb http://debian.inode.at/debian-amd64/debian/ sarge main contrib
deb http://debian.sil.at/debian-amd64/debian/ sarge main contrib
deb http://public.planetmirror.com/pub/debian-amd64/debian/ sarge main contrib
deb http://mirror.pacific.net.au/linux/debian-amd64/debian/ sarge main contrib
deb http://bytekeeper.as28747.net/debian-amd64/debian/ sarge main contrib
deb http://ftp.belnet.be/debian-amd64/debian/ sarge main contrib
deb ftp://mirror.switch.ch/mirror/debian-amd64/debian/ sarge main contrib
deb http://ftp.cl.debian.org/debian-amd64/debian/ sarge main contrib
deb http://ftp.de.debian.org/debian-amd64/debian/ sarge main contrib
deb http://ftp2.de.debian.org/debian-amd64/debian/ sarge main contrib
deb http://debian.tu-bs.de/debian-amd64/debian/ sarge main contrib
deb http://debian.mrstec.de/debian-amd64/debian/ sarge main contrib
deb http://ftp.es.debian.org/debian-amd64/debian/ sarge main contrib
deb ftp://ftp2.caliu.info/debian-amd64/debian/ sarge main contrib
deb http://ftp.crans.org/debian-amd64/debian/ sarge main contrib
deb http://ftp.iut-bm.univ-fcomte.fr/debian-amd64/debian/ sarge main contrib
deb http://ftp.jp.debian.org/debian-amd64/debian/ sarge main contrib
deb http://hanzubon.jp/debian-amd64/debian/ sarge main contrib
deb http://ftp.nl.debian.org/debian-amd64/debian/ sarge main contrib
deb http://bach.hpc2n.umu.se/debian-amd64/debian/ sarge main contrib
deb http://ftp.sk.debian.org/debian-amd64/debian/ sarge main contrib
deb http://ftp.tr.debian.org/debian-amd64/debian/ sarge main contrib
deb http://kalug.linux.org.tw/debian-amd64/debian/ sarge main contrib
deb http://mirror.espri.arizona.edu/debian-amd64/debian/ sarge main contrib
deb http://debian.csail.mit.edu/debian-amd64/debian/ sarge main contrib


Trecho do /etc/X11/XF86Config-4:

Citar:Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/08/2006, 23:43
Resposta: #3
 
Olá,

Quanto ao primeiro problema, tente rodar

Código:
apt-get update

E depois instalar o firefox. Veja se resolve.

Quanto ao seguinte problema, tente deixar o /etc/X11/XF86Config-4 assim

Código:
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Caso ainda não funcione, volte a postar.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/08/2006, 03:13
Resposta: #4
 
antes de tudo, so acho que sua abordagem ao Windows é errada, porque dizer ruindows? ele atende suas necessidades, se não você não estaria usando. a filosofia do software livre é para mostrar aos usuários da grande rede o que temos como opção e não como munição para uma guerra.

então, sobre o mouse, isso me acontecia mas era apenas um mal contato no plug ps/2 no pc.

sobre suas dependencias, o comando que o fernando mostrou tira seus problemas, pelo menos deve diminuir em boa part essa lista.

http://blog.forumdebian.com.br/kayohf/
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/08/2006, 11:04
Resposta: #5
 
Já usei esse comando apt-get update, e não resolve. Fala que não é possivel baixar a lista de pacotes e blá blá blá, não estou em casa, quando voltar edito esse post com o erro completo e testo o mouse com as alterações.

Sobre o windows, não estou dizendo que é ruim, mas ele não atende todas minhas necessidades. Principalmente para mim, que trabalho com transações bancárias, e de moedas eletrônicas como paypal e egold e estou vulnerável a trojans e keyloggers.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/08/2006, 17:20
Resposta: #6
 
Mas que ruim é...valeu!

!Debian = Gnu/Linux = Freedom!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/08/2006, 12:34
Resposta: #7
 
Comprei um novo mouse, tabém PS2, optico e com scroll. Mas dessa vez é um Dr Hank, pois os satellites estão me decepcionando, é o segundo que estraga.

Mas como eu disse, o problema não é no mouse, e sim nas configurações, pois no windows ele funciona perfeitamente.

Fiz as alterações no /etc/X11/XF86Config-4.
Pelo poucos minutos que estou usando agora, ele não está se mexendo sozinho como antes, mas agora ele não me obedece sempre, ele está dando umas travadas enquanto eu o movimento. E enquanto eu estou digitando essa mensagem, ele ta se movendo de um lado para o outro, numa margem de 15 pixels +\-...

Fui dar o apt-get update novamente, e olha o erro que deu:

Citar:Lendo Lista de Pacotes... Erro !
E: Dynamic MMap ran out of room
E: Um erro ocorreu processando nana (NovaVersão1)
E: Problem with MergeList /var/lib/apt/lists/mirror.switch.ch_mirror_debian-amd64_debian_dists_sarge_main_binary-amd64_Packages
E: As listas de pacotes ou o arquivos de status não pôde ser analizado ou aberto.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/08/2006, 13:10
Resposta: #8
 
Gabriel,

Tente fazer o seguinte, abra o arquivo /etc/apt/apt.conf e adicione a seguinte linha:

Código:
APT::Cache-Limit 12582912;

Salve, feche e tente rodar apt-get update novamente.

Fernando.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/08/2006, 19:25
Resposta: #9
 
Aqui não existe o arquivo /etc/apt/apt.conf
então eu criei e adicionei a lnha citada por você, e o erro continuou.

Então vi que o conteúdo do arquivo /etc/apt/apt.conf.d/70debconf tem a mesma sintaxe PALAVRA::PALAVRA

o conteúdo dele é

Citar:// Pre-configure all packages with debconf before they are installed.
// If you don't like it, comment it out.
DPkg::Pre-Install-Pkgs {"/usr/sbin/dpkg-preconfigure --apt || true

adicionei a linha que você pediu, e continuou dando o erro.
deletei tudo que havia nesse arquivo e adicionei a linha, continuou o erro..

Só que agora, o erro fala em LUA40

Citar:Baixados 99B em 10s (9B/s)
Lendo Lista de Pacotes... Erro !
E: Dynamic MMap ran out of room
E: Dynamic MMap ran out of room
E: Um erro ocorreu processando lua40 (NovaVersão1)
E: Problem with MergeList /var/lib/apt/lists/mirror.switch.ch_mirror_debian-amd64_debian_dists_sarge_main_binary-amd64_Packages
E: As listas de pacotes ou o arquivos de status não pôde ser analizado ou aberto.


Obrigado pela atenção Alegre
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/08/2006, 19:39
Resposta: #10
 
Tentei tirar o mau pela raiz..

Vi que no erro citava:

Citar:/var/lib/apt/lists/mirror.switch.ch_mirror_debian-amd64_debian_dists_sarge_main_binary-amd64_Packages

então procurei por mirror.switch.ch no /etc/apt/source.list
removi a linha que contia ele
e dei um apt-get update,
então ele citou outro repositorio com erro
e fui tirando os repositorios até parar com o erro.
e PAROU!!

mas agora fui instalar o mozilla firefox e...

Citar:# apt-get install mozilla-firefox
Lendo Lista de Pacotes... Pronto
Construindo Árvore de Dependências... Pronto
O pacote mozilla-firefox não está instalado, então não será removido
Você deve querer rodar `apt-get -f install' para corrigir isso:
Os pacotes a seguir têm dependências desencontradas:
synaptic: Depende: libapt-inst-libc6.3-6-1.1
Depende: libapt-pkg-libc6.3-6-3.11
Depende: libatk1.0-0 (>= 1.12.1) mas 1.8.0-4 está para ser instalado Depende: libc6 (>= 2.3.5-1) mas 2.3.2.ds1-22 está para ser instalado Depende: libcairo2 (>= 1.2.0) mas não vai ser instalado
Depende: libgcc1 (>= 1:4.1.0) mas 1:3.4.3-13 está para ser instalado Depende: libglade2-0 (>= 1:2.5.1) mas 1:2.4.2-2 está para ser instalado
Depende: libglib2.0-0 (>= 2.10.0) mas 2.6.4-1 está para ser instalado
Depende: libgtk2.0-0 (>= 2.8.0) mas 2.6.4-3 está para ser instalado
Depende: libncurses5 (>= 5.4-5) mas 5.4-4 está para ser instalado
Depende: libpango1.0-0 (>= 1.12.3) mas 1.8.1-1 está para ser instalado
Depende: libstdc++6 (>= 4.1.0) mas 3.4.3-13 está para ser instalado
Depende: libvte4 (>= 1:0.12.1) mas 1:0.11.12-1 está para ser instalado
Depende: libxfixes3 mas não vai ser instalado
Depende: libxinerama1 mas não vai ser instalado
Depende: libxml2 (>= 2.6.26) mas 2.6.16-7 está para ser instalado
E: Dependências desencontradas. Tente `apt-get -f install' sem nenhum pacote (ou especifique uma solução).

então dou um apt-get install e o nome de um pacote dependente
e assim aparece "os pacotes que dependem dos pacotes dependentes" do firefox (intenderam? Sorrisão)

Instalei 2x o debian, e na primeira instalação (a 3 semanas atras), o apt-get funcionava, e ele baixava os pacotes dependentes automaticamente. Pelo menos foi assim com o a instalação do amsn.


Vi nesse erro final, que ele manda eu dar o comando apt-get install -f
que iria desinstalar 599mb de pacotes
e instalar 56,6mb de pacotes.

Devo fazer isso?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico:

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS