Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Configuração do teclado não fixa
20/11/2015, 22:05
Resposta: #1
Erro Configuração do teclado não fixa
Debian 8, Gnome 3 e teclado ABNT 2.

Não consigo fixar a configuração do teclado. Tentei via interface mas não funciona.

Um paliativo que encontrei é, ao iniciar o sistema, usar o comando:

$ setxkbmap -model pc105 -layout br -variant abnt2

Porém, ao reiniciar o sistema a configuração se perde e tenho que sempre aplicar esse comando para usar essa configuração.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/11/2015, 09:25 (Resposta editada pela última vez em: 21/11/2015 10:07 por fran.)
Resposta: #2
RE: Configuração do teclado não fixa
# nano /etc/init.d/meuscript

#!/bin/bash
#
# /etc/init.d/meuscript

setxkbmap -model pc105 -layout br -variant abnt2

#fim

Agora é só dar a permissão para execução:

# chmod 755 /etc/init.d/meuscript

inicializar junto com o sistema

# update-rc.d meuscript defaults

remover

update-rc.d -f meuscript remove

[Imagem: 11112_9039_128_tux_gpl_linux_icon.gif]

Debian 10 "Buster" + LXDE 64 bits
Linux Sempre
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/11/2015, 23:30
Resposta: #3
RE: Configuração do teclado não fixa
Imagino que tenha me instruído a fazer um script que aplicará o comando que citei antes de forma automática.

Infelizmente não funcionou. Não sou avançado em terminal (na verdade acho mais interessante operar pela interface gráfica). Fiz algumas deduções sobre o que eu acho que era pra ser feito.

1 - Abrir terminal

2 - Digitar "nano /etc/init.d/meuscript" (abriu o nano dentro do terminal)

3 - Colar o algorítimo do scritp
#!/bin/bash
#
# /etc/init.d/meuscript

setxkbmap -model pc105 -layout br -variant abnt2

#fim

Por favor, revise o script. Após tentar e falhar, eu fiz uma alteração, para checar se era erro de digitação. Na terceira linha há um espaço entre o tralha e a barra. Eliminei refiz a sequência de instruções e não funcionou.

4 - Autorizar o script a operar no sistema com o comando "chmod 755 /etc/init.d/meuscript"

5 - Fazer o scritp iniciar automaticamente com o comando "update-rc.d meuscript defaults"

Reiniciei e continuei com o teclado desconfigurado. Ainda tive que aplicar o comando manualmente em um terminal.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/11/2015, 08:38 (Resposta editada pela última vez em: 22/11/2015 08:49 por fran.)
Resposta: #4
RE: Configuração do teclado não fixa
ok, então tem que ser quando inicia a sessão de usuário.
e um autostart.

No terminal sem ser root
$ gnome-session-properties

olha a figura eu fiz 2 autostart tem outras formas de fazer o meu e LXDE o seu e gnome ai vc ve como fazer o autostart.


Arquivos Anexos Miniaturas
   

[Imagem: 11112_9039_128_tux_gpl_linux_icon.gif]

Debian 10 "Buster" + LXDE 64 bits
Linux Sempre
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/11/2015, 13:10
Resposta: #5
RE: Configuração do teclado não fixa
Resultado:

@debian-hjs:~$ gnome-session-properties
bash: gnome-session-properties: comando não encontrado
@debian-hjs:~$

O comando não funciona aqui.

Conhece algum comando alternativo?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/11/2015, 13:42 (Resposta editada pela última vez em: 22/11/2015 14:31 por fran.)
Resposta: #6
RE: Configuração do teclado não fixa
OBS :: Não como root # como usuário comum $

Criar autostart manualmente.

[email protected]:~$ gedit ~/.config/autostart/tc.desktop


[Desktop Entry]
Name=tc
GenericName=tc
Comment=tc
Exec=tc
Terminal=false
Type=Application
X-GNOME-Autostart-enabled=true

agora vc cria o script como root

su
senha

[email protected]:~# gedit /usr/bin/tc

#!/bin/bash

setxkbmap -model pc105 -layout br -variant abnt2

exit 0


OBS :: agora vc faz isso

[email protected]:~# chmod 777 /usr/bin/tc


agora reinicia

[email protected]:~# reboot

[Imagem: 11112_9039_128_tux_gpl_linux_icon.gif]

Debian 10 "Buster" + LXDE 64 bits
Linux Sempre
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/11/2015, 22:58
Resposta: #7
RE: Configuração do teclado não fixa
Você solucionou o problema.

As novas instruções fizeram o sistema reiniciar com a configuração correta para o teclado.

Um complemento às instruções:

após dar o comando "gedit ~/.config/autostart/tc.desktop" e colar o script instruído, tentei salvar o arquivo e não era possível. Tentei localizar a pasta "autostart" na pasta ".config" e não a encontrei, ela não existia. Dei o comando "mkdir autostart" para criar a pasta e finalmente consegui salvar o primeiro script.

Esse complemento pode ser útil para quem enganchar na parte de salvar o primeiro script.

Obrigado pela ajuda.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/03/2016, 16:16
Resposta: #8
RE: Configuração do teclado não fixa
Boa tarde.

Sou novo aqui e me cadastrei porque achei este tópico que aborta o problema que estou tendo, que é exatamente esse, criado pelo "virtualhjs".

O problema é que fiz exatamente tudo que foi orientado pelo "fran", principalmente referente às últimas instruções sobre criar o script como usuário normal $ no GEdit. É a mesma coisa, se eu executar o comando no terminal funciona, mas, ao reiniciar o sistema, tenho que executar o comando de novo porque a solução proposta não está funcionando pra mim.

Estou usando o Debian 8.2.0, que foi instalado em inglês, porém, meu teclado é ABNT2.

Obs.: Não sei se tem alguma coisa a ver, mas, na barra de tarefas no canto superior direito do meu desktop, aparece a opção de mudança de entrada de idioma do teclado "pt" e "en". Creio que isso deve ter ocorrido, porque durante a instalação, embora eu tenha escolhido o inglês como idioma principal, escolhi o Brasil como opção de localidade.

Se alguém tiver mais sugestões eu agradeço.


______________
IT is my life!
¯¯¯¯¯¯¯¯¯¯¯¯¯¯
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/03/2016, 17:00
Resposta: #9
RE: Configuração do teclado não fixa
Abra o terminal e experimente usar o comando como root

Código:
# dpkg-reconfigure keyboard-configuration

Escolha nas opções:

Modelo do Teclado ------> PC (Intl) Genérico de 105 teclas

Layout do Teclado ------> Português (Brasil)

Tecla para funcionar como AltGr ------> O padrão para o layout do teclado

Tecla Compose --------> Sem tecla Compose

Escolha SIM ou NÃO para ativar se o Ctrl + Alt + Backspace mata o servidor X

Após isto, feche o terminal e reinicie o computador.

Deve estar funcionando seu teclado ABNT2 no português do Brasil
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/03/2016, 17:29
Resposta: #10
RE: Configuração do teclado não fixa
Boa tarde "risislunit".

Fiz tudo o que você disse, após escolher "não" para a opção final "Escolha SIM ou NÃO para ativar se o Ctrl + Alt + Backspace mata o servidor X" o terminal retornou esse erro:

update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults

Mesmo assim reiniciei o sistema e não adiantou nada. Triste


______________
IT is my life!
¯¯¯¯¯¯¯¯¯¯¯¯¯¯
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/03/2016, 23:56
Resposta: #11
RE: Configuração do teclado não fixa
Ok netstryker, então já que o dpkg-reconfigure não resolveu, vamos editar na mão

como root digite

Código:
# gedit /etc/default/keyboard

Acrescente o texto abaixo

Código:
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="br"
XKBVARIANT=""
XKBOPTIONS="terminate:ctrl_alt_bksp"

BACKSPACE="guess"

Se existir algo dentro do arquivo apague e coloque somente o texto acima

Reinice e verifique se desta vez vai
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico:

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS