Fórum Debian
Atualizar squid para 2.6 - Versão para Impressão

+- Fórum Debian (http://www.forumdebian.com.br)
+-- Fórum: Debian (/forum-4.html)
+--- Fórum: Redes (/forum-17.html)
+--- Tópico: Atualizar squid para 2.6 (/thread-11431.html)



Atualizar squid para 2.6 - Junio Vitorino - 30/10/2006 16:04

Gente estou querendo atualizar o meu squid para a 2.6 para fazer um proxy transparente, me disseram que ele é otimo para isso, sem contar que pelo que me disseram é bem mais simples de configurar.

Estou no Debian Sarge e ele instala no máximo a versão 2.5.9, será que alguém poderia me ajudar com isso? :?:


Re: Atualizar squid para 2.6 - Fernando - 30/10/2006 23:40

Junio Vitorino Escreveu:Estou no Debian Sarge e ele instala no máximo a versão 2.5.9, será que alguém poderia me ajudar com isso? :?:

Você chegou a tentar compilar ele?

Não encontrei nenhum backport para o sarge, então acho que única forma seguindo esse caminho seria atualizar para o Etch.


- Junio Vitorino - 01/11/2006 07:57

Cara eu tentei compilar ele sim, baixei o source no squid-cache.org, tive que instalar várias coisas do tipo gcc e bibliotecas e muitas outras coisas, pois sempre dava vários erros, mas após tudo inslado eu consigo compilar e executar ./configure dar o make all e o make install nenhum erro ocorreu, mas ele não é instalado.


- Fernando - 01/11/2006 08:53

Junio Vitorino,

Nesse caso, se você realmente precisa do 2.6 acho que só passando para o Debian Etch.

Mas se a razão é utilizar o squid como proxy transparente, veja esse documento http://www.guiadohardware.net/dicas/con ... squid.html

A configuração mesmo no 2.5.9 parece ser bem tranquila.


- Junio Vitorino - 01/11/2006 10:20

Ok Fernando não tenho a necessidade de usar a versão 2.6, vou usar a 2.5.9 mesmo obrigado.

Agora vou abrir outro tópico sobre uma reformulação, que estou pretendendo fazer aqui em dezembro, e gostaria de contar com sua ajuda. Sorrisão

Thanks for everything.