Fórum Debian
Ajuda com php - Versão para Impressão

+- Fórum Debian (http://www.forumdebian.com.br)
+-- Fórum: Debian (/forum-4.html)
+--- Fórum: Software (/forum-14.html)
+--- Tópico: Ajuda com php (/thread-11680.html)



Ajuda com php - escobar - 19/09/2006 07:11

Opa galera,

Instalei o php no Debian, funcionou tudo de boa, instalei o pacote php4-cgi.

Testei um script na linha de comando e funcionou.

O problema é que quando tento rodar um arquivo pelo browser ele me pergunta para onde quero baixar, e não roda o arquivo.

Coloquei o arquivo em /etc/www e nada, tentei mudar o path, e nada, como fazer para o browser interpretar ele ?

Demian Escobar


- Fernando - 19/09/2006 09:01

Olá,

Você está utilizando o Apache 1 ou 2?

Fernando.


- escobar - 19/09/2006 14:04

estou usando o apache 1.3.33, debian sarge (2.4.27-2-386).

O mysql ja ta funcionando, o apache tb.

Apenas dei um apt-get install php4-cgi, ele baixou, e instalou, e via linha de comnado, qnd rodo um arquivo funciona de boa, mas qnd abro qualquer browser, em vez de executar o arquivo, ele pergunta com qual editor quero abrir ou me pergunta se quero fazer o download dele.

Grato

Escobar


- Fernando - 19/09/2006 17:43

Olá,

Tente adicionar isso no arquivo de configuração do apache (/etc/apache/apache.conf):

Código:
LoadModule php4_module /usr/lib/apache/1.3/libphp4.so
AddType application/x-httpd-php .php

Reinicie o apache e teste.


- escobar - 20/09/2006 11:41

depois que adicionei isto funcionou perfeitamente fernando, mto obrigado, vou testar o mysql agora, para ver se ta 100%.

Só uma pergunta, qual é o mais apropriado, o php4-cgi ou o php-mysql ??

Instalei os dois, não sei qual que ta funcionando, gostaria de saber pq um ou outro ?

Grato

Escobar


- ueluis - 07/01/2008 20:58

olá gente fernando inclui as duas linhas no meu apache2.conf e deu o seguinte erro...
server:~# sudo /etc/init.d/apache2 start
Starting web server (apache2)...apache2: Syntax error on line 188 of /etc/apache 2/apache2.conf: Cannot load /usr/lib/apache/1.3/libphp4.so into server: /usr/lib /apache/1.3/libphp4.so: undefined symbol: ap_user_id
failed!

estou tentando a meses fazer meu apache interpretar páginas em php e não consigo poderia me dá uma força?