Fórum Debian
libgtkmm-2.4-1c2a quebrado - Versão para Impressão

+- Fórum Debian (http://www.forumdebian.com.br)
+-- Fórum: Debian (/forum-4.html)
+--- Fórum: Software (/forum-14.html)
+--- Tópico: libgtkmm-2.4-1c2a quebrado (/thread-12629.html)



libgtkmm-2.4-1c2a quebrado - guislip - 27/06/2011 10:05

E ai galera tudo na paz?
estou tentando instalar o pacote DEB do inkscape 0.48.1, até ai tudo bem, me pediu algumas depencians e sai na caça das dependência e fui instalando até chegar na dependência libatkmm-1.6-1 puxei ela do site oficial de packages do debian, e instalei só que durante a instalção acabou dando um conflito ou quebrou o pacote libgtkmm-2.4-1c2a, e me recomendou a utilização do apt-get -f install, o qual não consegui fazer funcionar. Como de costume fui lá no synaptic e removi o pacote quebrado, removi o tal do libgtkmm e reinstalei tudo e continua quebrando o pacote. segue o LOG do terminal pela instalação pelo Gdebi

Procedimento. Executando o pacote libatkmm-1.6-1_2.22.5-1_i386.deb, Todas a Dependências satisfeitas. durante a instalação o pacote quebrado.

Janela de Alerta dizendo: FALHA EM INSTALAR AS DEPENDÊNCIAS - para arrumar isso excute 'sudo apt-get install -f' em um terminal

e atrás a janale do gdebi, dizendo
installation finished
Selecionado pacote previamente não selecionado libatkmm-1.6-1.
dpkg: considerando desconfiguração de libgtkmm-2.4-1c2a, que seria quebrado por instalação de libatkmm-1.6-1 ...
dpkg: sim, vou desconfigurar libgtkmm-2.4-1c2a (quebrado por libatkmm-1.6-1).
(lendo bando de dados ... 141768 ficheiros e directórios actualmente instalados.
)
Desempacotando libatkmm-1.6-1 (de .../libatkm-1.6-1_2.22.5-1_i386.deb) ...
Desconfigurando libgtkmm-2.4-1c2a ...
Configurando libatkmm-1.6-1 (2.22.5-1) ...
dpkg: problemas de dependência impedem a configuração de libgtkmm-2.4-1c2a:
libatkm,-1.6-1 (2.22.5-1) quebra libgtkmm-2.4-1c2a (<< 1:2.22.0) e é instalado.
Versão de libgtkmm-2.4-1c2a a ser configurada é 1:2.20.3-1.
dpkg: erro processando libgtkmm-2.4-1c2a (--install):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
libgtkmm-2.4-1c2a


__________________________________________________________________________
bY GuiSliP
http://www.guislip.com.br



RE: libgtkmm-2.4-1c2a quebrado - spikey - 28/06/2011 00:55

Olá tente isso:

Código:
apt-get check



RE: libgtkmm-2.4-1c2a quebrado - guislip - 28/06/2011 07:32

olha a mensagem do apt-get check

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você pode querer executar 'apt-get -f install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
libatkmm-1.6-1 : Quebra: libgtkmm-2.4-1c2a (< 1:2.22.0) mas 1:2.20.3-1 está instalado
E: Dependências desencontradas. Tente usar -f.



RE: libgtkmm-2.4-1c2a quebrado - spikey - 28/06/2011 13:52

Certo, então faça o que ele sugere. Tome cuidado somente se ele tentar remover muitos pacotes. Provavelmente o apt irá tentar remover os pacotes libatkmm-1.6-1 e libgtkmm-2.4-1c2a mantendo a versão 1:2.20.3-1. Aliás, isso pode ser problema do seu sources.list, aproveite e poste para vermos se está correto.


RE: libgtkmm-2.4-1c2a quebrado - guislip - 28/06/2011 14:35

segue ai então meu source.list o qual eu coloquei os repositórios que estava numa página do Debian

#mirros de segurança
deb http://security.debian.org/ squeeze/updates main contrib
deb-src http://security.debian.org/ squeeze/updates main contrib

#mirros oficiais
deb ftp://ftp.br.debian.org/debian/ squeeze main contrib non-free
deb http://linorg.usp.br/debian/ squeeze main contrib non-free

#para usar os servidores abaixo basta remover o "#" e atualizar a lista de pacotes

#mirros multimidia
# deb http://debian-multimedia.org/ testing main
deb http://ftp.debian-unofficial.org/debian testing main contrib non-free

#compiz-fusion
# deb http://apt-get.if.uff.br lenny-ifuff compiz

#opera
# deb http://deb.opera.com/opera/ testing non-free

# deb http://ppa.launchpad.net/mozillateam/firefox-stable/ubuntu lucid main
# deb-src http://ppa.launchpad.net/mozillateam/firefox-stable/ubuntu lucid main
deb http://ppa.launchpad.net/inkscape-nightly/ppa/debian squeeze main


Será que é isso?
abraços


RE: libgtkmm-2.4-1c2a quebrado - spikey - 29/06/2011 13:48

Então, no caso você tem o repositório debian-multimedia coma versão Testing, isso pode ser um dos motivos de existirem pacotes quebrados no sistema.


RE: libgtkmm-2.4-1c2a quebrado - guislip - 30/06/2011 22:20

apaguei os repositorios de teste
e atualizei o source list e executei todos os deb que tenho que puxei do inkscape,
usando o comando via terminal dpkg -i *.deb
e olha o log do terminal

Selecionando pacote previamente não selecionado libatkmm-1.6-1.
dpkg: sobre 01 -libatkmm-1.6-1_2.22.5-1_i386.deb contendo libatkmm-1.6-1:
libatkmm-1.6-1 quebra libgtkmm-2.4-1c2a (<< 1:2.22.0)
libgtkmm-2.4-1c2a (versão 1:2.20.3-1) está presente e instalado.
dpkg: erro processando 01 -libatkmm-1.6-1_2.22.5-1_i386.deb (--install):
instalando libatkmm-1.6-1 quebrará libgtkmm-2.4-1c2a, e
a desconfiguração não é permitida (--auto-deconfigure poderá ajudar)
(Lendo banco de dados ... 152345 ficheiros e directórios actualmente instalados.)
Preparando para substituir libglibmm-2.4-1c2a 2.28.1-1 (usando 02 -libglibmm-2.4-1c2a_2.28.1-1_i386.deb) ...
Desempacotando substituto libglibmm-2.4-1c2a ...
Preparando para substituir libglibmm-2.4-1c2a 2.28.1-1 (usando 03 - libglibmm-2.4-1c2a_2.28.1-1_i386.deb) ...
Desempacotando substituto libglibmm-2.4-1c2a ...
Preparando para substituir libglib2.0-0 2.28.6-1 (usando 04 - libglib2.0-0_2.28.6-1_i386.deb) ...
Desempacotando substituto libglib2.0-0 ...
Preparando para substituir libpcre3 8.12-3 (usando 05 - libpcre3_8.12-3_i386.deb) ...
Desempacotando substituto libpcre3 ...
Preparando para substituir libstdc++6 4.6.0-10 (usando 06 - libstdc++6_4.6.0-10_i386.deb) ...
Desempacotando substituto libstdc++6 ...
Preparando para substituir gcc-4.6-base 4.6.0-10 (usando 07 - gcc-4.6-base_4.6.0-10_i386.deb) ...
Desempacotando substituto gcc-4.6-base ...
Preparando para substituir libatk1.0-data 2.0.1-1 (usando 08 - libatk1.0-data_2.0.1-1_all.deb) ...
Desempacotando substituto libatk1.0-data ...
Preparando para substituir libatk1.0-0 2.0.1-1 (usando 09 - libatk1.0-0_2.0.1-1_i386.deb) ...
Desempacotando substituto libatk1.0-0 ...
Preparando para substituir inkscape 0.47.0-2+b1 (usando inkscape_0.48.1-2.1_i386.deb) ...
Desempacotando substituto inkscape ...
Mais de uma cópia do pacote libglibmm-2.4-1c2a foi desempacotada
nesta execução! Configurando-o somente uma vez.
Configurando libpcre3 (8.12-3) ...
Configurando gcc-4.6-base (4.6.0-10) ...
Configurando libatk1.0-data (2.0.1-1) ...
dpkg: problemas de dependência impedem a configuração de inkscape:
inkscape depende de libatkmm-1.6-1 (>= 2.22.1); porém:
Pacote libatkmm-1.6-1 não está instalado.
inkscape depende de libgc1c2 (>= 1:7.1); porém:
Versão de libgc1c2 no sistema é 1:6.8-1.2.
inkscape depende de libgdk-pixbuf2.0-0 (>= 2.22.0); porém:
Pacote libgdk-pixbuf2.0-0 não está instalado.
inkscape depende de libgtk2.0-0 (>= 2.24.0); porém:
Versão de libgtk2.0-0 no sistema é 2.20.1-2.
inkscape depende de libgtkmm-2.4-1c2a (>= 1:2.24.0); porém:
Versão de libgtkmm-2.4-1c2a no sistema é 1:2.20.3-1.
inkscape depende de libmagick++4 (>= 8:6.6.9.7); porém:
Pacote libmagick++4 não está instalado.
inkscape depende de libmagickcore4 (>= 8:6.6.9.7); porém:
Pacote libmagickcore4 não está instalado.
inkscape depende de libpangomm-1.4-1 (>= 2.27.1); porém:
Versão de libpangomm-1.4-1 no sistema é 2.26.2-1.
inkscape depende de libwpd-0.9-9; porém:
Pacote libwpd-0.9-9 não está instalado.
inkscape depende de libwpg-0.2-2; porém:
Pacote libwpg-0.2-2 não está instalado.
dpkg: erro processando inkscape (--install):
problemas de dependência - deixando desconfigurado
Configurando libstdc++6 (4.6.0-10) ...
Processando gatilhos para man-db ...
Configurando libglib2.0-0 (2.28.6-1) ...
Configurando libatk1.0-0 (2.0.1-1) ...
Configurando libglibmm-2.4-1c2a (2.28.1-1) ...
Processando gatilhos para hicolor-icon-theme ...
Processando gatilhos para menu ...
Processando gatilhos para desktop-file-utils ...
Processando gatilhos para gnome-menus ...
Erros foram encontrados durante o processamento de:
01 -libatkmm-1.6-1_2.22.5-1_i386.deb
inkscape



RE: libgtkmm-2.4-1c2a quebrado - spikey - 01/07/2011 11:35

Então, mas não seia mais simples instalar o ink-scape pelo apt-get?


RE: libgtkmm-2.4-1c2a quebrado - vadinhodebian - 01/07/2011 16:00

Boa tarde,

Experimente o comando, para solucionar os pacotes quebrados:
Código:
aptitude -f install

Depois tente instalar novamente o programa.

Até mais...