Fórum Debian
Problema para instalar Sendmail - Versão para Impressão

+- Fórum Debian (http://www.forumdebian.com.br)
+-- Fórum: Debian (/forum-4.html)
+--- Fórum: Software (/forum-14.html)
+--- Tópico: Problema para instalar Sendmail (/thread-12638.html)



Problema para instalar Sendmail - rchaves - 29/06/2011 21:10

Tenho um servidor debian onde instalei o nginx e o passenger, pra rodar minha aplicação rails, porém preciso instalar nele o sendmail, pra enviar emails, mas isso acontece:

Código:
apt-get -f install sendmail
Reading package lists... Done
Building dependency tree      
Reading state information... Done
sendmail is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 79 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
Setting up sendmail-bin (8.14.3-9.4) ...
insserv: warning: script 'php-fastcgi' missing LSB tags and overrides
insserv: There is a loop between service nginx and php-fastcgi if stopped
insserv:  loop involving service php-fastcgi at depth 2
insserv:  loop involving service nginx at depth 1
insserv: Stopping php-fastcgi depends on nginx and therefore on system facility `$all' which can not be true!
update-rc.d: warning: sendmail stop runlevel arguments (0 1 6) do not match LSB Default-Stop values (1)
insserv: warning: script 'php-fastcgi' missing LSB tags and overrides
insserv: There is a loop between service nginx and php-fastcgi if stopped
insserv:  loop involving service php-fastcgi at depth 2
insserv:  loop involving service nginx at depth 1
insserv: Stopping php-fastcgi depends on nginx and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing sendmail-bin (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of sensible-mda:
sensible-mda depends on sendmail-bin | mail-transport-agent; however:
  Package sendmail-bin is not configured yet.
  Package mail-transport-agent is not installed.
  Package sendmail-bin which provides mail-transport-agent is not configured yet.
dpkg: error processing sensible-mda (--configure):
dependency problems - leaving unconfigured
dpkg: deconfigured to not write apport reports
                                              configured to not write apport reports
    configured to not write apport reports
                                          pendency problems prevent configuration of sendmail:
sendmail depends on sendmail-bin; however:
  Package sendmail-bin is not configured yet.
sendmail depends on sensible-mda; however:
  Package sensible-mda is not configured yet.
dpkg: error processing sendmail (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
sendmail-bin
sensible-mda
sendmail

não tenho a menor ideia do que está acontecendo pois configurar servidores realmente não é minha área, então coloquei apenas a mensagem de erro q dá no apt-get, espero que possam me ajudar!
opa! resolvi! Era o php-fastcgi q tava dando algum problema, deletei ele do /etc/init.d e foi, valeu Sorrisão


RE: Problema para instalar Sendmail - spikey - 30/06/2011 11:04

Não entendi o porque usou o -f, mas que bom que o problema foi solucionado.