Fórum Debian
Xorg.conf Vazio! [ Resolvido ] - Versão para Impressão

+- Fórum Debian (http://www.forumdebian.com.br)
+-- Fórum: Debian (/forum-4.html)
+--- Fórum: Ambiente Gráfico (/forum-19.html)
+--- Tópico: Xorg.conf Vazio! [ Resolvido ] (/thread-2937.html)



Xorg.conf Vazio! [ Resolvido ] - tvieira - 20/07/2009 03:33

Ola a todos!


Alguém ja teve um problema parecido? Eu instalei novamente o Debian Squeeze e instalei o compiz, mas quando eu ativo as bordas das janelas desaparecem, mas fui abrir o xorg.conf para ver o que tinha lá e configurá-lo para não acontecer mais isso, e para o mesmo espanto ele esta vazio! Esta tudo funcionando normalmente, com excessão das bordas da janela com o compiz ativado. Eu entro em /etc/X11/xorg.conf e o arquivo esta em branco, eu entrei na pasta pelo nautilus e o arquivo esta lá.

Alguém tem idéia do que esta acontecendo?


Desde já agradeço


Abraços


Re: Xorg.conf Vazio! - dmatrix - 20/07/2009 12:27

seu sistema está gerando e utilizando um xorg.conf padrão, vc deve criar um com as configurações apropriadas.


Re: Xorg.conf Vazio! - tvieira - 20/07/2009 13:02

dmatrix Escreveu:seu sistema está gerando e utilizando um xorg.conf padrão, vc deve criar um com as configurações apropriadas.

Caramba! Como que eu faço isso agora?.........rsrsrsrs Não tem como eu alterar as coisas nesse xorg padrão?



Abraços


Re: Xorg.conf Vazio! - dmatrix - 20/07/2009 13:57

veja se gera um bom e completo com o comando:
# X -configure
# cp /etc/X11/xorg.conf{,.backup}
# cp /root/xorg.conf.new /etc/X11/xorg.conf


caso não seja satisfatório tente inicializar utilizando um livecd do ubuntu, por exemplo, e copie o xorg.conf migrando para o seu sistema.

obs: a segunda linha é só por segurança.


Re: Xorg.conf Vazio! - tvieira - 20/07/2009 15:45

dmatrix Escreveu:veja se gera um bom e completo com o comando:
# X -configure
# cp /etc/X11/xorg.conf{,.backup}
# cp /root/xorg.conf.new /etc/X11/xorg.conf


caso não seja satisfatório tente inicializar utilizando um livecd do ubuntu, por exemplo, e copie o xorg.conf migrando para o seu sistema.

obs: a segunda linha é só por segurança.

Fiz os comandos acima e gerou um xorg, é esse abaixo ai:

Código:
Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    RgbPath      "/etc/X11/rgb"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load  "dri"
    Load  "GLcore"
    Load  "glx"
    Load  "record"
    Load  "extmod"
    Load  "dbe"
    Load  "xtrap"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    #DisplaySize      330   210    # mm
    Identifier   "Monitor0"
    VendorName   "SEC"
    ModelName    "3358"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"                # [<bool>]
        #Option     "SWcursor"               # [<bool>]
        #Option     "ColorKey"               # <i>
        #Option     "CacheLines"             # <i>
        #Option     "Dac6Bit"                # [<bool>]
        #Option     "DRI"                    # [<bool>]
        #Option     "NoDDC"                  # [<bool>]
        #Option     "ShowCache"              # [<bool>]
        #Option     "XvMCSurfaces"           # <i>
        #Option     "PageFlip"               # [<bool>]
    Identifier  "Card0"
    Driver      "intel"
    VendorName  "Intel Corporation"
    BoardName   "Mobile GM965/GL960 Integrated Graphics Controller"
    BusID       "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Só que não configuro o meu teclado, mesmo fazendo o xserver não configura e fica configuro, sempre quando reinicio o pc ele volta ao teclado sem o ç.


Abraços


Re: Xorg.conf Vazio! - dmatrix - 21/07/2009 09:27

tvieira Escreveu:Fiz os comandos acima e gerou um xorg, é esse abaixo ai:

Código:
Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    RgbPath      "/etc/X11/rgb"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load  "dri"
    Load  "GLcore"
    Load  "glx"
    Load  "record"
    Load  "extmod"
    Load  "dbe"
    Load  "xtrap"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    #DisplaySize      330   210    # mm
    Identifier   "Monitor0"
    VendorName   "SEC"
    ModelName    "3358"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"                # [<bool>]
        #Option     "SWcursor"               # [<bool>]
        #Option     "ColorKey"               # <i>
        #Option     "CacheLines"             # <i>
        #Option     "Dac6Bit"                # [<bool>]
        #Option     "DRI"                    # [<bool>]
        #Option     "NoDDC"                  # [<bool>]
        #Option     "ShowCache"              # [<bool>]
        #Option     "XvMCSurfaces"           # <i>
        #Option     "PageFlip"               # [<bool>]
    Identifier  "Card0"
    Driver      "intel"
    VendorName  "Intel Corporation"
    BoardName   "Mobile GM965/GL960 Integrated Graphics Controller"
    BusID       "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Só que não configuro o meu teclado, mesmo fazendo o xserver não configura e fica configuro, sempre quando reinicio o pc ele volta ao teclado sem o ç.


Abraços

veja, adicione na seção do teclado as opções que falta:
Código:
Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "abnt2"
   Option      "XkbLayout"   "br"
   Option      "XkbVariant"   "abnt2"
EndSection



Re: Xorg.conf Vazio! - tvieira - 21/07/2009 09:30

Muito obrigado!


Tópico resolvido!



Abraços