Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Inicia e trava em tela preta após instalação
03/10/2013, 19:34 (Resposta editada pela última vez em: 04/10/2013 12:51 por lioncblu.)
Resposta: #1
Inicia e trava em tela preta após instalação
Olá a todos, sou novo no mundo Debian, porem tenho algum conhecimento em Linux, pois usava o Mandriva desde o tempo da Conectiva.

O fato é que achei um tanto estranho a instalação do Debian não me fornecer muitas janelas de configuração, é isso mesmo? praticamente automático?

Indiquei que tenho só o disco 1 (debian-7.1.0-amd64-DVD-1), selecionei a língua e meu local particionei o HD, e indiquei o local para o grub na MBR, mas ele não perguntou nada sobre a interface gráfica e minha polaca de vídeo. Como resultado ele vai iniciando mas chega em um ponto e a tela fica escura e não consigo fazer mais nada, nem outros consoles é possível abrir, me obrigando a desligar o note.

Acredito que o problema seja a falta ou configuração errada do servidor X. Alguém poderia me dar alguma ajuda?

Minha máquina é: um Avell Titanium B153, que possui tela de 15,6 polegadas intel i7 e 8GB de RAM com placa de vídeo dedicada nVidia Gforce GT640M com 1GB dedicado e estou instalando em conjunto com Windows 7 x64. No windows é informado que a placa de vídeo tem 4Gb de memória, sendo que 3GB são compartilhado/retirados da RAM

============== Editado ==============
Já que tem mais um com problema semelhante, vou acrescentar alguma informação:

No meu estou usando MBR e a instalação ocorre de forma natural e com ambiente gráfico, no boot ele passa por vária conf. e informações e só depois é que trava, e não consigo alterar para nenhum console (não sei se o Debian traz mais algum consolo por padrão). Em um determinado momento surge um erro de "mdevd" com relação a algum PCI, mas após jogar repetidamente este erro na tela ele passa e continua a carregar módulos e outras coisa, sendo que alguns poucos mostram o status em "verde OK" mas sem erros, a maioria não traz informação alguma!

Seria isso a acrescentar

Avell Titanium B153 - Intel i7 3630QM - 8GB RAM - GeForce GT640M 1GB dedicado - HD750GB 7200RPM - Win 7 64bit - Debian 7.1.0
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/10/2013, 12:05
Resposta: #2
RE: Inicia e trava em tela preta após instalação
Oi pessoal!

Acho que estou com o mesmo problema que o lioncblu.

Há dias estou tentando instalar o Debian Wheezy no meu laptop, mas está muito difícil...

Montei um pendrive a partir da iso netinstall(~200MB) e depois do CD (~600MB), mas o problema é o mesmo a partir de ambos.

Uso tabela de partição GPT e, portanto, o boot é a partir da partição efi. Quanto a isto, nenhum problema. O computador dá boot pelo pendrive efi.

A instalação em modo gráfico não funciona, mas em modo texto tudo ocorre com tranquilidade. Ao final é instalado o grub2, que reconhece a partição efi e insere o debian na lista de sistemas da bios.

Após o reboot, agora a partir do hd, o grub2 é iniciado sem problemas. Mas a partir daqui as coisas não funcionam mais. Ao selecionar o Debian na lista do grub2, o sistema congela em uma tela preta...

Pesquisando na net, descobri que inserindo a instrução GRUB_GFXPAYLOAD_LINUX=keep no arquivo /etc/default/grub, é possível ver o passo a passo do boot e, portanto, em que momento o sistema congela.

E ele congela logo no início, com as seguintes mensagens na tela:

Loading Linux 3.2.0-4amd64 ...
Loading initial ramdisk ...

A partir de então, nada mais funciona.

O processador é um i3 Sandy Bridge 2a geração, com placa de video Intel HD Graphics integrada.

Alguém já passou por isto e poderia me ajudar? Não sei mais o que fazer...

Muito obrigado.
Citar esta mensagem em uma resposta
04/10/2013, 18:21
Resposta: #3
RE: Inicia e trava em tela preta após instalação
Rapaz o seu primeiro erro foi baixar uma imagem para amd se o seu processador é intel, segundo se você escolher a opção avançada você vai poder escolher o que deve instalar ou não. tente estas alterações primeiro depois se continuar dando algum erro fala novamente para que possamos corrigir

Jvianez
Todo Cristão é Livre use Linux e não seja Pirata.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/10/2013, 22:32
Resposta: #4
RE: Inicia e trava em tela preta após instalação
não vejo por esse lado, processadores i3 i5 e i7 são multicore então a imagem utilizada é a amd64 para poder ter um sistema de 64 bits funcional. Com relação a tela negra, pode ser o video mas creio que o debian esteja mais avançado em compatibilidade de drivers de video genericos então acredito que o problema seja alguma incompatibilidade da bios, ou seja vc precisa desativar a inicialização do kernel com o acpi. Na primeira janela de instalação tem um mode de editar os flags que pode ser incluídos na linha do kernel, então adicione o flag apci=off e veja se a instalação prossegue normalmente.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/10/2013, 10:57
Resposta: #5
RE: Inicia e trava em tela preta após instalação
Sobre a imagem, sim a intenção é usufruir do sistema 64bit, e com o mandriva sempre funcionou com a imagem amd64, por esta ser a referencia do sistema x64.

Tentei fazer uma instalação em modo avançado tb não resolveu, vou tentar o modo acpi=off e ver no que dá.
Estou concluindo o download das outras imagens e vou utilizar na instalação mais a frente!

Grato por enquanto!

Avell Titanium B153 - Intel i7 3630QM - 8GB RAM - GeForce GT640M 1GB dedicado - HD750GB 7200RPM - Win 7 64bit - Debian 7.1.0
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/10/2013, 12:04
Resposta: #6
RE: Inicia e trava em tela preta após instalação
esqueci de dizer que tb tem as outras flags que ajudam bastante e pode ser adicionadas em conjunto: nolapic noapic

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
06/10/2013, 08:38
Resposta: #7
RE: Inicia e trava em tela preta após instalação
(05/10/2013 12:04)dmatrix Escreveu:  esqueci de dizer que tb tem as outras flags que ajudam bastante e pode ser adicionadas em conjunto: nolapic noapic

Esta tag não foi necessária, adicionei a acpi=off e o sistema iniciou perfeitamente. Já baixei as outras midias e vou fazer a instalação completa durante a semana, obrigado pela ajuda! Este meu problema foi solucionado.

Avell Titanium B153 - Intel i7 3630QM - 8GB RAM - GeForce GT640M 1GB dedicado - HD750GB 7200RPM - Win 7 64bit - Debian 7.1.0
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS