Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Perdi a aceleração 3D
22/12/2007, 13:12
Resposta: #1
Perdi a aceleração 3D
Boa tarde,
primeiramente, fiquei em dúvida em qual área postar, se na de hardware ou nessa sobre ambiente gráfico, postei aqui porque o problema tem mais a ver com ambiente gráfico.

É o seguinte:
Instalei o debian lenny 2.6.22 (recompilado, para ativar suporte a 4gb de ram)
Radeon 9600xt 256mb, Xorg 7.3 com o driver open source ati.

Instalei tudo certo, eu tinha aceleração 3d perfeita, aiglx + compiz-fusion perfeito, sem problema algum.

Ontem estava usando o pc normalmente, com o compiz ativado, estável, só fazendo tarefas comuns tipo navegando na internet, ouvindo música, emulando windows no vmware, reiniciei várias vezes, etc, tudo perfeito.
desliguei o pc e fui dormir, hoje ligo o pc e fui ativar o compiz e ele não ativou, dei um glxinfo |grep direct e a resposta foi "no"

Código:
sempron:/home/alex# glxinfo |grep direct
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect
sempron:/home/alex#

Eu não entendo o que possa ter acontecido, porque estava tudo funcionando ontem, só desliguei o pc e liguei hoje e sumiu a aceleração 3d :?

acredito que não tenha problemas com o xorg.conf, mas vou colocar-lo aqui para vcs conferirem:

Código:
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Module"
    Load "glx"
    Load "dri"
    Load "drm"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "abnt2"
    Option        "XkbLayout"    "br"
    Option        "XkbVariant"    "abnt2"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/input/mice"
    Option        "Protocol"        "ImPS/2"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "Device"
    Identifier    "Placa de Vídeo Genérica"
    Driver        "ati"
    BusID        "PCI:1:0:0"
    Option          "AGPMode"       "8"

    # aiglx
    Option "GARTSize" "64"
    Option "DRI" "true"
    Option "AccelMethod" "XAA"
    Option "ColorTiling" "on"
    Option "EnablePageFlip" "True"
    Option "XAANoOffscreenPixmaps" "true"
    Option "RenderAccel" "True"
    Option "BackingStore" "on"
EndSection

Section "Monitor"
    Identifier    "Monitor Genérico"
    Option        "DPMS"
    HorizSync    28-51
    VertRefresh    43-60
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Placa de Vídeo Genérica"
    Monitor        "Monitor Genérico"
    DefaultDepth    24
    SubSection "Display"
        Modes        "1024x768"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    Option "AIGLX" "True"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "True"
EndSection

se precisarem de mais alguma informação é só pedir!
Obrigado pela atenção!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Mensagens neste Tópico
Perdi a aceleração 3D - Alex Lacerda - 22/12/2007 13:12
[] - eliasdiniz - 26/12/2007, 23:31
[] - Alex Lacerda - 29/12/2007, 13:35

Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS