Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Net Virtua não compartilha internet
17/06/2011, 09:33
Resposta: #13
RE: Net Virtua não compartilha internet
(16/06/2011 15:42)Jvianez Escreveu:  
(16/06/2011 10:21)jukinha Escreveu:  cara essa é minha config de interfaces,dhcp e firewall, meu pc tem internet, mas o pc restante ligado ao meu roteador (tp-link) não tem acesso a internet, segue minha topologia :

http://imageshack.us/photo/my-images/684/topologia.jpg/

/etc/network/interfaces

auto lo eth1 eth2
iface lo inet loopback
iface eth1 inet dhcp

iface eth2 inet static
address 192.168.2.1
netmask 255.255.255.0
network 192.168.2.0
broadcast 192.168.2.255

DHCP.conf

ddns-update-style none;
default-lease-time 600;
max-lease-time 7200;
authoritative;
subnet 192.168.2.0 netmask 255.255.255.0
{
range 192.168.2.2 192.168.2.20;
option routers 192.168.2.1;
option domain-name-servers 208.67.222.222, 208.67.220.220;
option broadcast-address 192.168.2.255;

host server {
hardware ethernet 00:0F:B0:55:EA:13;
fixed-address 192.168.2.0;
}
}

## Ativando Compartilhamento
modprobe iptable_nat
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
Ola as configurações estão corretas o problema pode esta no rotiador coloca ele em mode brigde e coloca o cabo que sai do servidor em uma das portas da lan dai o servidor enviar as comfigurações de ip para os computadores
Um outro problema que você pode esta tendo é que você configurou o rotiador com o a mesma classe de ip que seu servidor e ativou o dhcp dele também se fez isto coloca um ip diferente no seu rotiador tipo 192.168.3.1 e não 192.168.2.xxx e coloca o cabo na porta wan e vc pode deixar o tipo de conheção dhcp.
faz um teste para ver, reseta o seu rotiador que deve volta com o ip 192.168.1.1 e só coloca o cabo que vem do servidor na porta wan e deve funcionar
PS.: E se não funcionar deve ter alguma coisa erra na configuração da rede de seu servidor execulta o comando ifconfig e verifica se realmente as suas placas de rede estão como eth1 e eth2 o normal seria estarem como eth0 e eth1
o ip do router esta padrao 192.168.1.1 , pelo menos nao mudei nada nisso.. nas config da interface nao coloquei o gateway ou seja, esta padrao ne?

sobre o eth1, eth2 é isso mesmo, o eth0 é minha onboard, e esta queimada, to usando 2 placa de rede pci..
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Mensagens neste Tópico
RE: Net Virtua não compartilha internet - jukinha - 17/06/2011 09:33

Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS