Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Erro no KDE após atualização do Sarge p/ o Etch [RESOLVIDO]
03/04/2007, 00:51
Resposta: #1
Erro no KDE após atualização do Sarge p/ o Etch [RESOLVIDO]
Galera,

decidi atualizar o Debian para o Etch, colocando repositórios testing e unstable (para algumas bibliotecas somente) e ziquizeiras a parte, consegui finalizar, mas não consigo entrar no kde, aparecendo a mensagem abaixo:

Código:
xsetroot:  unable to open display ''
Can't open display
xset:  unable to open display ""
xset:  unable to open display ""
xsetroot:  unable to open display ''
startkde: Starting up...
ksplash: cannot connect to X server
xprop:  unable to open display ''
usage:  xprop [-options ...] [[format [dformat]] atom] ...

where options include:
    -grammar                       print out full grammar for command line
    -display host:dpy              the X server to contact
    -id id                         resource id of window to examine
    -name name                     name of window to examine
    -font name                     name of font to examine
    -remove propname               remove a property
    -set propname value            set a property to a given value
    -root                          examine the root window
    -len n                         display at most n bytes of any property
    -notype                        do not display the type field
    -fs filename                   where to look for formats for properties
    -frame                         don't ignore window manager frames
    -f propname format [dformat]   formats to use for property of given name
    -spy                           examine window properties forever

kdeinit: Aborting. $DISPLAY is not set.
Warning: connect() failed: : No such file or directory
ksmserver: cannot connect to X server
ERROR: Couldn't attach to DCOP server!
startkde: Shutting down...
Warning: connect() failed: : No such file or directory
Error: Can't contact kdeinit!
startkde: Running shutdown scripts...
xprop:  unable to open display ''
usage:  xprop [-options ...] [[format [dformat]] atom] ...

where options include:
    -grammar                       print out full grammar for command line
    -display host:dpy              the X server to contact
    -id id                         resource id of window to examine
    -name name                     name of window to examine
    -font name                     name of font to examine
    -remove propname               remove a property
    -set propname value            set a property to a given value
    -root                          examine the root window
    -len n                         display at most n bytes of any property
    -notype                        do not display the type field
    -fs filename                   where to look for formats for properties
    -frame                         don't ignore window manager frames
    -f propname format [dformat]   formats to use for property of given name
    -spy                           examine window properties forever

De um detalhe que eu não sabia é que o X mudou para o X.org, onde creio que tenha complicado a minha vida...

Segue o xorg.conf:
Código:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
        FontPath        "/usr/share/fonts/X11/misc"
        FontPath        "/usr/X11R6/lib/X11/fonts/misc"
        FontPath        "/usr/share/fonts/X11/cyrillic"
        FontPath        "/usr/X11R6/lib/X11/fonts/cyrillic"
        FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath        "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath        "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/Type1"
        FontPath        "/usr/X11R6/lib/X11/fonts/Type1"
        FontPath        "/usr/share/fonts/X11/100dpi"
        FontPath        "/usr/X11R6/lib/X11/fonts/100dpi"
        FontPath        "/usr/share/fonts/X11/75dpi"
        FontPath        "/usr/X11R6/lib/X11/fonts/75dpi"
        # path to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load    "bitmap"
        Load    "dbe"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "record"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "abnt2"
        Option          "XkbLayout"     "br"
        Option          "XkbVariant"    "abnt2"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "ImPS/2"
EndSection
Section "Device"
        Identifier      "GeForce FX5500"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
        VideoRam        256000
EndSection

Section "Monitor"
        Identifier      "SyncMaster"
        Option          "DPMS"
        HorizSync       28-50
        VertRefresh     43-75
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "GeForce FX5500"
        Monitor         "SyncMaster"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1152x864" "1024x768" "800x600"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1152x864" "1024x768" "800x600"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1152x864" "1024x768" "800x600"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1152x864" "1024x768" "800x600"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1152x864" "1024x768" "800x600"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1152x864" "1024x768" "800x600"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection

Section "DRI"
        Mode    0666
EndSection

Reinstalei pelo menos duas vezes o kde pelos pacotes principais: kdm e kde-core, mas o resultado é o mesmo...

O curioso é que o XFCE rola na boa...

Alguém já passou por esta experiência ou tem alguma dica?

Abraços fortes a todos!!!

.:M:.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/04/2007, 01:01
Resposta: #2
 
...fato muito curioso...

se eu dou um startkde num bash dentro do kde ele sobe, mas diretamente do X ele aparece a mensagem acima...isso aconteceu depois de instalar o x-window-system...

Depois de reinicializar o sistema o kde voltou a funcionar corretamente, mas depois de instalar o pacote xorg, agora está bala!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/04/2007, 11:43
Resposta: #3
 
marquinhos Escreveu:...fato muito curioso...

se eu dou um startkde num bash dentro do kde ele sobe, mas diretamente do X ele aparece a mensagem acima...isso aconteceu depois de instalar o x-window-system...
Olá, tem umas coisas confusas... para entrar no kde vc está mudando o sistema na tela do login para sessão kde? Vc não pode iniciar uma sessão do kde dentro de outra sessão em bash. Abra um terminal no xfce e digite init 1, no prompt que aparecer depois de entrar com a senha de root, digite startx e diga que mensagem de erro ocorre.
Posta a saída do comando:
$ dpkg -l kde* | grep ii

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS