Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Como ouvir os Sons de Sistema no gnome?[RESOLVIDO]
26/03/2007, 12:33
Resposta: #16
 
Dmatrix lá vai os comandos que me postou acima:
Num terminal como root:

XBlade:/home/adilson# ls -l /dev/dsp
-rw-r--r-- 1 root root 0 2007-03-26 12:24 /dev/dsp
XBlade:/home/adilson# id
uid=0(root) gid=0(root) grupos=0(root)

Num terminal como usuário:

[email protected]:~$ ls -l /dev/dsp
-rw-r--r-- 1 root root 0 2007-03-26 12:24 /dev/dsp
[email protected]:~$ id
uid=1000(adilson) gid=1000(adilson) grupos=4(adm),20(dialout),21(fax),24(cdrom),25(floppy),26(tape),29(audio),44(vid​eo),46(plugdev),107(powerdev),108(scanner),1000(adilson)

LINUX, it's the future... and the future it's on our hands!!!
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/03/2007, 18:06
Resposta: #17
 
dmatrix Escreveu:no play do gdm não toca o som? veja se existe o utilitário play:
$ type play
Agora lá preferências > som é utilizado o daemon esd

Quando vou em preferências > som na caixa está assim:
(x) Habiliitar mixagem por software (ESD)
(x) Reproduzir sons do sistema

Então eu deixei habilitado os dois.
E então dou um click no play, mas não sai nada de som, mesmo tento escolhido um arquivo *.wav.

LINUX, it's the future... and the future it's on our hands!!!
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/03/2007, 21:41
Resposta: #18
 
bom pelo que vi seu user faz parte do grupo audio mas o dsp não está correto, isso num é muito fácil de se corrigir até porque provávelmente está utilizando o udev e é ele quem cria os devs. Bom vamos fazer o seguinte teste:
# rm /dev/dsp
# mknod /dev/dsp c 14 3
# chgrp audio /dev/dsp
# chmod 660 /dev/dsp

agora tente executa o play com o phone.wav conforme citado anteriomente. se sair o som vá no gdmsetup e teste tb os sons lá.
No gnome-sound-properties só vai funcionar se estiver carregando o esd mas isso acho que não vai querer.
Só tem um probleminha essas configurações acima deve perder ao reiniciar.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/03/2007, 00:32
Resposta: #19
 
dmatrix Escreveu:No gnome-sound-properties só vai funcionar se estiver carregando o esd mas isso acho que não vai querer.
Só tem um probleminha essas configurações acima deve perder ao reiniciar.

Realmente grande dmatrix deu certo, mas como vc tinha previsto o som num saiu no gnome-sound-properties e também como vc previu as configurações se perderam ao reiniciar o pc.

Será que há um modo de se auto-configurar esses comandos ou então salvar essas configurações? E Por que está acontecendo isso, num era pra funcionar sem precisar fazer esses ajustes? Esse problema num deve ser só no meu pc, então isso é um bug?

LINUX, it's the future... and the future it's on our hands!!!
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/03/2007, 16:57
Resposta: #20
 
infelizmente esse problema provávelmente faz parte de uma má instalação do Alsa ou do sistema do udev. Verifique se existe o script que cria os dev em /sbin/MAKEDEV localize em seu conteúdo a linha referente ao dispositivo dsp (makedev dsp ) verifique se está no grupo certo e permissões como abaixo. Creio que esse problema seja só no seu pc.
Código:
audio)
                major=`Major sound 14`
                makedev mixer      c $major  0 $audio
                makedev mixer1     c $major 16 $audio
                makedev mixer2     c $major 32 $audio
                makedev mixer3     c $major 48 $audio
                makedev sequencer  c $major  1 $audio
                makedev midi00     c $major  2 $audio
                makedev midi01     c $major 18 $audio
                makedev midi02     c $major 34 $audio
                makedev midi03     c $major 50 $audio
                makedev dsp        c $major  3 $audio
                makedev dsp1       c $major 19 $audio
                makedev dsp2       c $major 35 $audio
                makedev dsp3       c $major 51 $audio
                makedev audio      c $major  4 $audio
                makedev audio1     c $major 20 $audio
                makedev audio2     c $major 36 $audio
                makedev audio3     c $major 52 $audio
                makedev sndstat    c $major  6 $audio
                makedev audioctl   c $major  7 $audio

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/03/2007, 17:52
Resposta: #21
 
Aqui vai como está o meu MAKEDEV:

audio)
major=`Major sound 14`
makedev mixer c $major 0 $audio
makedev mixer1 c $major 16 $audio
makedev mixer2 c $major 32 $audio
makedev mixer3 c $major 48 $audio
makedev sequencer c $major 1 $audio
makedev midi00 c $major 2 $audio
makedev midi01 c $major 18 $audio
makedev midi02 c $major 34 $audio
makedev midi03 c $major 50 $audio
makedev dsp c $major 3 $audio
makedev dsp1 c $major 19 $audio
makedev dsp2 c $major 35 $audio
makedev dsp3 c $major 51 $audio
makedev audio c $major 4 $audio
makedev audio1 c $major 20 $audio
makedev audio2 c $major 36 $audio
makedev audio3 c $major 52 $audio
makedev sndstat c $major 6 $audio
makedev audioctl c $major 7 $audio
major=31
makedev mpu401data c $major 0 $audio
makedev mpu401stat c $major 1 $audio
major=35
for i in 0 1 2 3
do

Me parece que num tem nada de diferente do seu.

LINUX, it's the future... and the future it's on our hands!!!
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/03/2007, 23:46
Resposta: #22
 
como disse isso num é muito fácil, pois percebemos que está sendo criado um arquivo normal e não um arquivo especial de caracter. Pode até ser o MAKEDEV esteja correto e sendo executado porém algum outro script pode estar alterando. Verifique se existe um link do MAKEDEV no /dev:
$ ls-l /dev/MAKEDEV
veja tb se no /etc/init.d/udev há uma chamada para que se crie tal link:
Código:
create_dev_makedev() {
  if [ -e /sbin/MAKEDEV ]; then
    ln -s /sbin/MAKEDEV /dev/MAKEDEV
  else
    ln -s /bin/true /dev/MAKEDEV
  fi
}

Talvez uma atualização do pacote Udev resolva esse problema.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/03/2007, 00:13
Resposta: #23
 
Aí está o link:
XBlade:/home/adilson# ls -l /dev/MAKEDEV
lrwxrwxrwx 1 root root 13 2007-03-27 19:25 /dev/MAKEDEV -> /sbin/MAKEDEV

Veja se é esta parte do /etc/init.d/udev que vc está falando:
create_dev_makedev() {
if [ -e /sbin/MAKEDEV ]; then
ln -sf /sbin/MAKEDEV /dev/MAKEDEV
else
ln -sf /bin/true /dev/MAKEDEV
fi


Repare que no link está ln -sf e não ln -s como no seu acima citado.

dmatrix Escreveu:Talvez uma atualização do pacote Udev resolva esse problema.

Então qaunto a isso tenteii desinstalar o Udev através do apt-get remove udev, mas olha:
XBlade:/home/adilson# apt-get remove udev
Lendo lista de pacotes... Pronto
Construindo árvore de dependências... Pronto
Os pacotes a seguir serão REMOVIDOS:
gnome-desktop-environment gnome-volume-manager hal initramfs-tools kde
kde-amusements kde-core kdebase linux-image-2.6-686 linux-image-2.6.18-3-686
udev
0 pacotes atualizados, 0 pacotes novos instalados, 11 a serem removidos e 0 não atualizados.
É preciso fazer o download de 0B de arquivos.
Depois de desempacotar, 55,7MB de espaço em disco serão liberados.
Quer continuar [S/n]?

Acho que assim não deve dar certo né?

LINUX, it's the future... and the future it's on our hands!!!
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/03/2007, 00:22
Resposta: #24
 
esse -sf não tira a essência do link apenas indica que se existir o link será removido a força. Mas o link está sendo criado? Qual a versão do seu udev?
$ dpkg -l udev

não remova , atualize.
# aptitude install udev

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/03/2007, 00:25
Resposta: #25
 
ii udev 0.105-4 /dev/ and hotplug management daemon

LINUX, it's the future... and the future it's on our hands!!!
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/03/2007, 00:30
Resposta: #26
 
voltando ao /sbin/MAKEDEV, veja se no inicio dele o audio está configurado com essas permissões:
Código:
coda="  root root   0600"
scanner="  root root   0666"
  ibcs2="  root root   0666"
  video="  root video  0660"
  audio="  root audio  0660"    <--------
   tape="  root tape   0660"
  cdrom="  root cdrom  0660"
   scsi="  root root   0600"
   disk="  root disk   0660"
floppy="  root floppy 0660"
printer="  root lp     0660"

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/03/2007, 00:30
Resposta: #27
 
tentei mas olha:
XBlade:/home/adilson# aptitude install udev
Lendo lista de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informações estendidas de estado
Inicializando estados de pacotes... Pronto
Gravando informações estendidas de estado... Pronto
Lendo descrições de tarefas... Pronto
Construindo a base de dados... Pronto
Os pacotes a seguir foram mantidos:
bind9-host dnsutils epiphany-browser firefox gnome-core
gnome-desktop-environment gnomemeeting initscripts libbind9-0 libisccfg1
linux-image-2.6-686 nautilus nautilus-cd-burner nautilus-data sysvinit
wine
0 pacotes atualizados, 0 novos instalados, 0 a serem removidos e 16 não atualizados.
É preciso obter 0B de arquivos. Depois do desempacotamento, 0B serão usados.
Gravando informações estendidas de estado... Pronto

Se eu tentar dar um aptitude dist-upgrade, só que vai atualizar o kernel, e vou pro unstable?

LINUX, it's the future... and the future it's on our hands!!!
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/03/2007, 00:34
Resposta: #28
 
Olha também tá normal:

cdrom=" root cdrom 0660"
tape=" root tape 0660"
audio=" root audio 0660"
video=" root video 0660"

Será que se eu instalar de novo o debian-br-cdd de novo na outra partição apenas pra teste para ver se lá funciona é uma boa tentativa pra teste?

LINUX, it's the future... and the future it's on our hands!!!
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/03/2007, 00:36
Resposta: #29
 
tá usando unstable?? não deveria...se não tiver feito a hibridização aos poucos qualquer pacotes que instalar vai danificando a distro. O udev está atualizado, essa versão acho que é a ultima.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/03/2007, 00:41
Resposta: #30
 
é essa parte parece estar certo agora tem que ver as regras no udev em /etc/udev. no momento não tenho como localizar o arquivo de regras exato para ver isso pois o meu sistema aqui utiliza o hotplug amanhã estarei vendo em um sistema que utiliza o udev.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS