Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
FSTAB muda a cada inicialização no Knoppix 5..1.1
21/02/2007, 09:44
Resposta: #1
FSTAB muda a cada inicialização no Knoppix 5..1.1
Bom dia a todos. Curiosamente, o /etc/fstab muda cada vez que inicio o sistema. Optei por montar automaticamente todos os /dev. Só que, faço as alterações necessárias, salva as mesmas, saio e quando reinicio o sistema, muda tudo e o que era para montar automaticamente não monta mais. O que causa isso e como corrigir. Valeu. Cezar


# /etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hdc2 / reiserfs defaults 0 1

proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
usbfs /proc/bus/usb usbfs devmode=0666 0 0
sysfs /sys sysfs defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
/dev/cdrom /media/cdrom iso9660 defaults,ro,users,noexec,auto 0 0
/dev/cdrom1 /media/cdrom1 iso9660 defaults,ro,users,noexec,auto 0 0
/dev/cdrom2 /media/cdrom2 iso9660 defaults,ro,users,noexec,auto 0 0
/dev/cdrom3 /media/cdrom3 iso9660 defaults,ro,users,noexec,auto 0 0
/dev/cdrom4 /media/cdrom4 iso9660 defaults,ro,users,noexec,auto 0 0
/dev/cdrom5 /media/cdrom5 iso9660 defaults,ro,users,noexec,auto 0 0
/dev/sda1 /media/sda1 auto users,rw,exec,umask=000 0 0
/dev/sdb1 /media/sdb1 auto users,rw,exec,umask=000 0 0
# Added by KNOPPIX
/dev/hda1 /media/hda1 reiserfs auto,users,exec 0 0
# Added by KNOPPIX
/dev/hda3 /media/hda3 reiserfs auto,users,exec 0 0
# Added by KNOPPIX
/dev/hda5 none swap defaults 0 0
# Added by KNOPPIX
/dev/hdc1 /media/hdc1 reiserfs auto,users,exec 0 0
# Added by KNOPPIX
/dev/sr0 /media/sr0 auto ro,auto,users,exec 0 0
# Added by KNOPPIX
/dev/hdd /media/hdd auto ro,auto,users,exec 0 0
# Added by KNOPPIX
/dev/hdb /media/hdb auto ro,auto,users,exec 0 0
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/02/2007, 15:48
Resposta: #2
 
Cezar, quais os devices que estão modificando? todos ou só os cdrom? modifique as linhas do cdrom para noauto e teste novamente, visto que não deve ter media em todos eles ao inicializar o sistema certo?
/dev/cdrom /media/cdrom iso9660 defaults,ro,users,noexec,noauto 0 0
/dev/cdrom1 /media/cdrom1 iso9660 defaults,ro,users,noexec,noauto 0 0
/dev/cdrom2 /media/cdrom2 iso9660 defaults,ro,users,noexec,noauto 0 0
/dev/cdrom3 /media/cdrom3 iso9660 defaults,ro,users,noexec,noauto 0 0
/dev/cdrom4 /media/cdrom4 iso9660 defaults,ro,users,noexec,noauto 0 0
/dev/cdrom5 /media/cdrom5 iso9660 defaults,ro,users,noexec,noauto 0 0

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/02/2007, 09:07
Resposta: #3
 
Olá, sim eu mudo, mas não adianta. Eu salvo todas as mudanças, de "noauto" para "auto" , mas TODA vez que inicio o sistema, não adianta, não adianta, todas as demais partições que existem nos dois HD não vêm como "auto", volta a ser "noauto". Só o pendrive /dev/sda1 que permanece, as demais partições não. Não consigo entender isso. Cezar


/etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hdc2 / reiserfs defaults 0 1

proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
usbfs /proc/bus/usb usbfs devmode=0666 0 0
sysfs /sys sysfs defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
/dev/cdrom /media/cdrom iso9660 defaults,ro,users,noexec,auto 0 0
/dev/cdrom1 /media/cdrom1 iso9660 defaults,ro,users,noexec,auto 0 0
/dev/cdrom2 /media/cdrom2 iso9660 defaults,ro,users,noexec,auto 0 0
/dev/cdrom3 /media/cdrom3 iso9660 defaults,ro,users,noexec,auto 0 0
/dev/cdrom4 /media/cdrom4 iso9660 defaults,ro,users,noexec,auto 0 0
/dev/cdrom5 /media/cdrom5 iso9660 defaults,ro,users,noexec,auto 0 0



/dev/sda1 /media/sda1 auto users,rw,exec,umask=000 0 0
/dev/sdb1 /media/sdb1 auto users,rw,exec,umask=000 0 0
# Added by KNOPPIX
/dev/hda1 /media/hda1 reiserfs noauto,users,exec 0 0
# Added by KNOPPIX
/dev/hda3 /media/hda3 reiserfs noauto,users,exec 0 0
# Added by KNOPPIX
/dev/hda5 none swap defaults 0 0
# Added by KNOPPIX
/dev/hdc1 /media/hdc1 reiserfs noauto,users,exec 0 0
# Added by KNOPPIX
/dev/sr0 /media/sr0 auto ro,noauto,users,exec 0 0
# Added by KNOPPIX
/dev/hdd /media/hdd auto ro,noauto,users,exec 0 0
# Added by KNOPPIX
/dev/hdb /media/hdb auto ro,noauto,users,exec 0 0
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS