Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Mplayer - erro pra compilar
20/02/2007, 00:54
Resposta: #1
Mplayer - erro pra compilar
Olá pessoal, quando mando compilar o mplayer, é exibido um erro:

mplayer.o(.data+0x3d3c): undefined reference to `subtitle_font_radius'
mplayer.o(.data+0x3d60): undefined reference to `subtitle_font_thickness'
mplayer.o(.data+0x3d84): undefined reference to `subtitle_autoscale'
mplayer.o(.data+0x3da8): undefined reference to `font_fontconfig'
mplayer.o(.data+0x3dcc): undefined reference to `font_fontconfig'
collect2: ld returned 1 exit status
make: *** [mplayer] Error 1

O que devo fazer?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/02/2007, 08:00
Resposta: #2
 
isso ta parecendo que ta faltando algum componente.. tipo uma lib, vc tem tudo instalado pra compila? o gcc, tk, tcl, tudo blz?

e pq naum vai pelo bom apt-get install mplayer?

Debian User
Obtenha seu nº de usuario linux: http://counter.li.org/!
# Linux User 443090
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/02/2007, 12:06
Resposta: #3
 
Pra que reinventar a roda....
http://wiki.forumdebian.com.br/index.ph ... yer_debian

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/02/2007, 12:10
Resposta: #4
 
se realmente quiser compilar o mplayer, faça do modo Debian !

use o apt-build

http://wiki.forumdebian.com.br/index.php/Apt-build

depois de instalado faça:

apt-build install mplayer

[Imagem: debianuseruserbarsp1.png]
[Imagem: gnomeuserqj9.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/02/2007, 19:14
Resposta: #5
 
rodhash,

Eu aconselho vc instalar via apt-get como na wiki por no caso de vc querer remover o mplayer vc nao vai poder se instalar da forma que vc esta tentando

[Imagem: banner_user.png]
[Imagem: 1819-52002.png]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/02/2007, 00:34
Resposta: #6
 
Bom, duas notações rápidas. Se eu instalar o libgtk1.2-dev ou libgtk2.0-dev eu não tenho erros para ./configure. Porém há erros no make.

Sem libgtkx instalado, consigo instalar sem a opção --enable-gui. Porém os vídeos não funcionam.

Baixei os codecs desta url: http://www.mplayerhq.hu/design7/dload.h ... ary_codecs

O que fiz de errado para o vídeo wmv não funcionar?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/02/2007, 15:23
Resposta: #7
 
Agora, configure, compilei e instalei sem problemas. Porém só funciona as músicas. O vídeo fica preto.

Os codecs peguei no site www.mplayerhq.hu
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/02/2007, 15:35
Resposta: #8
 
Vejam o que acontece:

sti-rodrigo:/home/rodrigo/downloads# mplayer /home/rodrigo/downloads/Puloufora.wmv
MPlayer 1.0pre8-3.3.5 © 2000-2006 MPlayer Team
CPU: AMD Athlon™ Processor (Family: 6, Model: 4, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx

Linux RTC init error in ioctl (rtc_irqp_set 1024): Invalid argument
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.

Playing /home/rodrigo/downloads/Puloufora.wmv.
ASF file format detected.
VIDEO: [WMV3] 320x240 24bpp 1000.000 fps 0.0 kbps ( 0.0 kbyte/s)
Clip info:
author: fugly.com
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, s16le, 64.0 kbit/4.54% (ratio: 8005->176400)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
vo: couldn't open the X11 display ()!
vo: couldn't open the X11 display ()!
VO XOverlay need a subdriver
[gl] using extended formats. Use -vo gl:nomanyfmts if playback fails.
vo: couldn't open the X11 display ()!
vo: couldn't open the X11 display ()!
vo: couldn't open the X11 display ()!
Can't open /dev/fb0: No such device
[fbdev2] Can't open /dev/fb0: No such device
No vidix driver name provided, probing available ones (-v option for details)!
vo: couldn't open the X11 display ()!
vo_cvidix: No vidix driver name provided, probing available ones (-v option for details)!
[VO_SUB_VIDIX] Couldn't find working VIDIX driver.
==========================================================================
Opening video decoder: [dmo] DMO video codecs
DMO dll supports VO Optimizations 0 1
DMO dll might use previous sample when requested
GetOutput r=0x0 size:230400 align:1
StreamCount r=0x0 1 1
Decoder supports the following formats: YV12 YUY2 UYVY YVYU RGB8 RGB555 RGB565 RGB24 RGB32
Decoder is capable of YUV output (flags 0x1b)
VDec: vo config request - 320 x 240 (preferred colorspace: Packed YUY2)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [null] 320x240 => 320x240 Planar YV12
Selected video codec: [wmv9dmo] vfm: dmo (Windows Media Video 9 DMO)
==========================================================================
AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)
Starting playback...
A: 4.9 V: 4.9 A-V: 0.007 ct: -0.038 28/ 28 16% 0% 3.2% 0 0

MPlayer interrupted by signal 2 in module: sleep_timer
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/02/2007, 20:23
Resposta: #9
 
rodhash,

Abra o mplayer -> clique com o botão direito -> vá em preferences -> abra a aba Video -> tente selecionar xv ou x11.

Lembrando que você deve reiniciar o mplayer para que essas alterações sejam feitas.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/02/2007, 10:06
Resposta: #10
 
Então, com esta versão (MPlayer 1.0pre8-3.3.5) eu não consegui. Mas instalei uma versão anterior, a pre7 e funcionou perfeitamente.
Quando eu ia nesta opção, não exibia nenhum driver de video. Apenas na versão pre7 que exibiu.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS