Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
O dhcp cliente não esta funcionando, não pega o Ip automatic
23/01/2007, 07:11
Resposta: #1
O dhcp cliente não esta funcionando, não pega o Ip automatic
Senhores, todas as vezes que reinicio o sistema o dhcp cliente não está pegando o IP Automatico, alias nem deixando com o IP Statico esta levantando a rede.

Deixei assim para no arquivo /etc/network/interface com IP Fixo e mesmo assim não levanta.

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
address 192.168.1.4
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255


Tenho que fazer tudo manual.

ifconfig eth0 192.168.1.4 nemask 255.255.255.0 up
route add default gw 192.168.1.1 eth0

Abraço
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/01/2007, 08:06
Resposta: #2
 
fazendo manualmente funciona? Já testou outro sistema ou placa de rede?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/01/2007, 10:54
Resposta: #3
 
spikey Escreveu:fazendo manualmente funciona? Já testou outro sistema ou placa de rede?

Manualmente funciona, a placa de rede não acredito que seja o vilão, pois tenho o WinXP como dual boot e funciona normalmente.

Deve ser algum probleminha com o daemon do dhcp-client

Até encontrar a solução coloquei no /etc/init.d/bootmisc as duas linhas do ifconfig e route.

Bom quem suber como deixar corretamente, caso eu encontre a solução informarei.

Abraço
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/01/2007, 11:30
Resposta: #4
 
jgama, me parece que sua configuração do DHCP é que esta errada, pois vc não definiu em qual interface ele vai receber o dhcp:

acredito que o certo seria:
Citar:auto lo
iface lo inet loopback


auto eth0
iface eth0 inet dhcp

E para estatico seria:

Citar:auto eth0
iface eth0 inet static
address 192.168.1.4
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255

Visite também o Nosso Wiki
WikiForumdebian

--
"In a World without Walls and Fences, who needs Windows and Gates? -
Think different. -Think Linux."
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/01/2007, 21:57
Resposta: #5
 
Jgama,

o que você tem aí como gateway?? um modem router ou um servidor dedicado?

Se for um router ele pode fornecer o ip automaticamente ou você fixar um ip dentro de uma faixa range de ips que você escolher no router.


Se for um servidor dedicado, como o que tenho aqui, configurei ele para fornecer ip´s fixos através do endereço mac da placa de rede. No caso, estou utilizando o dhcp3-server, para esse tipo de configuração no arquivo das estações você vai utilizar apenas a primeira opção que o ljulio comentou:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp


:wink: espero ter contribuído
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS