Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
rede e compartilhamento não funcionam
20/01/2007, 02:29
Resposta: #1
rede e compartilhamento não funcionam
Caros amigo,
Já criei um tópico sobre o meu compartilhamento que não está funcionando, agora percebi também que o sistema não está segurando a configuração da rede, quando cofigura ela funciona mas ao desligar ou reiniciar a configuração é perdida, segue abaixo o meu /etc/network/interfaces, a minha conexão está funcionando perfeitamente mas ainda não consegui compartilhar mesmo qdo a rede funciona:

iface eth0 inet static
address 192.168.0.1
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255

auto dsl-provider
iface dsl-provider inet ppp
provider dsl-provider
# please do not modify the following line
pre-up /sbin/ifconfig eth1 up # line maintained by pppoeconf

Meu arquivo /etc/init.d/bootmisc.hs

modprobe iptabLe_nat
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUNTING -o ppp0 -j MASQUERADE

Até mais
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/01/2007, 07:27
Resposta: #2
 
linuxerbel,

Tente alterar

Código:
modprobe iptabLe_nat
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUNTING -o ppp0 -j MASQUERADE

Para

Código:
modprobe iptabLe_nat
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUNTING -o eth1 -j MASQUERADE

Veja se assim ele começa a compartilhar e volte a postar.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/01/2007, 00:47
Resposta: #3
 
Caro Fernando,

Fiz a alteração que voce sugeriu acima, mas mesmo assim ainda continua sem compartilhar.

até mais

Os lucros decorrentes das vendas de Software Proprietário são sempre privatizados, enquanto que os frutos da produção de Software Livre tornam-se disponíveis para toda a comunidade.
_____________________________
Debian-BR-CDD
Debian à brasileira.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/01/2007, 08:10
Resposta: #4
 
linuxerbel,

Você configurou as máquinas clientes corretamente? Qual o gateway que você colocou nelas?

Você poderia postar o resultado do comando ifconfig quando a conexão estiver funcionando?
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/01/2007, 13:27
Resposta: #5
 
Coloque na sua configuração de rede, a opção:

auto eth0

como já existe na sua configuração do ADSL

Eustáquio Júnior
[email protected]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/01/2007, 11:09
Resposta: #6
 
Ola galera, sou iniciante no linux mas preciso saber como posso compartilhar internet com meus vizinhos só que eles usan windows, nós temos um switch que da para todos porém eu queria saber um jeito de eu controlar a quantidade de kbs de cada um se for possível.

Valeu desde já galera, qualquer informação a respeito é valido.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/02/2007, 02:10
Resposta: #7
 
iservidor:/home/luis# ifconfig
eth0 Encapsulamento do Link: Ethernet Endereço de HW 00:40:F4:7D:37:50
inet end.: 192.168.0.1 Bcast:192.168.0.255 Masc:255.255.255.0
endereço inet6: fe80::240:f4ff:fe7d:3750/64 Escopo:Link
UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
RX packets:151 errors:0 dropped:0 overruns:0 frame:0
TX packets:196 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:1000
RX bytes:11592 (11.3 KiB) TX bytes:22955 (22.4 KiB)
IRQ:10 Endereço de E/S:0xec00

eth1 Encapsulamento do Link: Ethernet Endereço de HW 00:30:1B:36:2F:B9
endereço inet6: fe80::230:1bff:fe36:2fb9/64 Escopo:Link
UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
RX packets:10936 errors:0 dropped:0 overruns:0 frame:0
TX packets:9497 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:1000
RX bytes:13565321 (12.9 MiB) TX bytes:984450 (961.3 KiB)
IRQ:11 Endereço de E/S:0xd800

lo Encapsulamento do Link: Loopback Local
inet end.: 127.0.0.1 Masc:255.0.0.0
endereço inet6: ::1/128 Escopo:Máquina
UP LOOPBACKRUNNING MTU:16436 Métrica:1
RX packets:214 errors:0 dropped:0 overruns:0 frame:0
TX packets:214 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:0
RX bytes:13992 (13.6 KiB) TX bytes:13992 (13.6 KiB)

ppp0 Encapsulamento do Link: Protocolo Ponto-a-Ponto
inet end.: 201.9.131.202 P-a-P:200.217.255.112 Masc:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Métrica:1
RX packets:10758 errors:0 dropped:0 overruns:0 frame:0
TX packets:9314 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:3
RX bytes:13317896 (12.7 MiB) TX bytes:773545 (755.4 KiB)

servidor:/home/luis#

Os lucros decorrentes das vendas de Software Proprietário são sempre privatizados, enquanto que os frutos da produção de Software Livre tornam-se disponíveis para toda a comunidade.
_____________________________
Debian-BR-CDD
Debian à brasileira.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/02/2007, 09:34
Resposta: #8
 
Bom dia pessoal,

Acima está o resulktado o ifconfig, todas as alternativas que me fora sugerida eu já fiz o sarge continua sem compartilhar:
tentei mudançcas como as abaixo:
iptables -t nat -A POSTROUNTING -o ppp0 -j MASQUERADE
ou
iptables -t nat -A POSTROUNTING -o eth1 -j MASQUERADE
ou
iptables -t nat -A POSTROUNTING -s ppp0 -s 192.168.0.0/24 -j MASQUERADE
e também acrescentei a seguinte regra:
iptables -A FORWARD -p tcp --tcp-flags SYN,RST SYN -m \
tcpmss --mss 1400:1536 -j TCPMSS --clamp-mss-to-pmtu

E como ainda estou engatinhando no debian tenho mais uma pergunta que é sobre a configuração da rede, pelo que estou lendo a configuração e feita no arquivo /etc/network/interfaces, mas se eu não comolar o comando: ifconfig eth0 192.168.0.1 netmask 255.255.255.0 up no arquivo /etc/init.d/bootmisc.sh a rede não é ativada despois de um reboot, pq?

alguem mais alguma alternativa.
PS: não quero rotear o modem e não quero montar um roteador coyote, quero realmente fazer com que o debian compartilhe a conexão.

até mais
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/02/2007, 14:50
Resposta: #9
 
vamos por partes, a respeito da rede, faça o seguinte para que toda vez ela funcione

vim /etc/network/interfaces

auto eth0 # coloque esta linha aqui no seu arquivo.
iface eth0 inet static
address 192.168.0.1
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255

auto dsl-provider
iface dsl-provider inet ppp
provider dsl-provider
# please do not modify the following line
pre-up /sbin/ifconfig eth1 up # line maintained by pppoeconf

assim, ele irá configurar a rede toda vez que der boot, poste o resultado aqui p/ gente acompanhar.

Eustáquio Júnior
[email protected]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/02/2007, 15:31
Resposta: #10
 
A rede já está funcionando.
até mais

Os lucros decorrentes das vendas de Software Proprietário são sempre privatizados, enquanto que os frutos da produção de Software Livre tornam-se disponíveis para toda a comunidade.
_____________________________
Debian-BR-CDD
Debian à brasileira.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS