Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Instalando maildrop com suporte ao mysql
22/01/2007, 23:14
Resposta: #16
 
Que coisa amigo, mesmo com o debian instalado não estou conseguindo instalar o maidrop

OBS: instalei o debian com unico cd Basico, estou complementadno com pacotes baixado via apt-get ou aptitude.

Agora aparece esta messagem, pelo qu entendi não era para ter maiores consequencia, mas ....

configure: creating ./config.status
config.status: creating xconfig.h
config.status: creating Makefile
config.status: creating README.html
config.status: creating testsuite
config.status: creating config.h
config.status: executing depfiles commands
+ '--mandir=${prefix}/share/man' '--libexecdir=${prefix}/lib/maildrop'
debian/rules: line 16: --mandir=${prefix}/share/man: No such file or directory

Quando rodo o comando para verificar se copilou o suporte ao mysql da erro.

huguinho:~/maildrop/maildrop-1.5.3# maildrop -v
bash: maildrop: command not found

Só para trar a dúvida se realmente foi criado o pacote maildrop rodei o comando:

dpkg: error processing maildrop_1.5.3-1.1_i386.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
maildrop_1.5.3-1.1_i386.deb
huguinho:~/maildrop#

Bom pelo jeito nada feito, agora o que será que deu pau?

Será que não irei ter sucesso?

Abraço
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/01/2007, 16:17
Resposta: #17
 
o primeiro comando acima é o .configure ? se for está faltando alguma dependencia...verifique isso...na log de config.log

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/01/2007, 00:12
Resposta: #18
 
não é ./configure

É este comando dpkg-buildpackage -rfakeroot -uc -b

Abraço
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/01/2007, 08:29
Resposta: #19
 
jgama Escreveu:não é ./configure

É este comando dpkg-buildpackage -rfakeroot -uc -b

Abraço

nunca usei esse comando, qual seria o produto final desse comando.... um arquivo de pacote .deb para instalar ou já instala direto o o programa? Vou chutar.....se esse comando é para criar pacote então vc deve estar referenciando algum diretório para contruí-lo certo? neste caso e baseado no erro acima, está faltando neste diretório o /share/man

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/01/2007, 15:13
Resposta: #20
Re: Instalando maildrop com suporte ao mysql
jgama Escreveu:Olá pessoal, acho que este é o quinto forúm que posto e até o momento não consegui resposta, posi já procurei encontra a solução, pode ser até facil, mas não tenho muita expeiência com Debian e nem com Linux, mas já consigo fazer bastante coisas.

Bom o meu problema é na hora de instalar o pacote maildrop com os comando abaixo:

# mkdir ~/maildrop
# cd ~/maildrop
# apt-get build-dep maildrop
# apt-get source maildrop
# cd maildrop-1.5.3/debian


Pessoal estou tentando baixar esses dois arquivos pelo apt-get porem não estou encontrando.... quais os repositórios utilizados para baixar os mesmos.

Leonardo Bueno
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/01/2007, 17:30
Resposta: #21
 
Olá Leonardo tenta este mirros e coloca no /etc/apt/sources.list não equece de executar apt-get update

deb-src http://ftp.br.debian.org/debian stable main contrib non-free

Quando vc rodar o apt-get update vai aparcer umas messagem diozendo que não tem chave blabla, mas vai baixar o source.

Abraço
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/01/2007, 17:38
Resposta: #22
 
Agora minha gente, meu problema e creio quem for usar o pacote source do maildrop para incluir o suporte ao mysql vai ter problema.

E até o momento não consegui resolver, já apelei para o pacote baixado no site do desenvolvedor e copilei com suporte ao mysql, mas sem sucesso. Estou não entendo porque não mostra que o mysql foi incorporado.

Depois da copilação e instalação executo o comando para verificação e nada de mysql.

# maildrop/maildrop -v
maildrop 1.5.3 Copyright 1998-2003 Double Precision, Inc.
GDBM extensions enabled.
Maildir quota extension enabled.
This program is distributed under the terms of the GNU General Public
License. See COPYING for additional information.


Já tentei com pacote também versão 2.0.3 mas sempre a mesma coisa o supoete ao mysql não aparece, mesmo incluindo a linha dentro do pacote antes de copilar " --enable-maildropmysql "

Puxa vida será que ninguém teve este problema ou resolveu e poderia ajudar-nos.

Abraço
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/01/2007, 14:45
Resposta: #23
 
veja...apenas segui esse tutorial http://www.vivaolinux.com.br/artigos/ve ... pagina=10#
somente trocando a linha onde ele pos # checkinstall -R digitei # make install e agora apresenta-se assim a versão:
~/maildrop-1.6.3$ maildrop -v
maildrop 1.6.3 Copyright 1998-2003 Double Precision, Inc.
Maildir quota extension enabled.
Virtual user database via MySQL extension enabled.
This program is distributed under the terms of the GNU General Public
License. See COPYING for additional information.

Obs: tive que instalar algumas libs de desenvolvimento do mysql ( aptitude install libmysql++-dev )

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/01/2007, 16:35
Resposta: #24
 
beleza, irei tentar, hoje um amigo meu que montou um Servidor também com Postfix e Debian, falou que no lugar do maildrop, pode usar o courier-maildrop que faz o mesmo papel e muito mais facil de instalar já que baixa direto pelo apt-get.

Bom irei fazer o teste com o dois e verei qual irei ter sucesso.

Valeu amigão
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/01/2007, 19:06
Resposta: #25
dificuldades para compilar o maildrop
pessoal estou tentando compilar o maildrop com suporte a mysql, porem estou com a seguinte dificuldade

quando coloco o comando para compilar para rodar aparece o seguinte erro no final de todo o processo:

config.status: creating testsuite
config.status: creating config.h
config.status: executing depfiles commands
+ --enable-maildrop-uid=120
debian/rules: line 18: --enable-maildrop-uid=120: command not found

abaixo um trecho do arquivo RULES alterado.....


[ -f config.status ] || CPPFLAGS="$CFLAGS" ./configure --prefix=/usr \
--mandir='${prefix}/share/man' --libexecdir='${prefix}/lib/maildrop' \
--sysconfdir=/etc/maildrop
--enable-maildrop-uid=120
--enable-maildrop-gid=120
--enable-syslog=1
--enable-maildropmysql
--enable-use-dotlock=1 --enable-use-flock=1
--enable-sendmail=/usr/sbin/sendmail --enable-maildirquota
[ -f maildrop/maildrop ] || make



alguem poderia me ajudar.....

Atenciosamente,

Leonardo Bueno
Linux até o fim........
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/01/2007, 20:36
Resposta: #26
 
Vc tem o usuario maidrop com uid 12 criado ?

Amigo esquece este esquema de copilar o source codebian pega o pacote courier-maildrop pelo apt-get ou aptitude vai fazer a mesma coisa.

abraço
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/01/2007, 06:43
Resposta: #27
 
jgama Escreveu:Vc tem o usuario maidrop com uid 12 criado ?

Amigo esquece este esquema de copilar o source codebian pega o pacote courier-maildrop pelo apt-get ou aptitude vai fazer a mesma coisa.

abraço


Mas ele da suporte a mysql????? e a configuração dele é a mesma coisa que o maildrop???



Leonardo Bueno
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/01/2007, 20:52
Resposta: #28
 
Citar:Mas ele da suporte a mysql????? e a configuração dele é a mesma coisa que o maildrop???

Leonardo Bueno


Não posso afirmar 100% mais 99% sim, porque tenho um colega que montou um MTA na Empresa que trabalha e já faz masi de 3 anos não teve problema com as tabelas do mysql, pois o courier-maildrop não usa o mysql diretamente mais tem a bibliotecas do mysql, ou seja da suporte sim.

Abraço

[/quote]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
31/01/2007, 13:50
Resposta: #29
Erro na compilação do postfix....
Pessoal,
Estou com um novo erro agora..... em minha instalação do servidor....

Estou seguindo um novo tutorial..... http://www.vivaolinux.com.br/artigos/ver...1&pagina=3 após realizar a compilação do postfix.... aparece o seguinte erro

Código:
[email protected]:/usr/src# dpkg -i postfix_2.1.5-9_i386.deb
Selecionando pacote previamente não selecionado postfix.
dpkg: sobre postfix_2.1.5-9_i386.deb contendo postfix:
libsasl2-2 conflita com postfix (<< 2.3.4-3)[email protected]:/usr/src# dpkg -i postfix_2.1.5-9_i386.deb
Selecionando pacote previamente não selecionado postfix.
dpkg: sobre postfix_2.1.5-9_i386.deb contendo postfix:
libsasl2-2 conflita com postfix (<< 2.3.4-3)
  postfix (versão 2.1.5-9) está para ser instalado.
dpkg: erro processando postfix_2.1.5-9_i386.deb (--install):
pacotes conflitantes - não instalando postfix
Erros foram encontrados durante processamento de:
postfix_2.1.5-9_i386.deb
[email protected]:/usr/src#
  postfix (versão 2.1.5-9) está para ser instalado.
dpkg: erro processando postfix_2.1.5-9_i386.deb (--install):
pacotes conflitantes - não instalando postfix
Erros foram encontrados durante processamento de:
postfix_2.1.5-9_i386.deb
[email protected]:/usr/src#

Alguem poderia me ajudar e informar o que posso fazer para corrigir o mesmo...


Atenciosamente,

Leonardo Bueno
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/02/2007, 08:40
Resposta: #30
 
Porquer vc não usa o postfix 'baixado pelo aptitude ou apt-get?

Abraço
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 2 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS