Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Desabilitar touchpad por completo [SOLVED]
02/01/2007, 11:05
Resposta: #1
Desabilitar touchpad por completo [SOLVED]
Pessoal,

possuo um mouse USB e quero desabilitar o touchpad pra usar apenas o USB.

No momento os dois funcionam normalmente.

Como faço pra desabilitar?

Danilo
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/01/2007, 11:50
Resposta: #2
 
você pode desligar no SETUP do seu notebook ou desabilitá-lo no /etc/X11/xorg.conf comentando as linhas que chamam os módulos.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/01/2007, 12:06
Resposta: #3
 
Tentei isso.

Comentei primeiro a linha que chamava o touchpad dentro do escopo do server. Mas não adiantou.

Aí comentei tudo que era linha relacionada ao touchpad no xorg.conf e mesmo assim ele tava funcionando.

Tô fazendo todos os teste no Ubuntu Edgy.

Falou
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/01/2007, 12:23
Resposta: #4
 
danvalho, quando vc comentou as linhas vc inicio o X para que ele carregar as novas configurações???

se vc usar o Gnome+GDM

/etc/init.d/gdm restart

Se vc usa o kde+kdm

/etc/init.d/kdm restart

Visite também o Nosso Wiki
WikiForumdebian

--
"In a World without Walls and Fences, who needs Windows and Gates? -
Think different. -Think Linux."
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/01/2007, 17:15
Resposta: #5
 
tente desabilitar deste modo, esteja certo que no seu /etc/X11/xorg.conf existe as linhas:
Código:
Section "InputDevice"
  Identifier   "Synaptics Touchpad"
  Driver      "synaptics"
  Option      "SendCoreEvents"        "true"
  Option      "Device"                "/dev/psaux"
  Option      "Protocol"              "auto-dev"
  Option      "HorizScrollDelta"      "0"
  Option      "SHMConfig"             "on"
EndSection
Com o SHMConfig configurado como acima digite o seguinte comando no terminal:
$ synclient TouchpadOff=1

depois veja se mesmo reiniciando X o touchpad continua desabilitado ( utilize a sequencia de teclas ctrl+alt+backspace )

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/01/2007, 22:23
Resposta: #6
 
Valeu dmatrix, sua dica funcionou.

Não precisei comentar nada no /etc/X11/xorg.conf, apenas adicionei a linha

Option "SHMConfig" "on"

na definição do synaptic/touchpad e utilizei o comando

$ sudo synclient TouchpadOff=1

Valeu mesmo, pessoal.

Só mais uma coisa, vocês podiam explicar o que são exatamente essa opção e esse comando. Pois percebi que existe um cliente que controla o synaptic/touchpad em tempo de execução, mas que temos que adicionar aquela opção no xorg.conf para poder utilizá-lo.

Obrigado a todos.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/01/2007, 12:38
Resposta: #7
 
Essa opção SHMConfig em conjunto com um dos pacotes Gsynaptics ou Ksynaptics torna possível configurar pelo modo gráfico o comportamento do touchpad ( a instalação de um desses pacotes adiciona um icone ao painel de ferramentas )
Além do synclient que é a ferramenta modo texto de configurar, existe o syndaemon que pode ser utilizado para desativar temporáriamente o touchpad por um tempo configurável, o padrão é 2 segundos após inatividade do teclado retorna o seu funcionamento, só que para caso de utilização constante do syndaemon seria necessário adicionar no iniciar da sessão.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/01/2007, 22:30
Resposta: #8
 
Valeu, dmatrix.

Vou já dar um apt-get Gsynaptics Alegre

Falou

Brainstorm...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS