Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Touchpad do Notebook
25/12/2006, 12:02
Resposta: #1
Touchpad do Notebook
Ola galera, tenho um notebook acer Aspire 3690 e gostaria de saber se alguem sabe se tem como desabilitar o clique no touchpad do notebook, gostaria nao de desabilitar o touchpad e sim somente o clique, usar o touchpad somente para apontar e o clique faço usando os botoes. Alguem sabe se é possivel fazer isso?
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/12/2006, 20:26
Resposta: #2
Re: Touchpad do Notebook
arcanjo_mg Escreveu:Ola galera, tenho um notebook acer Aspire 3690 e gostaria de saber se alguem sabe se tem como desabilitar o clique no touchpad do notebook, gostaria nao de desabilitar o touchpad e sim somente o clique, usar o touchpad somente para apontar e o clique faço usando os botoes. Alguem sabe se é possivel fazer isso?

Bom eu não sei se essa opção na configuração do X vai desabilitar por completo o touchpad, creio que não, portanto não sei qual é o X que está utilizando se é Xfree86 ou Xorg, sendo assim vá até o diretório /etc/X11 e veja se existe o xorg.conf caso não exista então procure pelo xfree86config-4 . Edite ele com:
# mcedit /etc/X11/xorg.conf
procure pela seção:
Section "InputDevice"
Identifier "Synaptics Touchpad"
....

localize a opção:

Option "TouchpadOff" "1" #1=off, 2=somente tapping/scrolling desligado

no seu deve estar como "0", reinicialize o pc e veja se resolveu.
Caso não resolva, volte lá e procure pela opção na mesma seção:

Option "SHMConfig" "true"
Option "UseShm" "true"

e instale o gsynaptics para Gnome, ou ksynaptics para KDE.
depois encontre o Configurador gráfico Touchpad no painel de configurações.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/12/2006, 18:41
Resposta: #3
 
Existe um fato interessante, acontece que eu tive um dia um problema com o Xorg e deletei o arquivo de configuração xorg.conf para tentar reinstalar, o que aconteceu que o X ta funcionando de novo mas nao existe mais nenhum arquivo xorg.conf no diretorio /etc/X11. E agora??

"As coisas que você possui acabam te possuindo." - Tyler, Fight Club
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/12/2006, 19:55
Resposta: #4
 
como eu disse acima, se não tem o xorg.conf edite o XF86Config-4

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/12/2006, 10:56
Resposta: #5
 
Cara, nao existe o arquivo xfree86config-4, pois o XFree86 nunca chegou a ser instalado no meu sistema.

Talvez deixei faltar informação, estou usando o Kubuntu 6.10 no notebook, estava instalando alguns pacotes usando o Automatix2 e ai quando iniciei o notebook de novo não estava carregando o XOrg. Tentei alterar o arquivo de xorg.conf e nao consegui arrumar, entao eu tentei deletar o arquivo e reinstalar o xorg pelo apt-get mas apesar de eu ter reinstalado e ter usado tambem um dpkg-reconfigure xorg o arquivo de configuração xorg.conf nao voltou, nao foi recriado, nao existe.
Fiz uma busca pelos dois arquivos de configuraçoes que falou e nao existe nenhum no meu sistema.
Então como faço?
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/12/2006, 21:35
Resposta: #6
 
o que existe no diretório /etc/X11
poderia listá-lo?
# ls -l /etc/X11
digite tb isso:
# dpkg -l *server* | grep ii
e poste o resultado

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/12/2006, 11:03
Resposta: #7
 
Ai esta o resultado que me pediu:

# ls -l /etc/X11/
total 72
drwxr-xr-x 2 root root 4096 2006-10-25 12:08 app-defaults
drwxr-xr-x 2 root root 4096 2006-10-25 12:11 cursors
-rw-r--r-- 1 root root 13 2006-10-25 12:08 default-display-manager
drwxr-xr-x 5 root root 4096 2006-12-24 16:53 fonts
-rw-r--r-- 1 root root 17371 2006-06-12 00:40 rgb.txt
lrwxrwxrwx 1 root root 13 2006-12-23 19:49 X -> /usr/bin/Xorg
drwxr-xr-x 2 root root 4096 2006-10-25 12:07 xinit
drwxr-xr-x 10 root root 4096 2006-10-25 12:05 xkb
drwxr-xr-x 2 root root 4096 2006-10-20 16:02 Xresources
-rwxr-xr-x 1 root root 4157 2006-10-12 12:33 Xsession
drwxr-xr-x 2 root root 4096 2006-12-24 08:15 Xsession.d
-rw-r--r-- 1 root root 265 2006-06-12 00:40 Xsession.options
-rwxr-xr-x 1 root root 13 2006-09-12 00:44 XvMCConfig
-rw------- 1 root root 614 2006-12-24 20:46 Xwrapper.config


# dpkg -l *server* | grep ii
ii ksmserver 3.5.5-0ubuntu3.2 session manager for KDE
ii xserver-xorg 7.1.1ubuntu6.2 the X.Org X server
ii xserver-xorg-core 1.1.1-0ubuntu12 X.Org X server -- core server
ii xserver-xorg-input-all 7.1.1ubuntu6.2 the X.Org X server -- input driver metapacka
ii xserver-xorg-input-elographics 1.1.0-0ubuntu1 X.Org X server -- ELOGraphics input driver
ii xserver-xorg-input-evdev 1.1.2-1ubuntu2 X.Org X server -- evdev input driver
ii xserver-xorg-input-kbd 1.1.0-0ubuntu1 X.Org X server -- keyboard input driver
ii xserver-xorg-input-mouse 1.1.1-0ubuntu1 X.Org X server -- mouse input driver
ii xserver-xorg-input-synaptics 0.14.6-0ubuntu3 Synaptics TouchPad driver for X.Org server
ii xserver-xorg-input-wacom 0.7.2-0ubuntu7 X.Org X server -- Wacom input driver
ii xserver-xorg-video-all 7.1.1ubuntu6.2 the X.Org X server -- output driver metapack
ii xserver-xorg-video-apm 1.1.1-0ubuntu1 X.Org X server -- APM display driver
ii xserver-xorg-video-ark 0.6.0-0ubuntu1 X.Org X server -- ark display driver
ii xserver-xorg-video-ati 6.6.2-0ubuntu4 X.Org X server -- ATI display driver
ii xserver-xorg-video-chips 1.1.1-0ubuntu1 X.Org X server -- Chips display driver
ii xserver-xorg-video-cirrus 1.1.0-0ubuntu1 X.Org X server -- Cirrus display driver
ii xserver-xorg-video-cyrix 1.1.0-0ubuntu1 X.Org X server -- Cyrix display driver
ii xserver-xorg-video-dummy 0.2.0-0ubuntu1 X.Org X server -- dummy display driver
ii xserver-xorg-video-fbdev 0.3.0-0ubuntu2 X.Org X server -- fbdev display driver
ii xserver-xorg-video-glint 1.1.1-0ubuntu1 X.Org X server -- Glint display driver
ii xserver-xorg-video-i128 1.2.0-0ubuntu1 X.Org X server -- i128 display driver
ii xserver-xorg-video-i740 1.1.0-0ubuntu1 X.Org X server -- i740 display driver
ii xserver-xorg-video-i810 1.6.5-0ubuntu3 X.Org X server -- Intel i8xx, i9xx display d
ii xserver-xorg-video-imstt 1.1.0-0ubuntu1 X.Org X server -- IMSTT display driver
ii xserver-xorg-video-mga 1.4.1-0ubuntu1 X.Org X server -- MGA display driver
ii xserver-xorg-video-neomagic 1.1.1-0ubuntu1 X.Org X server -- Neomagic display driver
ii xserver-xorg-video-newport 0.2.0-0ubuntu1 X.Org X server -- Newport display driver
ii xserver-xorg-video-nsc 2.8.1-0ubuntu1 X.Org X server -- NSC display driver
ii xserver-xorg-video-nv 1.2.0-0ubuntu2 X.Org X server -- NV display driver
ii xserver-xorg-video-rendition 4.1.0-0ubuntu1 X.Org X server -- Rendition display driver
ii xserver-xorg-video-s3 0.4.1-0ubuntu1 X.Org X server -- legacy S3 display driver
ii xserver-xorg-video-s3virge 1.9.1-0ubuntu1 X.Org X server -- S3 ViRGE display driver
ii xserver-xorg-video-savage 2.1.1-0ubuntu3 X.Org X server -- Savage display driver
ii xserver-xorg-video-siliconmotion 1.4.1-0ubuntu1 X.Org X server -- SiliconMotion display driv
ii xserver-xorg-video-sis 0.9.1-0ubuntu2 X.Org X server -- SiS display driver
ii xserver-xorg-video-sisusb 0.8.1-0ubuntu1 X.Org X server -- SiS USB display driver
ii xserver-xorg-video-tdfx 1.2.1-0ubuntu1 X.Org X server -- tdfx display driver
ii xserver-xorg-video-tga 1.1.0-0ubuntu1 X.Org X server -- TGA display driver
ii xserver-xorg-video-trident 1.2.1-0ubuntu2 X.Org X server -- Trident display driver
ii xserver-xorg-video-tseng 1.1.0-0ubuntu1 X.Org X server -- Tseng display driver
ii xserver-xorg-video-v4l 0.1.1-0ubuntu1 X.Org X server -- Video 4 Linux display driv
ii xserver-xorg-video-vesa 1.2.1-0ubuntu1 X.Org X server -- VESA display driver
ii xserver-xorg-video-vga 4.1.0-0ubuntu1 X.Org X server -- VGA display driver
ii xserver-xorg-video-via 0.2.1-0ubuntu4 X.Org X server -- VIA display driver
ii xserver-xorg-video-vmware 10.13.0-0ubuntu2 X.Org X server -- VMware display driver
ii xserver-xorg-video-voodoo 1.1.0-oubuntu1 X.Org X server -- Voodoo display driver


Espero que esteja ok, como eu disse nao existe os arquivos e o que esta instalado é o XOrg.

"As coisas que você possui acabam te possuindo." - Tyler, Fight Club
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/12/2006, 14:29
Resposta: #8
 
ok, vamos tentar descobrir onde está esse arquivo de configuração, digite o seguinte comando:
$ ls /var/log
veja se existe um arquivo de log de nome Xorg e liste o conteúdo dele com:
$ cat /var/log/Xorg.0.log | grep xorg.conf
caso não apareça nada tente com esse:
$ cat /var/log/Xorg.0.log | grep config
deve aparecer uma linha especificando o local onde está o arquivo de configuração utilizado:
(==) Using config file: "/etc/X11/xorg.conf"
No seu caso deve ser diferente.
Outra coisa em algum momento utilizou esse comando:
Xorg -configure

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/12/2006, 22:02
Resposta: #9
 
O resultado que encontrei foi o seguinte:

$ cat /var/log/Xorg.0.log | grep config
Markers: (--) probed, (**) from config file, (==) default setting,
(EE) Unable to locate/open config file
Running "getconfig -X 70101000 -I /etc/X11,/usr/etc/X11,/usr/lib/xorg/modules,/usr/lib/X11/getconfig -v 0x8086 -d 0x27a2 -r 0x03 -s 0x1025 -b 0x0090 -c 0x0300"
(==) Using default built-in configuration (43 lines)
(==) --- Start of built-in configuration ---
(==) --- End of built-in configuration ---
Using the default mouse configuration.
Using the default keyboard configuration.

Me ajude a decifrar pq nao encontrei uma referencia direta ao arquivo de configuração como disse na sua msg, apenas referencias ao diretorio onde deveria estar a arquivo de configuração.
Não, não usei o comando Xorg -configure em momento algum, deveria tenta-lo?

"As coisas que você possui acabam te possuindo." - Tyler, Fight Club
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
31/12/2006, 09:35
Resposta: #10
 
arcanjo_mg Escreveu:Cara, nao existe o arquivo xfree86config-4, pois o XFree86 nunca chegou a ser instalado no meu sistema.

Talvez deixei faltar informação, estou usando o Kubuntu 6.10 no notebook, estava instalando alguns pacotes usando o Automatix2 e ai quando iniciei o notebook de novo não estava carregando o XOrg. Tentei alterar o arquivo de xorg.conf e nao consegui arrumar, entao eu tentei deletar o arquivo e reinstalar o xorg pelo apt-get mas apesar de eu ter reinstalado e ter usado tambem um dpkg-reconfigure xorg o arquivo de configuração xorg.conf nao voltou, nao foi recriado, nao existe.
Fiz uma busca pelos dois arquivos de configuraçoes que falou e nao existe nenhum no meu sistema.
Então como faço?

Ok, não sei como vc está dando sorte da configuração embutida do X estar inicializando o gráfico, está pegando tudo como padrão, vamos tentar corrigir isso, execute os seguinte passos:
Abra um terminal e vamos derrubar o X com:
# init 1
execute depois de inicializado o prompt:
# X -configure
Veja se criou o novo arquivo xorg.conf.new com:
# ls -l /root
Copie renomeando o arquivo que foi criado em /root/xorg.conf.new para o /etc/X11
# cp /root/xorg.conf.new /etc/X11/xorg.conf
Confirme que vc possue as fontes basicas do X instalado:
# aptitude install xfonts-base xfonts-100dpi xfonts-75dpi
# aptitude install xfonts-encodings xfonts-scalable xfonts-utils
# aptitude install xfs
feito isso e tudo ok, execute isso para indexar e disponibilizar as fontes para o X:
# fc-cache -fv
Agora vamos ver se o X inicia corretamente, digite:
# init 2
ou reinicie o pc.
Caso o X no inicialize, digite o comando:
# cat /var/log/Xorg.0.log | grep EE
e poste a saída aqui.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/01/2007, 21:13
Resposta: #11
 
Cara, ao usar o comando: init 1 o X começa a ser desativado mais ai a tela do bootsplash fica garrada, nao sai apesar do X ser fechado.
Passei para o terminal tty1 e segui o restante das instruçoes e ta tudo instalado so que com o arquivo de configuração gerado o X não iniciou, somente voltou a entrar dps que deletei o arquivo de novo.

"As coisas que você possui acabam te possuindo." - Tyler, Fight Club
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/01/2007, 16:22
Resposta: #12
 
dmatrix Escreveu:
arcanjo_mg Escreveu:Caso o X no inicialize, digite o comando:
# cat /var/log/Xorg.0.log | grep EE
e poste a saída aqui.

Bom parece que estas ultimas linha não executou, então fica dificil ajudar a corrigir o seu problema sem o arquivo de configuração do xorg não vejo como corrigir o touchpad.
Poderia postar o conteúdo do xorg criado pelo sistema e tb a saída do comando lspci. Talvez eu possa fazer alguns ajustes neste arquivo de modo que possa funcionar. E adiantando, instale no seu sistema o seguinte pacote de suporte para o touchpad:
# aptitude install xserver-xorg-input-synaptics

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/01/2007, 19:54
Resposta: #13
 
Uma pergunta dmatrix, tenho o Debian Etch no mesmo notebook, o arquivo de configuração dele deve servir no Ubuntu nao deve?

O pacote que sugeriu instalar ja esta presente.

"As coisas que você possui acabam te possuindo." - Tyler, Fight Club
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/01/2007, 19:54
Resposta: #14
 
Uma pergunta dmatrix, tenho o Debian Etch no mesmo notebook, o arquivo de configuração dele deve servir no Ubuntu nao deve?

O pacote que sugeriu instalar ja esta presente.

"As coisas que você possui acabam te possuindo." - Tyler, Fight Club
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/01/2007, 20:33
Resposta: #15
 
RESOLVIDO!
Copiei o arquivo xorg.conf do Debian Etch que tenho no mesmo notebook para o Kubuntu. Funcionou normalmente.
Acrescentei: Option "SHMConfig" "on"
na seção do touchpad do arquivo de configuração e instalei o ksynaptic. Usando o ksynaptic eu desativei a função tapping e pronto! Estou usando o touchpad agora so para apontar.
So que agora eu ja estava acostumado Alegre

Bem, o que importa que foi resolvido, por segurança vou ate salvar uma copia backup desse arquivo no estado atual Alegre
Tenho muitas configurações para fazer neste notebook seria melhor que eu tivesse ajuda de alguem que tem um igual, preciso ativar a webcam, o bluetooth e a saida tv-out ainda, caso tenha alguem que ja fez isso por favor me dê uma forcinha.

Obrigado dmatrix pela ajuda constante.

"As coisas que você possui acabam te possuindo." - Tyler, Fight Club
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS