Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Internet a Rádio no Debian [RESOLVIDO]
20/12/2006, 22:33
Resposta: #16
 
É verdade, num tinha percebido isso, tb achei estranho pois tava pingando no gateway e na primeira linha fez:
PING 192.168.4.254 (192.168.4.254) 56(84) bytes of data
depois ficou do jeito que te falei antes.
Bem uso internet a radio de um loja de informática que a destribui por torre, com um roteador, e meu IP do pc com a loja é 192.168.4.29, e Gateway 192.168.4.254, DNS 201.10.120.2, a loja tem 3 antenas a radio, a minha é 3cinfo, todas são encriptadas, ok...
dei o ping no meu ip com a loja e tá ok, normal, pinguei com o gateway, sem sinal, tb fiz o mesmo com o DNS, tb sem sinal.
Geralmente no XP qdo acontece isso é por que está sem criptografia (validação de senha), mas no debian eu pus a senha certa, então num sei pq num responde, o ip local só de casa até a loja, da loja pra provedor acho que passa pelo servidor da loja (encritografado). Pelo menos eu penso assim.
Espero que tenha entendido.
Até mais
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/12/2006, 07:39
Resposta: #17
 
profpardal Escreveu:# route
Tabela de Roteamento IP Kernel
Destino Roteador Masc.Gen. Opções Métrica Ref UsoIface
192.168.4.0 * 255.255.255.0 U 0 0 0 ra0
default 192.168.4.29 0.0.0.0 UG 0 0 0 ra0

# ifconfig
ra0 Encapsulamento de Link: Ethernet Endereço de HW 00:0E:2E:82:2A:1C
inet end: 192.168.4.29 Bcast: 192.168.4.255 Masc: 255.255.255.0
endereço inet6: Fe80::20e:2eff:fe82:2a1c/64 Escopo: Link
UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
Rx packets:15770 errors:0 droped:0 overruns:0 frame:0
Tx pachets:5842 errors:0 droped:0 overruns:0 carrier:0
colisões:144 txqueuelen:1000
Rx bytes:1152305 (1.0 MiB) Tx bytes:74795 (73.0 KiB)
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Amigo, só ficou uma dúvida nesta configuração que tá route configurado o ip como o mesmo ip de endereço de seu pc, o correto no route seria o 254. Testou o wifi-radar?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/12/2006, 20:11
Resposta: #18
 
Aee Fera!!! Você é MESTRE... Estou tc do debian-br-cdd agora pela primeira vez na net, como consegui num sei direito, acho que foi alguma coisa que fiz que passarei abaixo pra vc.
Ah! sobre o route que te passei acima, realmete foi só digitação errada, pois o certo seria onde tava 4.29 era 4.254, tá vendo como manja muito, pois eu digitei errado e nem tinha percebido.
Óh! só tem alguns ajuste a fazer ainda com certeza, pois toda vez que desligo o pc e depois ligo de novo tenho que configurar tudo de novo com o iwconfig ra0 essid 3cinfo, iwconfig ra0 key restricted xxxxxxxxxx e channel e mode.
Por que está acontecendo insto? será que tenho que fazer mais alguma coisa.
Olha alguma das coisas que fiz foi no /etc/network/ mcedit interfaces foi colocar informações a mais como: dns, wireless_essid, mode, key_restricted.
Ah! também poderá ser porque, até acho que ainda não tinha postado essa informação antes, é que qdo eu dava ifconfig, além de ra0 também aparecia lo, isto é rede local, e lá tinha um ip 127.0.0.1 masc 255.0.0.0 ... maquina, eu dei um ifconfig lo 192.168.4.29, mas pinguei no gateway 192.168.4.254, mas nada respondeu, depois o que fiz voltei ao que era antes, fazendo ifconfig lo 127.0.0.1, logo depois dei o ping de novo 192.168.4.254, e inacreditável deu ok.
agora não sei de dizer qual foi o passo certo.
outra coisa aque wifi-radar não deu certo, depois eu te passo os erros que apresentaram, ok?
Por enquanto o que me resta e agradeço muito por sua atenção e presteza, MUITO OBRIGADO!!!
Mais ainda preciso da sua bondade e paciência um pouco pra resolver este último probleminha tá...
At+ fera.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/12/2006, 23:03
Resposta: #19
 
Mestre!!! É o seguinte, depois que desligo o pc acontece aquilo tudo que falei e tive que configurar tudo de novo, só que acho que depois da segunda vez que configurei a net, e dei os seguintes passos:
# lsmod
a placa tava lá, mas dei um:
# ifconfig
e nada aparecia e,
# iwconfig
network no device
# iwconfig ra0
ra0 no wireless extensions
então tive que fazer um:
# ifconfig ra0 up
daí apareceu lo, ra0, etc.. tudo sem nenhum IP, e a ra0 não tinha nem wh address 00:00:00:00:... então fiz todas aquelas configurações:
# iwconfig ra0 AP 00:02:6F.......
# iwconfig ra0 essid 3cinfo
# iwconfig ra0 mode managed
# iwconfig ra0 channel 1
# iwconfig ra0 key restricted 2305........
# ping 192.168.4.254 num pingava
# route e tb não parecia nada
# wifi-radar e dava todos aqueles erros, então deletei e sai dele
# ping 192.168.4.254 num pingava
# route aparecia só # 192.168.4.0 * 255.255.255.0 U 0 0 0
o que eu fiz foi dar
# ifconfig ra0 inet 192.168.4.29 up e ja pingou no 192.168.4.254, mas no site www.uol.com.br nada
# route tava do msm jeito só aparecia um # 192.168.4.0 * ......
aí fui de novo no
# wifi-radar deu os mesmos erros então deletei, mas a hora que sai e dei:
# route apareceu normal as duas linhas esperadas
# 192.168.4.0 * 255.255......
# default 192.168.4.254 0.0.0.... que escrito errado na outra mensagem
# ping www.uol.com.br e deu belezinha
entrei no mozilla e naveguei blz
Só um problema é que toda vez que desligo PC tenho que fazer todo esse processo novamente, deve ter alguma coisa ainda errada. Tá duro de descobrir, mas sou persistente e vou descobrir.
Ah!!! tô digitando do debian depois terceira conexão, do terceiro boot e terceira configuração.
Amigo ainda preciso de vc pra resolves esses karmas.
Até a próxima, se Deus quiser que seja a ultima deste tópico.
Vlw
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/12/2006, 10:46
Resposta: #20
 
Seguinte vc não deve mexer na parte da configuração do interfaces referente ao lo, deve permanecer desta forma o inicio:
# The loopback network interface
auto lo
iface lo inet loopback

daqui pra baixo é que vc configura sua placa de wireless:

auto ra0
iface ra0 inet static
address 192.168.4.29
netmask 255.255.255.0
gateway 192.168.4.254
wireless_mode managed
wireless_nick seu_nick
wireless_keymode restricted
wireless_key SUA_CHAVE ## ---> em formato HEX, talvez formato ASCII funcione entre " "
wireless_rate auto
wireless_enc on ## ---> se tiver criptografia senão remova ou ponha off
wireless_essid 3cinfo
wireless_channel 1

outra coisa ao efetuar mudança no arquivo restart o serviço de rede com:
# /etc/init.d/networking restart

pode ser que ao restartar o dns pare de funcionar e aí não vai navegar, vai pingar para o gateway mas pode não navegar. O correto é configurar tudo no boot. O que vc poderia estar fazendo é colocar esses comandos todos no final do arquivo /etc/init.d/bootmisc.sh

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/12/2006, 15:25
Resposta: #21
 
Éh! Amigo não entnedi direito o comando:
# /etc/init.d/network restart
pois não tem nenhum diretório com o nome de network nesta pasta nem arquivo, nem comando restart, apenas encontrei um arquivo com o nome de networking, abri ele e lá tem albumas linhas falando sobre network, start, restart, etc.........
então fiz a outras configurações no interfaces e reinicie o PC, e logo vi que pelo menos a placa estava ativa e e pingava o gateway mas num navegava, pois num pingava nenhum endereço net. então vi que só faltava configurar com iwconfig ra0 AP 00:00:00 .... iwconfig ra0 essid 3cinfo etc etc. E depois disso dei # route e não dava as duas linha somente uma, então sabia que teria que ainda teria que pelo ao menos abrir o wifi-radar que ainda tinha a rede lá configurada, embora não conecta pq dá um monte de erros, mesmo pedi pra conectar e depois o programa e já tava tudo normal de novo.
Será que não vai dar certo?
Porque o wifi-radar não configura direito e dá aqueles monte de erros?
Vou pesquisar um pouco sobre ess wifi-radar, Blz?
At+

LINUX, it's the future... and the future it's on our hands!!!
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/12/2006, 16:21
Resposta: #22
 
profpardal Escreveu:Éh! Amigo não entnedi direito o comando:
# /etc/init.d/network restart
pois não tem nenhum diretório com o nome de network nesta pasta nem arquivo, nem comando restart, apenas encontrei um arquivo com o nome de networking, abri ele e lá tem albumas linhas falando sobre network, start, restart, etc.........
então fiz a outras configurações no interfaces e reinicie o PC, e logo vi que pelo menos a placa estava ativa e e pingava o gateway mas num navegava, pois num pingava nenhum endereço net. então vi que só faltava configurar com iwconfig ra0 AP 00:00:00 .... iwconfig ra0 essid 3cinfo etc etc. E depois disso dei # route e não dava as duas linha somente uma, então sabia que teria que ainda teria que pelo ao menos abrir o wifi-radar que ainda tinha a rede lá configurada, embora não conecta pq dá um monte de erros, mesmo pedi pra conectar e depois o programa e já tava tudo normal de novo.
Será que não vai dar certo?
Porque o wifi-radar não configura direito e dá aqueles monte de erros?
Vou pesquisar um pouco sobre ess wifi-radar, Blz?
At+


ok, errei faltou o resto do comando, já corrigi o tópico, é que a gente se acostuma tando com o tab ... bom não sei o que seria esse comando AP 00:00:00... que vc está dizendo que está faltando no interfaces, acho que tem todos esses aí, a não ser endereço MAC mas acho que isso vc não troca certo?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/12/2006, 17:42
Resposta: #23
 
É verdade não posso mudar o MAC, mas ele tá aparecendo certinho qdo dou um ifconfig.
Agora consegui dar o comando networking restart:
# /etc/init.d/networking restart
Setting up IP spoofing protection: rp_filter.
Reconfiguring network interfaces...ifup: interface lo already configured
Error for wireless request "Set Mode" (8B06) :
SET failed on device ra0 ; Network is down.
Error for wireless request "Set Encode" (8B2B) :
GET failed on device ra0 ; Network is down.
Error for wireless request "Set Encode" (8B2A) :
SET failed on device ra0 ; Network is down.
Error for wireless request "Set Encode" (8B2A) :
SET failed on device ra0 ; Network is down.
Error for wireless request "Set Frequency" (8B04) :
SET failed on device ra0 ; Network is down.
Error for wireless request "Set ESSID" (8B1A) :
SET failed on device ra0 ; Network is down.
done.

Vixi agora danou tudo hein!!!!!!!!
Depois que eu dei esse comando eu estava na net e parou de navegar e tive que fazer aquelas configurações de novo pra acabar de passar a mensagem.
Ah! AP 00:02:6F:43:87:5A e' o Acess Point da rede de radio da loja, qdo dou um iwlist ra0 scan ele aparece lá, OK?
At+

LINUX, it's the future... and the future it's on our hands!!!
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/12/2006, 20:30
Resposta: #24
 
Citar:Error for wireless request "Set Mode" (8B06) :
SET failed on device ra0 ; Network is down.
Error for wireless request "Set Encode" (8B2B) :
GET failed on device ra0 ; Network is down.
Error for wireless request "Set Encode" (8B2A) :
SET failed on device ra0 ; Network is down.
Error for wireless request "Set Encode" (8B2A) :
SET failed on device ra0 ; Network is down.
Error for wireless request "Set Frequency" (8B04) :
SET failed on device ra0 ; Network is down.
Error for wireless request "Set ESSID" (8B1A) :
SET failed on device ra0 ; Network is down.

ok os erros são provenientes das linhas no interfaces de wireless_mode, wireless_key wireless_essid e wireless_channel. Façamos o seguinte, como minha rede aqui não utiliza essas opções (rede aberta) vamos mudar algumas coisas e deixar o essencial:


auto ra0
iface ra0 inet static
address 192.168.4.29
netmask 255.255.255.0
gateway 192.168.4.254
wireless_keymode restricted
wireless-key 945136leac ## ---> sem as aspas
wireless-essid 3cinfo


veja se desta forma a rede já funciona de pronto ao reiniciar o PC, observe que em algumas opções foi trocado o caracter underscore pelo hifen.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/12/2006, 07:02
Resposta: #25
 
Olá amigo, olha eu aqui de novo, fiz o que me disse e mesmoassim deram alguns erros.

XBlade:/home/adilson# /etc/init.d/networking restart
Setting up IP spoofing protection: rp_filter.
Reconfiguring network interfaces...ifup: interface lo already configured
Error for wireless request "Set Encode" (8B2A) :
SET failed on device ra0 ; Network is down.
Error for wireless request "Set Encode" (8B2A) :
SET failed on device ra0 ; Network is down.
Error for wireless request "Set ESSID" (8B1A) :
SET failed on device ra0 ; Network is down.
done.

Depois disso aconteceu como anteriormente, fiquei sem navegar, e pra mandar esta mensagem tive que configurar de novo somente com este comando iwconfig key restricted 1234567890 e já funcionou de novo, num precisa de essid, channel e mode, como eu estava fazendo antes.

<<<<< Obs >>>>>
Ah! também outra coisa, alguma coisa pode ter desconfigurado o som, pois eu consigo ouvir só músicas mp3 e cd, mas o som na internet num funciona, já fiz tudo aquele procedimento alsaconf e alsamixer, qdo vou aplicar alsaconf logo ele desativa o controle de volume do painel dizendo que posso add ele depois, mas dai faço as configurações normais e salvo alsactl store, mas qdo vou adicionar o controle de volume no painel, ele não levanta a barra de volume, dou um click com o botão direito em cima dele e em preferências pra selecionar o volume, mas lá esta em branco, sem nenhum canal. Falta instalar alguma coisa?
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/12/2006, 11:01
Resposta: #26
 
Aeee! Mestre. Tá resolvido. Liguei o PC e dei um route e vi que estava tudo certo, dei um iwconfig e vi que tava tudo configurado até a key 123xxxx tava ok, então entrei na net belezinha, olha vou mostrar como está a minha configuração de interfaces:
# mcedit /etc/network/interfaces
auto ra0
iface ra0 inet static
name Placa Wireless LAN
address 192.168.4.29
netmask 255.255.255.0
gateway 192.168.4.254
access_point 00:02:6F:43:87:5A
essid 3cinfo
Key 1234567890
channel 1

Agora amigo só ficou aquele probleminha do som, acho que é bom eu adicionar outro tópico no forum para este problema né?
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/12/2006, 12:39
Resposta: #27
 
profpardal Escreveu:# mcedit /etc/network/interfaces
auto ra0
iface ra0 inet static
name Placa Wireless LAN
address 192.168.4.29
netmask 255.255.255.0
gateway 192.168.4.254
access_point 00:02:6F:43:87:5A
essid 3cinfo
Key 1234567890
channel 1

Interessante, as opções são inseridas em formato diferente, será a versão do interfaces que é diferente? Estranho até o essid é informado diferente. Vou testar aqui essa forma de configurar.

Citar:Agora amigo só ficou aquele probleminha do som, acho que é bom eu adicionar outro tópico no forum para este problema né?

Para organização do forum seria melhor. Só explica melhor o que ocorre com o som logo após inicializar o sistema, pois pelo que deu entender é que está desconfigurando somente ao executar o alsaconf, e som no browser se for flash é outra coisa a configurar, lembro que o cdd-br utiliza o sistema de som Oss e não Alsa.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/12/2006, 13:39
Resposta: #28
 
Olá amigo dmatrix, olha eu aqui de novo, tenho novidades... Bem é o seguinte: estava navegando normalmente na net e aprendendo a usar o linux debianbr-cdd (sou iniciante) e atualizei alguns pacotes com o apt-get up date (sources.lit), então fiz algo errado pois n~ao sabia, é que baixei atualização de pacotes debian unstable, durante a instalação perguntou se queria trocar o debian-br-cdd pelo instable, dei yes, daí em diante não consegui carregar mais o gnome, e resumindo tive que formatar e intalar de novo o debian-br-cdd, e fiz todo aquele processo de intalação da placa rt 61 de novo, deu ok, instalada, configurada a placa pelo iwfconfig ra0, tudo ok, pingou normal, mas, na hora de configurar /etc/network/interfaces fiz tudo como postei acima e tinha dado certo da outra vez, mas incrivel, num deu certo, continuou dando os mesmos erros na hora do /etc/init.d/networkink # Error for wireless request "Set ESSID" (8B1A), depois disso caia a conexão, tinha que desligar o PC tinha que configurar tudo de novo.

LINUX, it's the future... and the future it's on our hands!!!
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/12/2006, 14:59
Resposta: #29
 
Então contiuando com o que postei acima, eo seguinte eu pesquisando em cites da net que fala sobre o kurumin, li um a parte que falava de configuração de wireless, e tapesar do kurumin ter kde dpo padrão e não o gnome, usei algumas informções e fiz um teste, num se é certo ou não e, se interfere em alguma outra coisa no funcionamento do ldebian, mas incrível que pareça DEU CERTO até agora. Fiz o seguinte:
Criei um arquivo com nome qualquer (escolhi wlan) na pasta /usr/Wireless/
Dentro desse arquivo coloquei os dados pra configuração da rede:
#!/bin/sh
iwconfig ra0 essid 3cinfo
iwconfig ra0 mode managed
iwconfig ra0 channel 1
iwconfig ra0 key restricted 1234567890

Dei permissão ao arquivo:
XBlade:/home/adilson# chmod +x wlan

Movi ele para o outro diretório:
XBlade:/home/adilson# mv wlan /etc/Wireless/

Fui para interfaces e:
XBlade:/home/adilson# mcedit /etc/network/interfaces

E deixei assim:
auto ra0
iface ra0 inet static
name Placa Wireless LAN
address 192.168.4.29
netmask 255.255.255.0
broadcast 192.168.4.255
network 192.168.4.0
gateway 192.168.4.254
post-up /etc/Wireless/wlan

Desliguei a máquina e reiniciei e incrível, funcionaou normalmente.

Tive lendo em outras paginas da net e vi tb tópicos sobre sripts de configuração. Acho também que existe outro modo de configurar com algum arquivo que faz configuração da iface durante o boot, mas no kurumin as pastas/arquivas de la'tem nomes diferentes, então desse jeito num deu certo pq naum sei no debian onde esses aquivos estão, eu acho que se fosse com eles daria mais certo.

O que vc acha disso tudo.
At+

LINUX, it's the future... and the future it's on our hands!!!
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/12/2006, 15:51
Resposta: #30
 
bom eu prefiro concentrar as configurações num arquivo padronizado tipo o interfaces e não distribuir configurações pelo sistema, porque quando vc for fazer um backup para migrar para um novo sistema é mais fácil de localizar. Sei que existe muitas maneiras de fazer rodar um script para na inicialização do sistema ser lido e preparado as configurações, mas na minha opnião é melhor limitarmos e concentrar as configurações de rede se possível num unico diretório. Só pra vc ter uma idéia existem meios de configurar o interfaces de modo que possamos ter 2 ou mais provedores e ser feita a configuração e seleção automática de AP conforme disponibilidade do sinal. Mas vc deve procurar fazer o modo mais fácil. Os diretório do kurumin não são tão diferentes do debian pois ele deriva do debian, o que pode estar diferente talvez seria a customização feita pelo Morimoto.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS