Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Autenticação no Samba
11/12/2006, 09:57
Resposta: #1
Autenticação no Samba
Tenho uma máquina Suse 9.2 pra autenticar num domonio Samba, ou seja, eu apenas crio os usuários no samba e uso pra autenticar em todos as maquinas linux clientes da rede, mas estou com o seguinte problema de autenticação e no log do servidor acusa o erro:

[2006/12/11 10:55:40, 3] smbd/oplock.c:init_oplocks(711)
open_oplock_ipc: opening loopback UDP socket.
[2006/12/11 10:55:40, 3] smbd/process.c:process_smb(1194)
Transaction 0 of length 72
[2006/12/11 10:55:40, 2] smbd/reply.c:reply_special(490)
netbios connect: name1=172.16.7.101 name2=EBR747203HOLTPS
[2006/12/11 10:55:40, 2] smbd/reply.c:reply_special(497)
netbios connect: local=172.16.7.101 remote=ebr747203holtps, name type = 20

Alguem pode me dar uma ajuda pra saber qual pode ser o problema?

Weder
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/12/2006, 19:34
Resposta: #2
 
Essas mensagem desta log não está deixando muito claro sobre o problema, mas me diga uma coisa os clientes logam ou não? ou loga só que não acessa os compartilhamentos e recursos?
Bom eu suspeito que o servidor samba não esteja sincronizado (horario) com os clientes ou melhor ao contrário. Por acaso tem configurado a opção oplocks no samba ?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/12/2006, 11:00
Resposta: #3
 
Bom os clientes não chegão a conseguir logar no servidor, o problema só ocorre em clientes suse, pois debian, solaris e windows está tudo normal. O mais estranho é que fiz um cliente suse logar e os outros não consigo fazer com a mesma configuração.
Não sei o que seria essa configuração de oplocks, será que pode ser isso causa do problema?
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/12/2006, 18:40
Resposta: #4
 
Oplocks é uma opção do Samba (smb.conf) ele ajuda a melhorar a performance da
rede, mas como disse que não loga então não é isso não. Já verificou as conexões e cabos destes pontos que não logam? Seria bom tirar essa dúvida colocando uma maquina que está logando perfeitamente no local desta outra que não funfa, vai que é o ponto ou porta do hub/switch.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/12/2006, 09:39
Resposta: #5
 
Amigo creio que não seja isso, pois isso é uma máquina virtual que se encontra num servidor vmware, com o comando smbtree ele consegue listar todas as máquinas samba da rede, mas não loga no servidor e com o comando: smbclient -L //172.16.7.101//wprado -U wprado eu consigo listar servidor ever outras máquinas que estão no samba, o que acha que pode ser?

Weder
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/12/2006, 19:47
Resposta: #6
 
Bom, desculpe a demora....desconfio de alguma configuração no arquivo /etc/samba/smb.conf ( não me lembro se no suse é a mesma localização), vc poderia estar instalando, nesta estação que apresenta esse problema, o swat, uma interface web para configuração do samba, através do browse acessando com o endereço 'localhost:901' e tentar configurar o samba, ou então copie esse arquivo smb.conf da estação suse que está autenticando beleza e substitua o desta maquina ( não se esqueça de fazer uma copia antes e alterar o item netbios name para o nome da estação) e reinicie a mesma. Outra coisa que poderia estar verificando é a versão instalada do samba e do winbind, visto que os repositório do debian são diferentes dos da suse. Poderá também estar comparando os arquivos em /etc/pam.d/kdm , /etc/pam.d/login e /etc/nsswitch.conf

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/12/2006, 09:41
Resposta: #7
 
Não sei porque mas a máquina que estava funcionando com o autenticação no samba não está mais, acredito que não seja nada relacionando ao arquivo de configuração do samba e sim uma configuração pam do Suse, percebi que que ficam sendo algumas coisas gravadas no log do servirdor samba, como segue abaixo:

[2006/12/21 10:04:20, 3] printing/pcap.c:pcap_cache_reload(223)
reload status: ok
[2006/12/21 10:05:20, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:06:20, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:07:20, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:08:20, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:09:20, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:10:20, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:11:20, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:12:20, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:13:20, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:14:20, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:15:20, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:16:20, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:17:19, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:17:19, 3] smbd/process.c:check_reload(1428)
Printcap cache time expired.
[2006/12/21 10:17:19, 3] smbd/process.c:check_reload(1428)
Printcap cache time expired.
[2006/12/21 10:17:19, 3] printing/pcap.c:pcap_cache_reload(117)
reloading printcap cache
[2006/12/21 10:17:19, 3] printing/pcap.c:pcap_cache_reload(223)
reload status: ok
[2006/12/21 10:18:19, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:19:19, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:20:19, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:21:19, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:21:21, 3] smbd/process.c:process_smb(1194)
Transaction 84 of length 182
[2006/12/21 10:21:21, 3] smbd/process.c:switch_message(993)
switch message SMBtrans (pid 15694) conn 0x83e97c0
[2006/12/21 10:21:21, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (65534, 65534) - sec_ctx_stack_ndx = 0
[2006/12/21 10:21:21, 3] smbd/ipc.c:reply_trans(539)
trans <\PIPE\> data=96 params=0 setup=2
[2006/12/21 10:21:21, 3] smbd/ipc.c:named_pipe(334)
named pipe command on <> name
[2006/12/21 10:21:21, 3] smbd/ipc.c:api_fd_reply(294)
Got API command 0x26 on pipe "lsarpc" (pnum 767f)
[2006/12/21 10:21:21, 3] rpc_server/srv_pipe_hnd.c:free_pipe_context(526)
free_pipe_context: destroying talloc pool of size 0
[2006/12/21 10:21:21, 3] rpc_server/srv_pipe.c:api_rpcTNP(2214)
api_rpcTNP: rpc command: LSA_ENUMTRUSTDOM
[2006/12/21 10:21:21, 5] passdb/secrets.c:secrets_get_trusted_domains(707)
[2006/12/21 10:21:21, 5] passdb/secrets.c:secrets_get_trusted_domains(788)
secrets_get_trusted_domains: got 0 domains
[2006/12/21 10:21:21, 3] rpc_server/srv_pipe_hnd.c:free_pipe_context(526)
free_pipe_context: destroying talloc pool of size 464
[2006/12/21 10:22:21, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:23:21, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:24:21, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:25:21, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:26:21, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:27:21, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:28:21, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:29:21, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:30:21, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/12/21 10:30:21, 3] smbd/process.c:check_reload(1428)
Printcap cache time expired.
[2006/12/21 10:30:21, 3] printing/pcap.c:pcap_cache_reload(117)
reloading printcap cache
[2006/12/21 10:30:21, 3] printing/pcap.c:pcap_cache_reload(223)
reload status: ok
[2006/12/21 10:31:21, 3] smbd/sec_ctx.c:set_sec_ctx(288)
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0

Acho que esses logs não fala muita coisa, o que devo fazer?

Weder
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/12/2006, 19:35
Resposta: #8
 
se vc disse que essa maquina enxerga as outras e navega na rede então que tal tentar ingressar ela no dominio novamente com o comando:
# net rpc join member -U root
ou
# net rpc join -S nome_servidor -w nome_dominio -U root

A senha que pedir é a do root do servidor PDC, cadastrada no Samba.

E os arquivos /etc/pam.d/kdm , /etc/pam.d/login e /etc/nsswitch.conf tá muito diferente das estações debian? Poderia verificar se o libpam-smb está instalado nestas estações suse?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/12/2006, 11:23
Resposta: #9
 
Bom é o seguinte, eu fiz um tar de todos os arquivos referente ao samba e pam que estavam instalados na máquina suse que a configuração funcionou e desempacotei na máquina suse que não está autentiacando e isso não deu certo.
Referente a esse comando:
# net rpc join -S nome_servidor -w nome_dominio -U root

Depois que eu digito a senha vem a mensagem que a senha está incorreta sendo que ela está correta, mas esse comando não funciona nem nas maquinas debian, pra que ele serve?
Com o comando smbclient //servidor/share -w dominio -U usuário eu consigo auntenticar normalmente no servidor.
Os arquivos de configuração da máquina suse estão bem diferentes da estação debian, mas se funciona em uma máquina teoricamente deveria funcionar nas outras tambem.Quanto a esse pacote libpam-smb eu não tenho instalado nas máquinas debian e para o suse não existe.
Obs: Usei esse tutorial para a configuração no suse:http://www.guiadohardware.net/artigos/342/
Depois dessas informações será que conseguimos chegar a algo mais concreto?
Mas vou continuar tentando por aqui

Weder
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/12/2006, 20:57
Resposta: #10
 
ok, só vamos verificar umas coisas, no smb.conf da estação tá mais ou menos assim:
[global]
workgroup = NOMEDODOMINIO
server string = %h server (Samba %v)
interfaces = eth0
security = DOMAIN
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
dns proxy = No
wins server = NOMEDOSERVERWINS
panic action = /usr/share/samba/panic-action %d
idmap uid = 10000-20000
idmap gid = 10000-20000
winbind use default domain = Yes
create mask = 0777
directory mask = 0777



E no /etc/nsswitch.conf tá tb assim:

passwd: compat winbind
group: compat winbind
shadow: compat

hosts: files dns
networks: files

protocols: db files
services: db files
ethers: db files
rpc: db files

netgroup: nis

Num sei se quando deu o comando net join se utilizou a conta administrator portando teste o comando desta forma:

# net rpc join -S nome_servidor -w nome_dominio -U administrator
# net rpc join -U administrator

Veja aí se a conta é administrator ou administrador em alguns caso é administrador.
Vamos testar agora a conexao com servidor q talvez retorne alguma mensagem explicativa:
# net rpc testjoin

Esse comando deve listar os usuário do domínio com o winbind rodando:
# wbinfo -u

Esse agora mostra informações sobre o domínio:
# net rpc info

Veja na estação em /var/log as logs do samba e do auth.log que pode estar registrando mais informações sobre tentativa de logon ou ingresso no dominio.
Sobre o /etc/pam.d/login vamos deixar pra verificar depois é mais complexo a alteração neste arquivo.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS