Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Problema no recebimento de e-mails (postfix) - RESOLVIDO
18/10/2006, 10:50
Resposta: #1
Problema no recebimento de e-mails (postfix) - RESOLVIDO
Caros amigos, Bom Dia.
Estou usando Debian 3.1, com os seguintes serviços instalados e rodando perfeitamente:
- Apache2
- FTP
- php4
- phpMyAdmin
- Mysql
- Bind9
Agora estou fazendo a parte de e-mail, estou usando o Postfix (qpopper, inetd, nmap e UebiMuai)

A parte de Envio de emails está OK, ele tá enviando corretamente, a mensagem chega completa, e o anexo tb, está td perfeito!!!

O PROBLEMA É: no recebimento dos emails. Ou seja, ele até está recebendo, mas a mensagem chega VAZIA, o remetente VAZIO, o anexo VAZIO. Fiz um teste: "Mandei 3 e-mails (de domínios diferentes) e chega os 3!!!, SÓ Q CHEGA SEM NENUM CONTEÚDO!!!

Estranho néh?!

Onde será meu proplema?
- nos arquivos de zonas?
- no protocolo POP?
- ou onde mais???

Quem puder me ajudar fico grato, e para facilitar um pouco o entendimento, acesse: www.paulista-ie.com.br/webmail (LOGIN: teste, SENHA: 123).

*PS: Estou usando o protocolo POP para recebimento.

Desde já agradeço,
Att.
Nilton Fortunato
[email protected][/b]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/10/2006, 11:12
Resposta: #2
 
Nilton,

Recomendo que você dê uma olhada (ou poste aqui) nos arquivos /var/log/mail.info e /var/log/mail.err eles geralmente mostram informações preciosas. Se esse erro for por causa do postfix, irá aparecer neles.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/10/2006, 11:46
Resposta: #3
 
Então Fernando, o mail.err (não contém erro, tá beleza!), eu já havia visto o mail.info e ele tá lotado de erro, acho até complicado de postar aqui pelo tamanho.

Eu deixei o MAIL.LOG, deixei tb meus arquivos de zonas pra download, acho q é mais fácil, é só acessar: http://ftp.paulista-ie.com.br

Grato,
Nilton
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/10/2006, 12:15
Resposta: #4
 
esquecí de mudar a permissão Outros (rs...)

Mas agora já tá OK.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/10/2006, 13:36
Resposta: #5
 
Será q algué tem noção do que possa estar acontecendo?!

Grato,
Nilton
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/10/2006, 16:02
Resposta: #6
 
Nilton Escreveu:Será q algué tem noção do que possa estar acontecendo?!

Grato,
Nilton

Olá nilton, tudo bem?

Aproveitando a sua experência com servidor de correio. Gostaria se possível, que você me pasassem exatamente o que eu preciso ter "em mãos", pra montar um servidor de correio com as mesmas caracteristica do seu, ok?

Obrigado pela sua atenção e aguardo retorno.

Na vida, o que vale é a viagem... e não o destino.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/10/2006, 17:37
Resposta: #7
 
Olá "aprendiz_ce", blz???!!
Então cara, é preciso primeiramente vc ter uma máq já com o bind configurada, ou seja, tipo: www.aprendiz.com.br
Se isso já estiver beleza fica meio caminho andado´e basta instalar os seguintes serviços:
- postfix
- qpopper
- inetd
- nmap
- uebimiau (se vc quiser, é um webmail)
é so isso e já nheras...rs.. pelo menos´eu uso assim, claro q tem N formas de conf o serv de e-mails.
Um abraço, e qq coisa estamos aí!!!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/10/2006, 09:06
Resposta: #8
 
Nilton,

Já conseguiu resolver os problemas no seu servidor de e-mail?


Nilton Escreveu:Eu deixei o MAIL.LOG, deixei tb meus arquivos de zonas pra download, acho q é mais fácil, é só acessar: http://ftp.paulista-ie.com.br

Não consegui acessar o mail.log
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/10/2006, 11:31
Resposta: #9
 
Nilton Escreveu:Olá "aprendiz_ce", blz???!!
Então cara, é preciso primeiramente vc ter uma máq já com o bind configurada, ou seja, tipo: www.aprendiz.com.br
Se isso já estiver beleza fica meio caminho andado´e basta instalar os seguintes serviços:
- postfix
- qpopper
- inetd
- nmap
- uebimiau (se vc quiser, é um webmail)
é so isso e já nheras...rs.. pelo menos´eu uso assim, claro q tem N formas de conf o serv de e-mails.
Um abraço, e qq coisa estamos aí!!!

Olá Nilton,

Obrigado pela sua pronto atenção. Mas me tira mais uma dúvida: Eu necessariamente tenho que ter um link de interner com ip fixo?

Obrigado mais uma vez e aguardo retorno.

Ps. esse UEBIMIAU é legal, funciona bem?

Na vida, o que vale é a viagem... e não o destino.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/10/2006, 16:43
Resposta: #10
 
Olá Fernando.
Cara, ainda não conseguí resolver meu problema!!! Inclusive postei em outros fóruns e até agora nada.
Coloquei meus arquivos de zona e log em outro lugar: www.paulista-ie.com.br/nilton
Vê se consegue me dá uma "luz", pq tô sem e-mail...

Desde já agradeço.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/10/2006, 16:46
Resposta: #11
 
Aprendiz.
Cara primeiro vc tem de ter um link de internet com IP FIXO sim!!! é esse ip fixo q vc informará ao programa de DNS (bind9) e fará a associação com seudominio.com.br (ou qualquer outro).
Qto ao UebiMuau, é bem rápido, simples de configurar e bem funcional!!!
Cara qq coisa me add no msn q a gente se fala melhor.
Att, Nilton
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/10/2006, 10:14
Resposta: #12
 
Nilton,

No log que você postou ele aparece enviando um e-mail, certo? E o seu problema é na hora de receber o e-mail?

Se possível, poste um log mais extenso, por favor.

Gosto de usar essa configuração em servidor de e-mail http://debian-ce.org/articles.php?id=17
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/10/2006, 10:13
Resposta: #13
 
Fernando, é isso mesmo!!! Meu problema é no recebimento e esses logs q eu indiquei é no envio ("viajei na maionese")!rs...).
É até um pouco estranho, mas tá dando tanto erro q eu vou postar aqui os erros das duas últimas horas no serviço:

Oct 18 10:07:30 servidor in.qpopper[2870]: (v4.0.5) POP login by user "nilton" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 10:09:40 servidor in.qpopper[2883]: (v4.0.5) POP login by user "nilton" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 10:10:20 servidor postfix/smtpd[2884]: warning: smtpd_peer_init: 201.0.174.77: address not listed for hostname servidor.paulista-ie.com.br
Oct 18 10:10:20 servidor postfix/smtpd[2884]: connect from unknown[201.0.174.77]
Oct 18 10:10:20 servidor postfix/smtpd[2884]: EA3FE16802A: client=unknown[201.0.174.77]
Oct 18 10:10:21 servidor postfix/cleanup[2887]: EA3FE16802A: message-id=<[email protected]>
Oct 18 10:10:21 servidor postfix/qmgr[1451]: EA3FE16802A: from=<[email protected]>, size=1803403, nrcpt=1 (queue active)
Oct 18 10:10:21 servidor postfix/smtpd[2884]: disconnect from unknown[201.0.174.77]
Oct 18 10:10:21 servidor in.qpopper[2889]: (v4.0.5) POP login by user "nilton" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 10:10:22 servidor postfix/smtp[2888]: EA3FE16802A: host mx1.mail.yahoo.com[4.79.181.168] refused to talk to me: 451 Message temporarily deferred - 4.16.50
Oct 18 10:12:46 servidor postfix/smtp[2888]: EA3FE16802A: to=<[email protected]>, relay=mx3.mail.yahoo.com[67.28.113.74], delay=146, status=sent (250 ok dirdel)
Oct 18 10:12:46 servidor postfix/qmgr[1451]: EA3FE16802A: removed
Oct 18 10:19:57 servidor in.qpopper[2907]: (v4.0.5) POP login by user "nilton" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 10:20:11 servidor in.qpopper[2909]: (v4.0.5) POP login by user "nilton" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 10:28:50 servidor in.qpopper[2938]: (v4.0.5) POP login by user "paulista" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 10:29:11 servidor postfix/smtpd[2940]: warning: smtpd_peer_init: 201.0.174.77: address not listed for hostname servidor.paulista-ie.com.br
Oct 18 10:29:11 servidor postfix/smtpd[2940]: connect from unknown[201.0.174.77]
Oct 18 10:29:11 servidor postfix/smtpd[2940]: 055A016802A: client=unknown[201.0.174.77]
Oct 18 10:29:11 servidor postfix/cleanup[2943]: 055A016802A: message-id=<[email protected]>
Oct 18 10:29:11 servidor postfix/qmgr[1451]: 055A016802A: from=<[email protected]>, size=947, nrcpt=1 (queue active)
Oct 18 10:29:11 servidor postfix/smtpd[2940]: disconnect from unknown[201.0.174.77]
Oct 18 10:29:11 servidor in.qpopper[2948]: (v4.0.5) POP login by user "paulista" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 10:29:16 servidor postfix/local[2944]: 055A016802A: to=<[email protected]>, relay=local, delay=5, status=sent (delivered to command: /usr/bin/procmail -f- -a "$USER" debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin xxgdb $daemon_directory/$process_name $process_id & sleep 5)
Oct 18 10:29:16 servidor postfix/qmgr[1451]: 055A016802A: removed
Oct 18 10:29:24 servidor in.qpopper[2953]: (v4.0.5) POP login by user "nilton" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 10:32:50 servidor in.qpopper[2990]: (v4.0.5) POP login by user "nilton" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 10:45:57 servidor in.qpopper[3000]: (v4.0.5) POP login by user "nilton" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 10:46:40 servidor postfix/smtpd[3001]: warning: smtpd_peer_init: 201.0.174.77: address not listed for hostname servidor.paulista-ie.com.br
Oct 18 10:46:40 servidor postfix/smtpd[3001]: connect from unknown[201.0.174.77]
Oct 18 10:46:40 servidor postfix/smtpd[3001]: 557E216802A: client=unknown[201.0.174.77]
Oct 18 10:46:40 servidor postfix/cleanup[3004]: 557E216802A: message-id=<[email protected]>
Oct 18 10:46:40 servidor postfix/qmgr[1451]: 557E216802A: from=<[email protected]>, size=94552, nrcpt=1 (queue active)
Oct 18 10:46:40 servidor postfix/smtpd[3001]: disconnect from unknown[201.0.174.77]
Oct 18 10:46:40 servidor in.qpopper[3006]: (v4.0.5) POP login by user "nilton" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 10:47:14 servidor postfix/smtp[3005]: 557E216802A: to=<[email protected]>, relay=mx1.hotmail.com[65.54.244.136], delay=34, status=sent (250 <[email protected]> Queued mail for delivery)
Oct 18 10:47:14 servidor postfix/qmgr[1451]: 557E216802A: removed
Oct 18 10:48:52 servidor in.qpopper[3027]: (v4.0.5) POP login by user "teste" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 10:52:25 servidor in.qpopper[3035]: (v4.0.5) POP login by user "teste" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 10:52:58 servidor postfix/smtpd[3036]: connect from saturn.moderna.com.br[200.157.130.35]
Oct 18 10:53:09 servidor postfix/smtpd[3036]: 57D8C16802A: client=saturn.moderna.com.br[200.157.130.35]
Oct 18 10:53:28 servidor postfix/cleanup[3039]: 57D8C16802A: message-id=<016201c6f2b9$a0ea50a0$[email protected]>
Oct 18 10:54:33 servidor postfix/smtpd[3040]: connect from 201-42-107-217.dsl.telesp.net.br[201.42.107.217]
Oct 18 10:54:34 servidor postfix/smtpd[3040]: NOQUEUE: reject: RCPT from 201-42-107-217.dsl.telesp.net.br[201.42.107.217]: 454 <[email protected]>: Relay access denied; from=<[email protected]> to=<[email protected]> proto=SMTP helo=<nilton>
Oct 18 10:54:34 servidor postfix/smtpd[3040]: disconnect from 201-42-107-217.dsl.telesp.net.br[201.42.107.217]
Oct 18 10:55:39 servidor postfix/qmgr[1451]: 57D8C16802A: from=<[email protected]>, size=244439, nrcpt=1 (queue active)
Oct 18 10:55:40 servidor postfix/smtpd[3036]: disconnect from saturn.moderna.com.br[200.157.130.35]
Oct 18 10:55:44 servidor postfix/local[3041]: 57D8C16802A: to=<[email protected]-ie.com.br>, relay=local, delay=158, status=sent (delivered to command: /usr/bin/procmail -f- -a "$USER" debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin xxgdb $daemon_directory/$process_name $process_id & sleep 5)
Oct 18 10:55:44 servidor postfix/qmgr[1451]: 57D8C16802A: removed
Oct 18 11:01:37 servidor in.qpopper[3048]: (v4.0.5) POP login by user "teste" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 11:02:15 servidor postfix/smtpd[3049]: warning: smtpd_peer_init: 201.0.174.77: address not listed for hostname servidor.paulista-ie.com.br
Oct 18 11:02:15 servidor postfix/smtpd[3049]: connect from unknown[201.0.174.77]
Oct 18 11:02:15 servidor postfix/smtpd[3049]: 9E41E16802A: client=unknown[201.0.174.77]
Oct 18 11:02:15 servidor postfix/cleanup[3052]: 9E41E16802A: message-id=<[email protected]>
Oct 18 11:02:15 servidor postfix/qmgr[1451]: 9E41E16802A: from=<[email protected]>, size=94550, nrcpt=1 (queue active)
Oct 18 11:02:15 servidor postfix/smtpd[3049]: disconnect from unknown[201.0.174.77]
Oct 18 11:02:15 servidor in.qpopper[3057]: (v4.0.5) POP login by user "teste" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 11:02:20 servidor postfix/local[3053]: 9E41E16802A: to=<[email protected]>, relay=local, delay=5, status=sent (delivered to command: /usr/bin/procmail -f- -a "$USER" debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin xxgdb $daemon_directory/$process_name $process_id & sleep 5)
Oct 18 11:02:20 servidor postfix/qmgr[1451]: 9E41E16802A: removed
Oct 18 11:09:47 servidor in.qpopper[3081]: (v4.0.5) POP login by user "teste" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 11:09:52 servidor in.qpopper[3082]: (v4.0.5) POP login by user "teste" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 11:12:41 servidor postfix/smtpd[3083]: connect from demorgan.com.br[200.138.31.116]
Oct 18 11:12:42 servidor postfix/smtpd[3083]: 22F2D16802A: client=demorgan.com.br[200.138.31.116]
Oct 18 11:12:42 servidor postfix/cleanup[3086]: 22F2D16802A: message-id=<[email protected]>
Oct 18 11:12:42 servidor postfix/qmgr[1451]: 22F2D16802A: from=<[email protected]>, size=1910, nrcpt=1 (queue active)
Oct 18 11:12:42 servidor postfix/smtpd[3083]: disconnect from demorgan.com.br[200.138.31.116]
Oct 18 11:12:47 servidor postfix/local[3087]: 22F2D16802A: to=<[email protected]>, relay=local, delay=5, status=sent (delivered to command: /usr/bin/procmail -f- -a "$USER" debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin xxgdb $daemon_directory/$process_name $process_id & sleep 5)
Oct 18 11:12:47 servidor postfix/qmgr[1451]: 22F2D16802A: removed
Oct 18 11:15:50 servidor postfix/smtpd[3091]: connect from smtp-28.ig.com.br[200.226.132.158]
Oct 18 11:15:50 servidor postfix/smtpd[3091]: NOQUEUE: reject: RCPT from smtp-28.ig.com.br[200.226.132.158]: 450 <[email protected]>: Recipient address rejected: User unknown in local recipient table; from=<[email protected]> to=<[email protected]> proto=SMTP helo=<smtp-28.ig.com.br>
Oct 18 11:15:50 servidor postfix/smtpd[3091]: disconnect from smtp-28.ig.com.br[200.226.132.158]
Oct 18 11:21:04 servidor in.qpopper[3094]: nilton at servidor.paulista-ie.com.br (201.0.174.77): -ERR [AUTH] PAM authentication failed for user "nilton": Authentication failure (7) [pop_pass.c:483]
Oct 18 11:21:04 servidor in.qpopper[3094]: [AUTH] Failed attempted login to nilton from host (servidor.paulista-ie.com.br) 201.0.174.77 [pop_pass.c:1383]
Oct 18 11:21:23 servidor in.qpopper[3095]: (v4.0.5) POP login by user "nilton" at (servidor.paulista-ie.com.br) 201.0.174.77 [pop_log.c:244]
Oct 18 11:37:31 servidor postfix/smtpd[3099]: connect from nf-out-1516.google.com[64.233.182.166]
Oct 18 11:37:32 servidor postfix/smtpd[3099]: 3A14316802A: client=nf-out-1516.google.com[64.233.182.166]
Oct 18 11:37:32 servidor postfix/cleanup[3102]: 3A14316802A: message-id=<[email protected]>
Oct 18 11:37:32 servidor postfix/qmgr[1451]: 3A14316802A: from=<[email protected].com>, size=1876, nrcpt=1 (queue active)
Oct 18 11:37:37 servidor postfix/local[3103]: 3A14316802A: to=<[email protected]>, relay=local, delay=6, status=sent (delivered to command: /usr/bin/procmail -f- -a "$USER" debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin xxgdb $daemon_directory/$process_name $process_id & sleep 5)
Oct 18 11:37:37 servidor postfix/qmgr[1451]: 3A14316802A: removed
Oct 18 11:38:02 servidor postfix/smtpd[3099]: disconnect from nf-out-1516.google.com[64.233.182.166]
Oct 18 11:43:25 servidor postfix/smtpd[3127]: connect from unknown[200.157.130.35]
Oct 18 11:43:33 servidor postfix/smtpd[3127]: BAAC516802A: client=unknown[200.157.130.35]
Oct 18 11:43:37 servidor postfix/cleanup[3130]: BAAC516802A: message-id=<016701c6f2b9$d81febc0$[email protected]>
Oct 18 11:43:48 servidor postfix/qmgr[1451]: BAAC516802A: from=<[email protected]>, size=193041, nrcpt=1 (queue active)
Oct 18 11:43:51 servidor postfix/smtpd[3127]: disconnect from unknown[200.157.130.35]
Oct 18 11:43:53 servidor postfix/local[3131]: BAAC516802A: to=<[email protected]>, relay=local, delay=23, status=sent (delivered to command: /usr/bin/procmail -f- -a "$USER" debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin xxgdb $daemon_directory/$process_name $process_id & sleep 5)
Oct 18 11:43:53 servidor postfix/qmgr[1451]: BAAC516802A: removed

Att,
Nilton Fortunato
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/10/2006, 12:18
Resposta: #14
 
Nilton Escreveu:Aprendiz.
Cara primeiro vc tem de ter um link de internet com IP FIXO sim!!! é esse ip fixo q vc informará ao programa de DNS (bind9) e fará a associação com seudominio.com.br (ou qualquer outro).
Qto ao UebiMuau, é bem rápido, simples de configurar e bem funcional!!!
Cara qq coisa me add no msn q a gente se fala melhor.
Att, Nilton


Beleza!

Quando eu for por isso em prática te chamo no MSN, OK?

Obrigado mais uma vez e um forte abraço.

Na vida, o que vale é a viagem... e não o destino.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/10/2006, 08:49
Resposta: #15
 
Fernando, já conseguí solucionar o problema.
Salvei todos meus arquivos de configuração, e depois removí todos os pacotes com --purge, ou seja, tive q reinstalar e reconfigurar tudo. Mas o importante é q tá funcionando!!!
Desde já agradeço a atenção!

Att,
Nilton Fortunato
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS