Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Problemas após atualização do sistema
13/10/2006, 16:39
Resposta: #1
Problemas após atualização do sistema
Acabo de dar um agt-get dist-upgrade e alguns problemas apareceram:

Primeiro, o ambiente gráfico não abre com o novo kernel, mas continua normal quando escolho o kernel antigo. Eu só queria saber quanto a isso, se eu preciso apenas instalar novamente o drive nvidia ou se existe uma maneira mais simples de fazê-lo funcionar.

O outro problema é que as fontes nos programas GTK ficaram com aparência terrível e tosca, enquanto nos programas do KDE, elas continuam iguais.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/10/2006, 21:50
Resposta: #2
 
qual era o kernel anterior? 2.4 e agora é 2.6? posta a log do xorg do x que tá com problema /var/log/Xog.0.log Quanto as fontes é provável que esteja faltando instalar as fontes do x adequadas.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/10/2006, 12:59
Resposta: #3
 
kernel antigo: Linux debian 2.6.15-1-686 #2 Mon Mar 6 15:27:08 UTC 2006 i686 GNU/Linux

kernel novo: Linux debian 2.6.17-2-686 #1 SMP Wed Sep 13 16:34:10 UTC 2006 i686 GNU/Linux

Não sei que parte do LOG devo colar, mas aqui está o final que aparenta ser relevante:

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo"
(**) NVIDIA(0): Enabling RENDER acceleration
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "ramdac"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found


Sobre as fontes eu não entendo, instalar novas ? Mas se funcionava tudo direitinho, já não devem estar instaladas ? E outra é que as mesmas fontes nos programas do KDE estão boas.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/10/2006, 14:18
Resposta: #4
 
veja se o modulo do nvidia está sendo carregado no novo kernel digite:
# lsmod
e procure pelo nvidia, caso não esteja presente digite:
# modprobe nvidia

e tente iniciar o X com startx.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/10/2006, 23:15
Resposta: #5
 
é possível que você tenha que reinstalar o módulo da nvidia para o seu novo kernel. pra cada kernel tem um conjunto de pacotes diferentes...

You worry too much about your job. Stop it. You are not paid enough to worry.

Regras para conduta no fórum: http://www.forumdebian.com.br/viewtopic.php?t=65
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/10/2006, 04:17
Resposta: #6
 
Valeu pela ajuda, mas além desses problemas apareceram outros e eu realmente não tenho tempo pra tentar resolver tudo. Por isso acabei reinstalando o sistema. Obrigado a todos :>
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS