Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Configuração do Xorg Universal
12/10/2006, 22:18
Resposta: #1
Configuração do Xorg Universal
Olá senhores,

Uma das principais dificuldades do pessoal que está vindo para o Debian é que as vezes se tem problemas ao iniciar o modo gráfico. Então estou abrindo esse tópico para colocar um xorg.conf universal para o pessoal que tiver esse tipo de problemas no Debian Etch.

Esta configuração aos poucos deve funcionar na maioria dos computadores. Mas isso só vai ser possível com a ajuda da comunidade, portanto se funcionar ou não, volte aqui e diga, assim podemos ir melhorando ele, ok? É claro que é sempre bom informar qual o seu hardware e qual erro aconteceu Alegre

Ai está (leia os comentários e volte dizendo o que achou):

Código:
# Xorg.conf universal
#
# Envie comentários, sugestões e críticas em
# http://www.forumdebian.com.br/topico-813.html
#

Section "ServerFlags"
        # Essa opção deixa o xorg abrir mesmo que se tenha um erro no
        # mouse.
    Option "AllowMouseOpenFail" "true"
EndSection

Section "Files"
    FontPath    "/usr/share/fonts/X11/misc"
    FontPath    "/usr/X11R6/lib/X11/fonts/misc"
    FontPath    "/usr/share/fonts/X11/cyrillic"
    FontPath    "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath    "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath    "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath    "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath    "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath    "/usr/share/fonts/X11/Type1"
    FontPath    "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath    "/usr/share/fonts/X11/100dpi"
    FontPath    "/usr/X11R6/lib/X11/fonts/100dpi"
    FontPath    "/usr/share/fonts/X11/75dpi"
    FontPath    "/usr/X11R6/lib/X11/fonts/75dpi"
    # path to defoma fonts
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load "ddc"
        Load "dbe"
        Load "extmod"
        Load "bitmap"
        Load "type1"
        Load "speedo"
        Load "freetype"
        Load "record"
EndSection

#
# Nessa parte temos dois tipos de teclado, o ABNT2 e o Americano
# Internacional, deixamos o ABNT2 por padrão, caso você use o
# Americano Internacional descomente as linhas dele
# (é só remover o # no início de cada linha)
# e remover as linhas do ABNT2.
#

###### Teclado ABNT2 ######
Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "abnt2"
    Option        "XkbLayout"    "br"
    Option        "XkbVariant"    "abnt2"
EndSection
###### Fim do Teclado ABNT2 ######

###### Teclado americano internacional ######
#Section "InputDevice"
#    Identifier    "Generic Keyboard"
#    Driver        "kbd"
#    Option        "CoreKeyboard"
#    Option        "XkbRules"    "xorg"
#    Option        "XkbModel"    "pc105"
#    Option        "XkbLayout"    "us_intl"
#EndSection
####### Fim do americano internacional ######

#
# Aqui estão os mouses, você não precisa remover nenhum deles
# pois o Xorg irá aceitar qualquer um já que temos a diretiva
# "AllowMouseOpenFail"  setada como "true" acima.
#

# Mouse PS/2
Section "InputDevice"
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/psaux"
    Option        "Protocol"        "Auto"
    Option        "Emulate3Buttons"    "true"
EndSection

# Mouse USB
Section "InputDevice"
    Identifier    "Mouse1"
    Driver        "mouse"
    Option        "Protocol"        "IMPS/2"
    Option        "Device"        "/dev/input/mice"
    Option        "ZAxisMapping"        "4 5"
    Option        "Buttons"        "5"
    Option        "Resolution"        "650"
EndSection

# Mouse Serial em ttys0
Section "InputDevice"
    Identifier    "Mouse2"
    Driver        "mouse"
    Option        "Protocol"        "Microsoft"
    Option        "Device"        "/dev/ttys0"
    Option        "ZAxisMapping"        "4 5"
    Option        "Buttons"        "5"
    Option        "Resolution"        "650"
EndSection

# Mouse Serial em ttys1
Section "InputDevice"
    Identifier    "Mouse3"
    Driver        "mouse"
    Option        "Protocol"        "Microsoft"
    Option        "Device"        "/dev/ttys1"
    Option        "ZAxisMapping"        "4 5"
    Option        "Buttons"        "5"
    Option        "Resolution"        "650"
EndSection

Section "Device"
    Identifier    "Placa de Vídeo Genérica"
    # Em raros caso, comente o vesa e descomente o fbdev
        Driver    "vesa"
    # Driver    "fbdev"
EndSection

Section "Monitor"
    Identifier    "Monitor Genérico"
    Option        "DPMS"
    HorizSync    28-57
    VertRefresh    43-60
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Placa de Vídeo Genérica"
    Monitor        "Monitor Genérico"
    DefaultDepth    16
    SubSection "Display"
        Depth        16
        Modes        "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Generic Keyboard"
    InputDevice    "Mouse0"
    InputDevice    "Mouse1"
    InputDevice    "Mouse2"
    InputDevice    "Mouse3"
EndSection

Section "DRI"
    Mode    0666
EndSection
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/10/2006, 00:29
Resposta: #2
 
No caso, é possível deixar dois teclados habilitados?? O ABNT2 e o americano?

Abraço,
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/10/2006, 12:39
Resposta: #3
 
apscherbach Escreveu:No caso, é possível deixar dois teclados habilitados?? O ABNT2 e o americano?

Mas ele vai ter que escolher um de qualquer jeito. O que podemos fazer é um script que pergunta para o usuário qual o teclado dele e assim automaticamente habilitar/desabilitar os layouts.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/08/2007, 16:43
Resposta: #4
 
estou com o xorg e xfce4 instalado e funcionando...
o xfce4 esta iniciando em 800x600... como faço pra forçar ele a iniciar em 1204x768 ???

Grato. Alegre
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/08/2007, 10:18
Resposta: #5
 
Hulk Escreveu:estou com o xorg e xfce4 instalado e funcionando...
o xfce4 esta iniciando em 800x600... como faço pra forçar ele a iniciar em 1204x768 ???

Grato. Alegre

Você está utilizando o xorg acima?

Você poderia me dizer qual a sua placa de vídeo e qual driver está utilizando?
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/08/2007, 17:12
Resposta: #6
 
ja resolvi.
Coloquei as taxas de atualizacao do monitor e foi.
valeu!

Piscada
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/12/2007, 12:53
Resposta: #7
 
Amigos, gostaria de pedir-lhes uma ajuda, pois estou migrando do windows para o linux e ainda não sou muito familiarizado.

Minha placa de video é uma xfx geforce 8600 GT Fatal1ty.
eu instalei o debian (debian-40r1-amd64-CD-1.iso) e depois de tudo instalado ao dar boot nele ocorria o erro:
XIO:Fatal IO error104 "0.0"

Então eu subistitui o xorg.conf por esse do post mais dai infelizmente ao dar boot a tela simplesmente desliga... gostaria de uma ajuda de voce pois me simpatizo bastante com o linux e gostaria de usa-lo como alternativa ao windows.

Grato
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/12/2007, 20:05
Resposta: #8
 
wskbr, da uma olhada se esse link abaixo te ajuda, pois vc precisa instalar o driver da nvidia antes de usar essas configurações, e para usar o drive da nvidia vc precisa trocar onde o driver vesa por nvidia.


http://wiki.forumdebian.com.br/index.ph ... _no_Debian

Visite também o Nosso Wiki
WikiForumdebian

--
"In a World without Walls and Fences, who needs Windows and Gates? -
Think different. -Think Linux."
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/12/2007, 23:13
Resposta: #9
 
amigo, obrigado pela pronta ajuda... mais ja estou com mais um problema: ao rodar o driver da nvidia ocorre o erro: "error: the cc sanity check failed" não sei oque fazer... to quebrando a cabeça aqui a um tempo e nada....
em outro topico voce respondeu a um problema parecido com esse artigo: http://wiki.forumdebian.com.br/index.ph ... do_Drivers
entao tentei isso mais não sei exatamente oque é o kernel-source-`uname -r | cut -f1 -d-`.tar.bz2 e por isso encalhei ai tbm....

obrigado... 8)

Ps. to quase desistindo... nada da certo... num tem nenhum script ou algo ssim para eu fazer isso?
grato...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/12/2007, 21:45
Resposta: #10
 
wskbr, uma pergunta o seu X não founciona de jeito nenhum ou ele funciona e vc quer instalar o driver da nvidia? vc instalou o linux-headersxxx correspondente ao seu kernel ? e outra coisa importante é verificar se o gcc esta instalado, uma dica se o X não estiver funcionando de forma alguma vc poderia tentar usar um drive generico de video o vesa pelo menos por enquanto, até a gente conseguir resolver esse problema

Ps. não desista nunca, no começo tudo é dificil mais depois que vc supera isso as coisas vão ficando cada vez mais facil.

Visite também o Nosso Wiki
WikiForumdebian

--
"In a World without Walls and Fences, who needs Windows and Gates? -
Think different. -Think Linux."
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/12/2007, 10:40
Resposta: #11
 
hehehe, to firme e forte aqui é que tem hora que da vontade de sair na mao com o pc... mais blz.... eu vo fazer o seguinte... vo formata e instala denovo o debian.
dai me explica só uma coisa, quais pacotes eu tenho que instalar pro X funciona? O problema é o seguinte: ele da boot e quando ele chega na parte que voce faz o login ele da umas piscadas na tela e aparece uma tela azul falando que deu um erro (se não me engano nessa hora da o erro "XIO:Fatal IO error104 "0.0" ").
Bom se voce puder me dar uma ideia dos pacotes e oque mais ou menos fazer depois de instala-los vai ajudar muito =)

Valew
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/12/2007, 21:11
Resposta: #12
 
wskbr, o que eu faço normalmente é no momento da instalação em que pede para dizer quais aplicativos eu quero instalar eu escolho sistema básico e Ambiente Desktop e normalmente a maioria das coisas já funciona, claro que depois tem um detalhe ou outro como no seu caso o driver da nvidia para funcionar a aceleração 3d, isso deve ser o suficiente.

Visite também o Nosso Wiki
WikiForumdebian

--
"In a World without Walls and Fences, who needs Windows and Gates? -
Think different. -Think Linux."
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/12/2007, 10:08
Resposta: #13
 
bom, formatei tudo e instalei denovo...
ao chegar no momento de dar o "make menuconfig" (para compilar o novo kernel) da o seguinte erro:
HOSTCC scripts/basic/fixdep
/bin/sh: gcc: command not found
make[1]: ** [scripts_basic] Error 127
make: ** [scripts_basic] Error 2

voce sabe oque pode ser e como corrigir isso??

valew ljulio...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/12/2007, 20:00
Resposta: #14
 
wskbr, mas o que vc esta querendo fazer? para que esta tentando compilar o kernel, e se for isso é bom dar uma pesquisada sobre compilação de kernel, a mensagem ai esta dizendo que falta o gcc, mas a alguns topicos aqui sobre a compilação de kernel se assim vc desejar.

Visite também o Nosso Wiki
WikiForumdebian

--
"In a World without Walls and Fences, who needs Windows and Gates? -
Think different. -Think Linux."
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/12/2007, 10:26
Resposta: #15
 
enfim consegui resolver os problemas 8)
bom para quem tiver os mesmos problemas:
o driver da nvidia realmente começaram a funcionar depois de recompilar o kernel! e no caso do erro do make menuconfig :
HOSTCC scripts/basic/fixdep
/bin/sh: gcc: command not found
make[1]: ** [scripts_basic] Error 127
make: ** [scripts_basic] Error 2

o make menuconfig começou a funcionar depois de instalar o pacote build-essential, apesar de parecer besta demoro pra descubri....

Falow e valew ai ljulio pela ajuda
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS