Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
apt-get p/ instalar dhcp3-server
05/10/2006, 11:04
Resposta: #1
apt-get p/ instalar dhcp3-server
Olá, galera to com um problema q não sei resolver! to tentando instalar um servidor LTSP e preciso do servidor dhcpd q no caso seria o dhcp3-server eu não encontro mirrors para baixar ele pro debian-cdd-br encontrei um no tutorial http://www.vivaolinux.com.br/artigos/ve ... 9&pagina=2 mas ele não da start quando termino todas as instalações, o pior q ja tentei usar kurumin e nele eu instalo pelo mirrors originais do kurumin, e deu certo no kurumin, mas quero usar o debian e não consigo fazer o dhcp3-server iniciar, sempre da uma msg de erro! será incompatbilidade com o debian-cdd-br? obrigado pela ajuda! :wink:
Citar esta mensagem em uma resposta
05/10/2006, 11:29
Resposta: #2
 
Não creio que seja incompatibilidade, se instalou tudo e não de erro em nada, falta configurar ele, posta a saída do comando abaixo pra sabermos o que está errado:
Código:
# grep  dhcpd  /var/log/syslog  | tail  -n30  -

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/10/2006, 11:44
Resposta: #3
 
aarzak,

Se não em engano enquanto você não configurar o dhcp3-server para servir pelo menos uma faixa de ip ele não inicia.

Configure o servidor dhcpd usando essa parte do artigo ( http://www.vivaolinux.com.br/artigos/ve ... 9&pagina=4 ) e depois tente inicializá-lo.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/10/2006, 12:59
Resposta: #4
 
bem galera o servidor dhcpd está configurado exatamente igual ao do kurumin q funcionou. usei o comando e apareceu isso.
Oct 5 12:01:45 localhost dhcpd: All rights reserved.
Oct 5 12:01:45 localhost dhcpd: For info, please visit http://www.isc.org/sw/dhcp/
Oct 5 12:01:45 localhost dhcpd: Wrote 0 leases to leases file.
Oct 5 12:01:45 localhost dhcpd:
Oct 5 12:01:45 localhost dhcpd: No subnet declaration for eth0 (192.168.254.1).
Oct 5 12:01:45 localhost dhcpd: ** Ignoring requests on eth0. If this is not what
Oct 5 12:01:45 localhost dhcpd: you want, please write a subnet declaration
Oct 5 12:01:45 localhost dhcpd: in your dhcpd.conf file for the network segment
Oct 5 12:01:45 localhost dhcpd: to which interface eth0 is attached. **
Oct 5 12:01:45 localhost dhcpd:
Oct 5 12:01:45 localhost dhcpd:
Oct 5 12:01:45 localhost dhcpd: Not configured to listen on any interfaces!
Oct 5 12:05:04 localhost dhcpd: /etc/dhcp3/dhcpd.conf line 27: unexpected end of file
Oct 5 12:05:04 localhost dhcpd:
Oct 5 12:05:04 localhost dhcpd: ^
Oct 5 12:05:04 localhost dhcpd: Configuration file errors encountered -- exiting
Oct 5 12:07:44 localhost dhcpd: /etc/dhcp3/dhcpd.conf line 26: unexpected end of file
Oct 5 12:07:44 localhost dhcpd:
Oct 5 12:07:44 localhost dhcpd: ^
Oct 5 12:07:44 localhost dhcpd: /etc/dhcp3/dhcpd.conf line 26: unexpected end of file
Oct 5 12:07:44 localhost dhcpd:
Oct 5 12:07:44 localhost dhcpd: ^
Oct 5 12:07:44 localhost dhcpd: Configuration file errors encountered -- exiting
Oct 5 12:09:16 localhost dhcpd: /etc/dhcp3/dhcpd.conf line 27: expecting a declaration
Oct 5 12:09:16 localhost dhcpd: }
Oct 5 12:09:16 localhost dhcpd: ^
Oct 5 12:09:16 localhost dhcpd: /etc/dhcp3/dhcpd.conf line 30: unexpected end of file
Oct 5 12:09:16 localhost dhcpd:
Oct 5 12:09:16 localhost dhcpd: ^
Oct 5 12:09:16 localhost dhcpd: Configuration file errors encountered -- exiting
Citar esta mensagem em uma resposta
05/10/2006, 14:23
Resposta: #5
 
aarzak,

O dhcpd.conf tem erros na linha 26, 27 e 30. Tem como você postá-lo aqui?
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/10/2006, 12:02
Resposta: #6
 
aki está mas acho q está = ao do site!
engraçado q faço essa configuração no kurumin e lá funciona!
e tem + no dhcp3-server do Kurumin existe o comando #/etc/init.d/dhcp3-server status
ja no debian não existe esse comando. será versões diferentes?

ddns-update-style none;

default-lease-time 21600;
max-lease-time 21600;

option subnet-mask 255.255.255.0;
option broadcast-address 192.168.254.255;
option routers 192.168.254.254;
option domain-name-servers 192.168.254.1;
#option domain-name "meudominio.com.br";

option root-path "192.168.254.1:/opt/ltsp/i386";

option option-128 code 128 = string;
option option-129 code 129 = text;

subnet 192.168.0.0 netmask 255.255.255.0 {
use-host-decl-names on;
option log-servers 192.168.254.1;

# Estações

host ws001 {
hardware ethernet 00:E0:7D:CF:8C:1D;
fixed-address 192.168.254.11;
filename "/tftpboot/lts/vmlinuz-2.4.21-ltsp-1";
}
Citar esta mensagem em uma resposta
08/10/2006, 12:40
Resposta: #7
 
Código:
host ws001 {
hardware ethernet 00:E0:7D:CF:8C:1D;
fixed-address 192.168.254.11;
filename "/tftpboot/lts/vmlinuz-2.4.21-ltsp-1";
}

Posicione o cursor após a } na ultima linha e tecle enter, use o delete várias vezes para certificar-se que não existe mais caracteres após essa chave final, e salve o arquivo novamente. veja se mesmo assim os erro ainda existem ao iniciar o serviço.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/10/2006, 18:03
Resposta: #8
 
realmente não adiantou. Triste mas tudo bem acho q vou ficar tentando no Kurumon mesmo! vlw galera!
Citar esta mensagem em uma resposta
08/10/2006, 22:07
Resposta: #9
 
aarzak Escreveu:subnet 192.168.0.0 netmask 255.255.255.0 {
use-host-decl-names on;
option log-servers 192.168.254.1;

# Estações

host ws001 {
hardware ethernet 00:E0:7D:CF:8C:1D;
fixed-address 192.168.254.11;
filename "/tftpboot/lts/vmlinuz-2.4.21-ltsp-1";
}

o exemplo do site está errado! veja está faltando um fechamento de chave na subnet, que deve ficar assim:

Código:
subnet 192.168.0.0 netmask 255.255.255.0 {     <---aqui abriu
    use-host-decl-names      on;
    option log-servers       192.168.254.1;
    }                                       <---aqui fecha
    # Estações

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/10/2006, 08:31
Resposta: #10
 
aarzak,

Aqui está o meu dhcpd.conf para LTSP

Código:
# dhcpd.conf

ddns-update-style             ad-hoc;

option subnet-mask            255.255.255.0;
option broadcast-address      192.168.1.255;
option routers                192.168.0.3; # IP DO SEU ROTEADOR
option domain-name-servers    192.168.0.3; # IP DO SEU SERVIDOR DNS
option domain-name            "seudominio.com.br";   # SEU DOMINIO
option option-128 code 128 = string;
option option-129 code 129 = text;


get-lease-hostnames           true;

next-server                   192.168.0.3; # IP DO SERVIDOR LTSP
option root-path              "192.168.0.3:/opt/ltsp/i386"; # IP DO SERVIDOR LTSP

subnet 192.168.0.0 netmask 255.255.255.0 {
    range   192.168.0.100   192.168.0.199; # FAIXA DE IPS QUE ELE VAI COLOCAR OS CLIENTES
    if substring (option vendor-class-identifier, 0, 9) = "PXEClient" {
        filename "/tftpboot/lts/2.6.16.1-ltsp-1/pxelinux.0";
    }
    else{
        filename "/tftpboot/lts/vmlinuz-2.6.16.1-ltsp-2";
    }
}

Eu realmente recomendo que você siga esse wiki (apesar de ser em inglês) para instalar o LTSP no Debian: http://wiki.ltsp.org/twiki/bin/view/Ltsp/Debian
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS