Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Não estou conseguindo usar o proxy transparente.
19/09/2006, 15:59
Resposta: #1
Não estou conseguindo usar o proxy transparente.
Então só estou conseguindo usar o proxy manual, com as configurações setadas nos clientes (Firefox e IE).

Estou usando o Squid 2.5.

Rodei alguns comandos como:

# iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128

E no final do arquivo /etc/squid/squid.conf

httpd_accel_host virtual
httpd_accel_port 80
httpd_accel_with_proxy on
httpd_accel_uses_host_header on

E nem assim eu consigo rodar esse proxy transparente.

Alguém tem algum outro tipo de script ou dica? Laughing

Venice [email protected] Mhz
DFI N4 Lanparty UT
2x512 3200 GEIL ULTRA X (DDR 500)
250GB SATAII / 2x HD Seagate 80GB-SATA
Evga 7900GT KO
Enermax EG565P-VE FMA 535w
Gabinete Xblade Vcom
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/09/2006, 00:46
Resposta: #2
 
Cara vc esta usando pppoe ou seu modem esta router??


'Pode utilizar assim

No seu squid.conf pode deixallo assim mesmo mais
coloque estas regras!

#Redirecionando portas do squid
iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 3128
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

#Ativando o compartilhamento
echo "1" > /proc/sys/net/ipv4/ip_forward

#Agora use o iptables para ativar mascaramento:
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

# Encaminhamento de Pacotes
echo "1" > /proc/sys/net/ipv4/ip_forward

# Mascaramento
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

Cara na minha rede finciona, só náo rola se estiver com modem roteado.
Não sei porque,..

Agora estou com um Site, dedicado a estudos e tutoriais com a distribuição Debian.

www.linuxconf.v10.com.br

Aguardo a visita de todos.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/09/2006, 13:27
Resposta: #3
 
estou usando modem roteado mesmo. :lol:

Venice [email protected] Mhz
DFI N4 Lanparty UT
2x512 3200 GEIL ULTRA X (DDR 500)
250GB SATAII / 2x HD Seagate 80GB-SATA
Evga 7900GT KO
Enermax EG565P-VE FMA 535w
Gabinete Xblade Vcom
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/12/2006, 19:17
Resposta: #4
 
Então cara, no modem roteado não consegui realizar isso, não sei porque não rolou nem apal.
Se você conseguir me da um toque!!!

Agora estou com um Site, dedicado a estudos e tutoriais com a distribuição Debian.

www.linuxconf.v10.com.br

Aguardo a visita de todos.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS