Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
modo grafico nao inicia erro do x
10/09/2006, 19:47
Resposta: #1
modo grafico nao inicia erro do x
Galera,
Estava com o sarge funcionando legal. mas ainda

insatisfeito por não ter conseguido configurar a

placa de video geforce 5200 V4. segui novamente

aquele tutorial aqui do forum,(aquelas 2 dicas

infaliveis que me faliram 2 vezes já o sistema);

tenho o seguinte erro
x window version 7.0.0

failed to load vesa
failed to load mouse
no driver available

fatal server error

no screen found

XIO fatal IO error 104
on server X 0.0 after 0 requests

estava eu usando o KDE 3.2 e kernel 2.6(maravilha por

sinal).

alguem me dá uma dica? tentei X -configure mas dá

erro.

[]s.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/09/2006, 17:25
Resposta: #2
 
Antes de alterar o xorg.conf vc fez uma cópia certo? Então é só sobrescrever o atual xorg.conf pelo backup e tudo volta ao normal.

Antes de fazer alterações em arquivos que requer root sempre salve o original.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/09/2006, 17:50
Resposta: #3
 
Grande Dmatrix. e o plano B?
aquele quando o Super User nao fez copia.

tem algum cmd do tipo Xorg.conf configure?

[]s
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/09/2006, 18:54
Resposta: #4
 
lordean, pelo que vc disse vc usa o Sarge se for isso vc não deve ter o xorg e sim o XF86config, partindo desse ponto vc pode execultar o seguinte comando:

Código:
xf86config

e ir respondendo as perguntas, outra opção é o :

Código:
XFree86 -configure

Esse comando ira gerar um arquivo de configuração novo no /root que deve se chamar algo como XF86Config.new, ai vc pode aproveitar algumas coisas do arquivo que vc já tem e tentar conserta-las e depois é só copiar para o local e nome correto que dever ser em /etc/X11/XF86Config-4.
Acho que o primeiro modo é mais facil, mas fica ai o poste pra quem quizer tentar algo diferente.

Visite também o Nosso Wiki
WikiForumdebian

--
"In a World without Walls and Fences, who needs Windows and Gates? -
Think different. -Think Linux."
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/09/2006, 19:25
Resposta: #5
 
lordean Escreveu:Grande Dmatrix. e o plano B?
aquele quando o Super User nao fez copia.

tem algum cmd do tipo Xorg.conf configure?

[]s

Sorrisão neste caso o plano B seria verificar dentre os arquivos que o próprio sistema fez de backup, aquele que sobrescrevendo o principal possa fazer levantar o X novamente, dá uma olhada em /etc/X11 os arquivos que possuem além da extensão uma data e hora, por exemplo: xorg.conf.20060702145125 ou
XF86Config-4-20050912-2016 é o caminho mais curto pra tentar recuperar. xorg -configure ou o X -xf86config tem 98% de dar certo. Sorrisão

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/09/2006, 16:48
Resposta: #6
 
Olha... o comando xfree86config
e xfree86 -configure
dá como comando não valido
e não retorna nada

uma coisa que pensei, será que se reinstalar o kde ou gnome, voltaria o modo gráfico do zero?
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/09/2006, 16:58
Resposta: #7
 
lordean, vc tentou o xf86config ??? não o xfree86config

Visite também o Nosso Wiki
WikiForumdebian

--
"In a World without Walls and Fences, who needs Windows and Gates? -
Think different. -Think Linux."
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/09/2006, 22:04
Resposta: #8
 
Alo galera do bem, Xorg - configure -> No devices do configure ( ele dá uma lista de 3 devices suportados, voodoo, silicon e mais um).

X - Xf86Config -> unrecognized option

Estou sem o arquivo como o dmatrix falou.
Tudo isso aconteceu depois que tentei configurar a geforce.

o aptitude não está instalado.
Estou pensando em re-instalar o kde, e aproveitar pra pegar a versao mais nova.
o que acham?
funciona?
como faço? atualizo o sources.list? Estou usando tudo em testing. pq minha aventura em unstable só me deu prob de dependencias!

[]s
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/09/2006, 16:23
Resposta: #9
 
lordean Escreveu:Alo galera do bem, Xorg - configure -> No devices do configure ( ele dá uma lista de 3 devices suportados, voodoo, silicon e mais um).

o aptitude não está instalado.
Estou pensando em re-instalar o kde, e aproveitar pra pegar a versao mais nova.
o que acham?
funciona?
como faço? atualizo o sources.list? Estou usando tudo em testing. pq minha aventura em unstable só me deu prob de dependencias!

[]s

ok, agora que deu o comando Xorg -configure vamos tentar levantar o X vá em /root e dê um cp xorg.conf.new /etc/X11/xorg.conf
instale o mc para facilitar a edição do arquivo:
apt-get install mc
entre no diretório:
/etc/X11
digite mc
localize o xorg.conf tecle f4 sobre ele e altere a linha na seção "Device" onde está "Driver" defina o "vesa"

salve com f2 e saia com F10.

dê agora um startx

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/09/2006, 17:55
Resposta: #10
 
cp xorg.conf.new /etc/X11/xorg.conf

xorg.conf.new file not found
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/09/2006, 21:18
Resposta: #11
 
lordean Escreveu:cp xorg.conf.new /etc/X11/xorg.conf

xorg.conf.new file not found

caramba :shock: ,existe pelo menos o arquivo xorg.conf no diretório /etc/X11 ?
se sim é possivel fazer o procedimento citado acima?
poderia postar aqui a saída do comando:
$ tail -20 /var/log/Xorg.0.log

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
16/09/2006, 11:39
Resposta: #12
 
$ tail -20 /var/log/Xorg.0.log

command not found
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
16/09/2006, 13:53
Resposta: #13
 
tente postar então as saídas destes comandos:

grep Driver /etc/X11/xorg.conf

grep EE /var/log/Xorg.0.log

tente refazer as configurações do X definindo o driver para "vesa"

# dpkg-reconfigure xserver-xorg

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
17/09/2006, 12:06
Resposta: #14
 
Ok. farei isso. só adiantando. ele já está em vesa. deu esse pau depois que eu dei o install do driver nvidia! já temo que o grep para Xorg.0.log de command not found. vou faze-lo! []s
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
17/09/2006, 17:22
Resposta: #15
 
lordean Escreveu:Ok. farei isso. só adiantando. ele já está em vesa. deu esse pau depois que eu dei o install do driver nvidia! já temo que o grep para Xorg.0.log de command not found. vou faze-lo! []s

qualquer comando cuja saída seja "command not found" então o caminho do comando não está na sua variável PATH pelo menos como root deve rodar a não ser que o comando não esteja instalado no sistema e isso é ruim, porque são comandos basico que estou passando. Para localizar o caminho digite type, exemplo:
@debian-br-cdd:~$ type grep
grep is /bin/grep

No caso do poste anterior o comando Tail não foi encontrado e não a log do Xorg :roll:

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS