Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
É normal o Xine consumir muito recurso da CPU? - RESOLVIDO
05/09/2006, 09:41
Resposta: #1
É normal o Xine consumir muito recurso da CPU? - RESOLVIDO
Instalei o Debian Etch, Gnome, todos os Codecs para ouvir música e assistir filmes. Aí instalei o Xine-ui e fui assistir a um Vídeo Divx. O monitor do sistema acusa 34% de uso da CPU! :shock:

No Ubuntu Dapper que é considerado muito mais pesado, ele utiliza 9%!

O que pode estar errado? O Etch não habilita o DMA da leitora por padrão?

Outra coisa, o som não está sincronizado com a imagem, isso vale para os outros players também. Como o Totem e o Mplayer.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/09/2006, 11:26
Resposta: #2
 
galactus,

Só para efeito comparativo. Acabei de rodar o mplayer com um vídeo divx e ele utilizou em média 7% de um Pentium 4 3Ghz. Qual o seu processador?

Se não me engano, o hdparm não vem instalado (muito menos ativado). Tente um apt-get install hdparm e depois hdparm -d1 -k1 /dev/hda. Substituindo /dev/hda pelo seu hd Lingua

Volte e poste os resultados Piscada
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/09/2006, 11:41
Resposta: #3
 
Meu caro Fernando, a minha modesta máquina é um Atlhon XP 2600, numa Abit NF7-S2 com 1GB de RAM e uma Geforce FX5200 com 128MB.

Vou instalar e configurar o hdparm. Depois posto os resultados.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/09/2006, 15:58
Resposta: #4
 
Instalei o hdparm e alterei os parâmetros dele. Melhora ínfima no xine. Agora consome 31%. No Mplayer continua na casa dos 37%. A sincronização do som foi resolvida.

algo definitivamemte não está correto, o Monitor do sistema e o Gnome-panel estão dando vários erros, precisando ser reiniciados.

Obrigado pela ajuda.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/09/2006, 16:41
Resposta: #5
 
galactus,

Nas preferências do Mplayer você pode escolher qual driver você deseja usar para som e vídeo. Qual você está usando?

Outra coisa, rode o xine ou mplayer com o comando top rodando em um terminal ao lado e verifique se realmente são eles que estão consumindo tanto o cpu.

Fernando.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/09/2006, 17:17
Resposta: #6
 
Estou usando o ALSA para o som e o xv para vídeo.


E o consumidor de recursos é o Xorg!!!!

Com uma média de 25% de uso da CPU entre os três players, Xine, totem, Mplayer.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/09/2006, 17:34
Resposta: #7
 
galactus,

É possível você postar seu arquivo de configuração do Xorg?

Não posso garantir nada, mas já vi casos em que o Xorg utilizava muito o CPU por causa de configuração errada, principalmente no driver da placa de vídeo.

Fernando.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/09/2006, 20:58
Resposta: #8
 
Fernando, como disse acima a minha placa de vídeo é uma Geforce FX 5200, uso o driver do Xorg mesmo, o "nv". Notei que as taxas de atualizações não estão corretas. Mas vou aguardar o seu diagnóstico! :wink:

Há sim, o monitor é LCD de 17 polegadas da LG, o L1750S.

Aqui vai o meu Xorg.conf :

Código:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
    FontPath    "/usr/share/fonts/X11/misc"
    FontPath    "/usr/X11R6/lib/X11/fonts/misc"
    FontPath    "/usr/share/fonts/X11/cyrillic"
    FontPath    "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath    "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath    "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath    "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath    "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath    "/usr/share/fonts/X11/Type1"
    FontPath    "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath    "/usr/share/fonts/X11/100dpi"
    FontPath    "/usr/X11R6/lib/X11/fonts/100dpi"
    FontPath    "/usr/share/fonts/X11/75dpi"
    FontPath    "/usr/X11R6/lib/X11/fonts/75dpi"
    # path to defoma fonts
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load    "i2c"
    Load    "bitmap"
    Load    "ddc"
    Load    "dri"
    Load    "extmod"
    Load    "freetype"
    Load    "glx"
    Load    "int10"
    Load    "type1"
    Load    "vbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "abnt2"
    Option        "XkbLayout"    "br"
    Option        "XkbVariant"    "abnt2"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/input/mice"
    Option        "Protocol"        "ExplorerPS/2"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "Device"
    Identifier    "NVIDIA Corporation NV34 [GeForce FX 5200]"
    Driver        "nv"
    BusID        "PCI:1:0:0"
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    Option        "DPMS"
    HorizSync    28-64
    VertRefresh    43-60
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "NVIDIA Corporation NV34 [GeForce FX 5200]"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection "Display"
        Depth        1
        Modes        "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        4
        Modes        "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        8
        Modes        "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        15
        Modes        "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        16
        Modes        "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "DRI"
    Mode    0666
EndSection
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/09/2006, 21:40
Resposta: #9
 
Ae blz fernando so gostaria de saber o q eh o hdparm nao querendo se intrometer na resoluça do problema do galactus flw

[Imagem: banner_user.png]
[Imagem: 1819-52002.png]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/09/2006, 22:04
Resposta: #10
 
Flaviodbz Escreveu:Ae blz fernando so gostaria de saber o q eh o hdparm nao querendo se intrometer na resoluça do problema do galactus flw

O hdparm habilita o DMA, entre outras pequenas coisas que ajudam no desempenho do HD e de leitoras de CD/DVD.

O termo DMA é um acrônimo para a expressão em inglês Direct memory access. O DMA permite que certos dispositivos de hardware em um computador acessem a memória do sistema para leitura e escrita independentemente da CPU. Muitos sistemas utilizam DMA, incluindo controladores de disco, placas gráficas, de rede ou de som.

O Ubuntu (6.06), SUSE, Mandriva e o Kurumin (das distro que já usei e conheço) procuram habilitar o hdparm por padrão. Com isso a CPU não fica sobrecarregada durante a leitura dos dispositivos.

Mais sobre o hdparm em:

http://www.guiadohardware.net/ebooks/linux/50.html

http://www.vivaolinux.com.br/artigos/ve ... odigo=1149

E já ía me esquecendo meu caro colega, lembre-se, o "man" é seu amigo! :wink:

man hdparm
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/09/2006, 23:14
Resposta: #11
 
galactus,

Eu apostaria algumas fichas (mas não todas) de que se você instalar o driver da nvidia (aquele fechado, disponível no site da nvidia) você resolveria esse problema. Eu sinceramente nunca li muito sobre esse driver da nv, mas acho que ele pode estar causando esse uso excessivo do cpu.

Fernando.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/09/2006, 23:57
Resposta: #12
 
Tá certo, vou tentar isso. Depois eu posto o resultado, também vou alterar as taxas de atualização.

Té+
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
06/09/2006, 09:05
Resposta: #13
 
Bom, agora o galho é o seguinte. O instalador do Driver da Nvidia se recusa a compilar o módulo do kernel porque a versão do GCC não é a mesma. Já instalei a versão 4.0, mas é necessário mudar o path do gcc antes de começar a usar este instalador. E agora? Como faço isso?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
06/09/2006, 23:34
Resposta: #14
 
Você tem duas opções galactus:

1) Baixar um kernel que foi compilado com gcc 4.0 (ou compilar o seu).

2) Instalar dessa outra maneira: http://www.forumdebian.com.br/post-920.html#920
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
07/09/2006, 11:24
Resposta: #15
 
Fernando, acabei fazendo um pouco de cada coisa que você falou. Muitos erros de depências. Parecia um parto para instalar o Driver da NVidia. Mas acabei instalando o Kernel 2.6.17.2 e depois rodei o instalador do driver da Nvidia. Deu erro mas foi!

Reiniciei o sistema e está funcionando tudo bem até agora, o consumo da CPU foi reduzido drasticamente, agora fica em torno de 12%, um pouco mais um pouco menos, fica variando um pouco. Com o novo kernel o Etch ficou bem mais esperto.

Será que até o lançamento final do Etch eles arruman uma maneira mais simples de instalar o driver da Nvidia?

Obrigado pela ajuda!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS