Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Qemu + Kqemu - Como usar no debian?
28/09/2006, 19:23
Resposta: #16
 
kra o problema eh justamente esse nao consegui pingar da minha maquina virtual para a fisica ou ao contrario tb

apesar de que vou tentar tb utilizando as 2 maquinas virtuais tb

[Imagem: banner_user.png]
[Imagem: 1819-52002.png]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/10/2006, 16:34
Resposta: #17
 
vou instalar aqui uma maquina virtual com linux, porque a que tenho aqui é com windows e utiliza o samba e neste seu caso a rede é outra forma. depois posto aqui.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/10/2006, 16:05
Resposta: #18
 
consegui finalmente consegui pingar a maquina fisica na virtual e vice-versa tive q fazer era restarta a placa de rede ja q os ips das maquinas ja estavam configurados o q me confundiu foi esse negocio de tun/tap la nao especificava em qual placa tinha q aparecer

ifconfig fisica
eth0 Encapsulamento do Link: Ethernet Endereço de HW 00:0A:E6:5B:1ESorrisãoE
inet end.: 172.16.0.2 Bcast:172.16.255.255 Masc:255.255.0.0
endereço inet6: fe80::20a:e6ff:fe5b:1ede/64 Escopo:Link
UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
RX packets:52342 errors:0 dropped:0 overruns:0 frame:0
TX packets:43731 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:1000
RX bytes:63404243 (60.4 MiB) TX bytes:3931108 (3.7 MiB)
IRQ:169 Endereço de E/S:0x9800

lo Encapsulamento do Link: Loopback Local
inet end.: 127.0.0.1 Masc:255.0.0.0
endereço inet6: ::1/128 Escopo:Máquina
UP LOOPBACKRUNNING MTU:16436 Métrica:1
RX packets:695 errors:0 dropped:0 overruns:0 frame:0
TX packets:695 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:0
RX bytes:44724 (43.6 KiB) TX bytes:44724 (43.6 KiB)

ppp0 Encapsulamento do Link: Protocolo Ponto-a-Ponto
inet end.: 201.27.11.93 P-a-P:200.100.11.72 Masc:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Métrica:1
RX packets:516 errors:0 dropped:0 overruns:0 frame:0
TX packets:525 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:3
RX bytes:272154 (265.7 KiB) TX bytes:45682 (44.6 KiB)

tun0 Encapsulamento do Link: Ethernet Endereço de HW 00:FF:10:2B:A6:17
inet end.: 172.16.0.1 Bcast:172.16.255.255 Masc:255.255.0.0
endereço inet6: fe80::2ff:10ff:fe2b:a617/64 Escopo:Link
UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
RX packets:12 errors:0 dropped:0 overruns:0 frame:0
TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:1000
RX bytes:1062 (1.0 KiB) TX bytes:1386 (1.3 KiB)

ja q eh maquina virtual entao nao tive como colar aki mas so precisei deixar na msm rede 172.16.0.3

so uma coisa me explica melhor esse negocio de tun/tap

[Imagem: banner_user.png]
[Imagem: 1819-52002.png]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/10/2006, 20:54
Resposta: #19
 
O TUN e TAP são driver para kernel para simular rede virtual.
Esse tun0 é o dispositivo de rede criado para a maquina virtual igualmente como o eth0 que é o dispositivo da placa de rede fisica.
Não sei se ficou claro.
TUN simula um dispositivo de rede ponto a ponto, enquanto o TAP simula um dispositivo de Ethernet.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/02/2007, 11:34
Resposta: #20
 
estou tento esse problema do gcc

[email protected]:~/qemu-0.9.0$ ./configure
WARNING: "gcc" looks like gcc 4.x
Looking for gcc 3.x
gcc 3.x not found!
QEMU is known to have problems when compiled with gcc 4.x
It is recommended that you use gcc 3.x to build QEMU
To use this compiler anyway, configure with --disable-gcc-check

Código:
[email protected]:~/qemu-0.9.0$ cat /proc/version
Linux version 2.6.18-3-486 (Debian 2.6.18-7) ([email protected]) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-20)) #1 Mon Dec 4 15:59:52 UTC 2006
Código:
[email protected]:~/qemu-0.9.0$ ls -l /usr/bin/gcc*
lrwxrwxrwx 1 root root      7 2007-02-08 16:10 /usr/bin/gcc -> gcc-4.1
-rwxr-xr-x 1 root root 183444 2006-12-10 14:46 /usr/bin/gcc-4.1
lrwxrwxrwx 1 root root     10 2007-02-08 16:10 /usr/bin/gccbug -> gccbug-4.1
-rwxr-xr-x 1 root root  16283 2006-12-10 14:44 /usr/bin/gccbug-4.1
-rwxr-xr-x 1 root root   2018 2006-12-20 02:02 /usr/bin/gccmakedep


acho que tenho que instalar a versão do gcc que o debian etch foi compilado ?? e qual que é ?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/02/2007, 16:09
Resposta: #21
 
não, vc tem que instalar o gcc 3.x que é necessário para compilar o qemu, instale essa versão 3 e depois troque os links simbolicos do gcc de 4.1 para apontar para o 3.x e tente novamente compilar.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
31/05/2007, 20:40
Resposta: #22
 
Fala, galera!!

Desculpem meu complexo de "pá de ouro", mas não queria criar outro tópico (ah, resolvi o problema do Kernel; vou lá no meu tópico dizer o que aconteceu =), mas eu não consigo instalar o módulo kqemu. Já fiz tudo que foi descrito durante este tópico, seguindo os links e tal, mas o módulo kqemu não é criado (module not found). =/
Citar esta mensagem em uma resposta
01/06/2007, 12:15
Resposta: #23
 
0625x86 Escreveu:Fala, galera!!

Desculpem meu complexo de "pá de ouro", mas não queria criar outro tópico (ah, resolvi o problema do Kernel; vou lá no meu tópico dizer o que aconteceu =), mas eu não consigo instalar o módulo kqemu. Já fiz tudo que foi descrito durante este tópico, seguindo os links e tal, mas o módulo kqemu não é criado (module not found). =/

Olá, dependendo da versão do seu kernel poderá estar instalando o pacote referente ao mesmo já pronto do modulo:
# uname -r
# aptitude search kqemu
p kqemu-common - Common files for the QEMU Accelerator modu
p kqemu-modules-2.6-486 - QEMU Accelerator modules for Linux 2.6 on
p kqemu-modules-2.6-686 - QEMU Accelerator modules for Linux 2.6 on
p kqemu-modules-2.6-686-bigmem - QEMU Accelerator modules for Linux 2.6 on
p kqemu-modules-2.6-k7 - QEMU Accelerator modules for Linux 2.6 on
p kqemu-modules-2.6.18-4-486 - QEMU Accelerator modules for Linux 2.6.18
p kqemu-modules-2.6.18-4-686 - QEMU Accelerator modules for Linux 2.6.18
p kqemu-modules-2.6.18-4-686-bigm - QEMU Accelerator modules for Linux 2.6.18
p kqemu-modules-2.6.18-4-k7 - QEMU Accelerator modules for Linux 2.6.18
p kqemu-source - Source for the QEMU Accelerator module

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS