Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Videos executados no Squeeze ficam lentos enquanto acesso qualquer menu
09/05/2011, 12:05 (Resposta editada pela última vez em: 10/05/2011 22:45 por burpera.)
Resposta: #1
Vídeo Videos executados no Squeeze ficam lentos enquanto acesso qualquer menu
Videos executados no Squeeze ficam lentos somente enquanto acesso qualquer menu, controle de volume ou abro alguma janela. O Compiz está habilitado e funcionando bem, a GPU está perfeitamente configurada, o único problema é este, testei no Totem e no Gnome Mplayer e acontece o mesmo problema, meu computador tem as seguintes configurações:

CPU: Intel® Pentium® Dual CPU T2390 @ 1.86GHz 1866.52MHz
Memoria: 3GB
VGA: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/05/2011, 22:55 (Resposta editada pela última vez em: 10/05/2011 23:12 por burpera.)
Resposta: #2
RE: Videos executados no Squeeze ficam lentos enquanto acesso qualquer menu
Realmente tem algo muito estranho acontecendo, pois eu testei alguns jogos como Ragnum Online e Return to Castle Wolfenstein, que não são pesados é verdade, mas o glxgears reporta baixo desempenho o que só percebo quando acesso os menus, por exemplo do gnome-mplayer ou do totem, eles travam o vídeo que está sendo executado e algumas vezes até o audio, testei como seria sem o xorg.conf e não mudou nada, tentei XAA, UXA, EXA e nada, vou postar alguns dados para alguma pessoa caridosa tentar me ajudar...
compiz --replace
Backend : ini
Integration : true
Profile : default
Adding plugins
Initializing core options...done
Initializing move options...done
Initializing resize options...done
Initializing place options...done
WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported! This is an application bug!
Initializing decoration options...done
Setting Update "mode"
Initializing splash options...done
compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
Initializing video options...done
Initializing imgjpeg options...done
Initializing mousepoll options...done
Initializing titleinfo options...done
Initializing workarounds options...done
inotify_add_watch: No such file or directory
Initializing kdecompat options...done
Initializing ezoom options...done
Initializing cube options...done
Initializing gnomecompat options...done
Initializing text options...done
Initializing svg options...done
Initializing obs options...done
Initializing annotate options...done
Initializing switcher options...done
Initializing 3d options...done
Initializing rotate options...done
Initializing loginout options...done
Initializing thumbnail options...done
Initializing scale options...done
Initializing shift options...done
WARNING: Application calling GLX 1.3 function "glXDestroyPixmap" when GLX 1.3 is not supported! This is an application bug!

glxgears
1262 frames in 5.0 seconds = 252.356 FPS
1547 frames in 5.0 seconds = 309.029 FPS
1515 frames in 5.0 seconds = 302.955 FPS
1397 frames in 5.0 seconds = 279.325 FPS
1391 frames in 5.0 seconds = 278.039 FPS
1585 frames in 5.0 seconds = 316.970 FPS
1464 frames in 5.0 seconds = 292.784 FPS
1375 frames in 5.0 seconds = 274.945 FPS
1511 frames in 5.0 seconds = 302.165 FPS
1515 frames in 5.0 seconds = 302.932 FPS
1418 frames in 5.0 seconds = 283.519 FPS
1355 frames in 5.0 seconds = 270.894 FPS
1592 frames in 5.0 seconds = 318.348 FPS
^C

cat /etc/X11/xorg.conf
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
#InputDevice "Mouse0" "CorePointer"
InputDevice "Synaptics Touchpad"
#InputDevice "Keyboard0" "CoreKeyboard"
Option "AIGLX" "true"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "built-ins"
EndSection

Section "Module"
Load "dri"
Load "dri2"
Load "extmod"
Load "glx"
Load "record"
Load "dbe"
#Load "synaptics"
EndSection

#Section "InputDevice"
# Identifier "Keyboard0"
# Driver "kbd"
# Option "XkbRules" "xorg"
# Option "XkbModel" "abnt2"
# Option "XkbLayout" "br"
#EndSection

#Section "InputDevice"
# Identifier "Mouse0"
# Driver "mouse"
# Option "Protocol" "auto"
# Option "Device" "/dev/input/mice"
# Option "ZAxisMapping" "4 5 6 7"
#EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "1"
Option "SHMConfig" "true"
EndSection

Section "Monitor"
Identifier "Monitor0"
Option "DPMS"
HorizSync 28-72
VertRefresh 43-60
# or it:
# VertRefresh 43-72
EndSection

Section "DRI"
Group "video"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" "false" # [<bool>]
#Option "HWCursor" "true" # [<bool>]
#Option "ColorKey" # <i>
#Option "CacheLines" # <i>
#Option "Dac6Bit" # [<bool>]
Option "DRI" "true" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # <i>
#Option "PageFlip" # [<bool>]
Option "Tiling" "false"
Option "XAANoOffscreenPixmaps" "true"
Option "AccelMethod" "UXA" # UXA, EXA, XAA
#Option "MigrationHeuristic" "greedy" # optional, may improve performance but introduce visible artifacts
Identifier "Card0"
Driver "intel"
VendorName "Intel Corporation"
BoardName "Mobile GM965/GL960 Integrated Graphics Controller"
BusID "PCI:0:2:0"
VideoRam 263168
EndSection

Section "Screen"
Identifier "Screen0"
SubSection "Display"
Depth 24
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

em /etc/default/grub eu uso esses parâmetros para o kernel:
GRUB_CMDLINE_LINUX_DEFAULT="loglevel=0"
GRUB_CMDLINE_LINUX="splash gfxpayload=keep i915.modeset=1"

No Debian Lenny o desempenho do vídeo reportado pelo glxgears passava de 3000, no Ubuntu Lucid 2500
Outro detalhe é que tive que fazer o downgrade de xserver-xorg-video-intel, para sanar o bug que faz a tela piscar e não deixa o monitor "dormir". No Ubuntu Lucid isso não prejudicou o desempenho.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/05/2011, 23:15
Resposta: #3
RE: Videos executados no Squeeze ficam lentos enquanto acesso qualquer menu
Olá colega. Realmente 318.348 FPS é muito baixo para exigir uma boa performance da placa de vídeo. Deveria alcançar acredito no mínimo 1800 FPS. Qual a resposta do comando:
lspci | grep VGA
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/05/2011, 23:20 (Resposta editada pela última vez em: 10/05/2011 23:23 por burpera.)
Resposta: #4
RE: Videos executados no Squeeze ficam lentos enquanto acesso qualquer menu
Eu falei dos jogos e esqueci de dizer que eles tem um desempenho normal apesar do glxgears reportar baixo desempenho, assim também é com todo o resto do sistema, o desempenho é satisfatório... ...mistério!!!
lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/05/2011, 23:36
Resposta: #5
RE: Videos executados no Squeeze ficam lentos enquanto acesso qualquer menu
Desculpe uma solução parcial mas é um caminho a ser pensado. Infelizmente não tenho experiência com essa placa mas segundo o que foi reportado no link abaixo "não está com suporte 3D". A dica é visitar a página proprietária do driver e tentar baixar e uma compilação.
http://www.vivaolinux.com.br/topico/Perg...eo-e-Beryl
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/05/2011, 09:52 (Resposta editada pela última vez em: 11/05/2011 09:57 por burpera.)
Resposta: #6
RE: Videos executados no Squeeze ficam lentos enquanto acesso qualquer menu
GNU matador de leoes, está com suporte 3D sim, pois o Compiz está executando e jogos opengl tbm...

o estranho é que usando a mesma configuração com o Ubuntu abrir menus não interfere na execução de videos.

veja:

glxinfo | grep rendering
direct rendering: Yes

glxinfo | grep glx
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:

glxinfo | grep renderer
OpenGL renderer string: Mesa DRI Intel® 965GM GEM 20091221 2009Q4 x86/MMX/SSE2
Na saída do compiz é relatado isso:

WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported! This is an application bug!

Será que é porque eu estou utilizando um driver mais antigo que o da distro? Isso poderia provocar esses "distúrbios"?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/05/2011, 10:23
Resposta: #7
RE: Videos executados no Squeeze ficam lentos enquanto acesso qualquer menu
O que responde
glxinfo | grep rendering
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/05/2011, 20:45
Resposta: #8
RE: Videos executados no Squeeze ficam lentos enquanto acesso qualquer menu
Responde se o GLX (opengl) está funcionando, ou seja rendering = executando, direct rendering = execução/contrução direta!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/05/2011, 22:16
Resposta: #9
RE: Videos executados no Squeeze ficam lentos enquanto acesso qualquer menu
A resposta deveria ser "direct rendering: Yes"
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/05/2011, 02:33 (Resposta editada pela última vez em: 12/05/2011 02:40 por burpera.)
Resposta: #10
RE: Videos executados no Squeeze ficam lentos enquanto acesso qualquer menu
Desculpe mesmo, eu estava meio distraido e não havia entendido a sua pergunta que era uma pergunta bem direta por sinal, hehehehe!

Então...

E a resposta foi esta ao digitar o comando, eu já havia postado, leia os posts anteriores, mais precisamente a resposta #6
ou seja:

glxinfo | grep rendering
direct rendering: Yes
Acredito que o problema não seja configuração, mas algum bug de software, o problema é descobrir o que, o xserver? Estou dizendo isto, pois acredito que todas as configurações estão corretas, pois no Ubuntu com exatamente as mesmas configurações o problema não ocorre...

...o que você acha?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/05/2011, 08:25
Resposta: #11
RE: Videos executados no Squeeze ficam lentos enquanto acesso qualquer menu
(12/05/2011 02:33)burpera Escreveu:  Desculpe mesmo, eu estava meio distraido.....
Então...

Distraido estava eu que não observei que ja tinhas postado o comando rssss


Citar:...pois no Ubuntu com exatamente as mesmas configurações o problema não ocorre...

...o que você acha?
Resposta difícil. Só você sabe o que instalou ou modificou em seu computador(se for o caso). De qualquer maneira não deixaria de tentar reinstalar o xserver-xorg.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/05/2011, 22:19
Resposta: #12
RE: Videos executados no Squeeze ficam lentos enquanto acesso qualquer menu
GNU matador de leoes, cara, você acredita que só tenho esse problema no Debian? No Ubuntu isso nunca aconteceu, isso é lamentável, pois gosto muito mais do Debian! Acho isso um pequeno mistério, instalei o Debian em outro computador, um Desktop com KDE ao invez do Gnome (meu favorito) que uso no meu Laptop, e acredita que o mesmo problema acontece, é alguma coisa com o modo que foi compilado algo talvez, provavelmente alguma coisa no xorg mesmo segundo a minha fértil imaginação.

Mas o que? Pensemos!

Vamos ver se alguma alma caridosa passa por aqui e nos dá uma resposta, ou a gente receba a iluminação para respondermos nós mesmos, o jeito é ter paciência! Qualquer novidade me fala oks? Se eu encontrar a resposta vou postar aqui! Abraço brother!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/06/2011, 01:48 (Resposta editada pela última vez em: 01/06/2011 01:50 por burpera.)
Resposta: #13
RE: Videos executados no Squeeze ficam lentos enquanto acesso qualquer menu
Para galera que quiser tentar ajudar, tem um detalhe intrigante... eu instalei algumas distribuições diferentes para matar a minha curiosidade (Suse 11.04, Debian Squeeze, Ubuntu Lucid Lynx) e apenas o Ubuntu não tem esse problema, ou seja, o Ubuntu tem algum "segredinho" que precisamos descobrir! Alegre
Outro detalhe é que testei também em hardwares totalmente diferentes e mesmo assim o Ubuntu foi o único que não apresentou o problema.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS